none
Creating Local Accounts with MDT and Config Mgr OSD: How to?

    Pergunta

  • We are using an MDT 2012 UDI deployment Task Sequence  in Config Mgr 2012. I have attempted to create and add a local account to the administrators group during deployment using both the default unattend.xml and a custom answer file. In both cases this setting is ignored. I am a little confused because other settings I specify in the answer file such as IE home page are preserved after deployment, but the local account is never created.

    Is this possible to do via the method I am describing or is there another method I must use?

    terça-feira, 3 de julho de 2012 19:21

Respostas

  • Hi,

    You can create a mdt vbscript / batch to create and add the user to a group. Either you use the script in the TS with a command line action or simply add an application step (if you create an app for this task)

    example addusers.cmd :

    net user /add useraccountname mypassword
    net localgroup administrators useraccountname /add

    regards,


    Revue du Geek | Déployer Windows 7 avec MDT 2010

    • Marcado como Resposta BryanCP quinta-feira, 5 de julho de 2012 15:36
    terça-feira, 3 de julho de 2012 20:56

Todas as Respostas

  • Hi,

    You can create a mdt vbscript / batch to create and add the user to a group. Either you use the script in the TS with a command line action or simply add an application step (if you create an app for this task)

    example addusers.cmd :

    net user /add useraccountname mypassword
    net localgroup administrators useraccountname /add

    regards,


    Revue du Geek | Déployer Windows 7 avec MDT 2010

    • Marcado como Resposta BryanCP quinta-feira, 5 de julho de 2012 15:36
    terça-feira, 3 de julho de 2012 20:56
  • I could be wrong but I was looking through my unattend.xml via the system image manager and I think that when I set the admin password, the account becomes active.  I did that here:

    7. oobe\ms-windows-shell-setup_neutral \UserAccounts\LocalAccount\AdministratorPassword

    The fact that the admin account is active on the machine supports the theory because I'm not adding the account in any other way.  -It is possible that I activated it long ago when I first build the WIM though.

    terça-feira, 3 de julho de 2012 22:26
  • Thanks Yannick, worked like a charm.
    quinta-feira, 5 de julho de 2012 15:36