none
Erro ao dar o deploy.

    Pergunta

  • Pessoal, to com uma bronca aqui ao dar o deploy no SSRS 2008. O que acontece é o seguinte:

    quando eu dou o deploy no relatório, é mostrado a seguinte mensagem:

    The specified report server URL http://andre-pc/Reports could not be found. Verify the sintax of the URL and that the report server exists.

    Lembrando que eu fui ao Configuration Manager do reporting services, peguei a URL, e coloquei nas propiedades, exatamente do jeito que está.

    Outro procedimento que tentei foi dar o drop nas tabelas do Report Service e recriá-las.

    Quem puder ajudar, agradeço de desde já.

    Atc,

    André Machado

    sexta-feira, 2 de março de 2012 13:10

Respostas

  • No solution Explorer do BIDS, clica com o botão direito no projeto e depois vai em propriedades ou properties se tiver em ingles. Verifica se o Target Server Version está o mesmo do ReportServer instalado.

    Ou seja, não adianta você ter instalado o SQL Server 2008R2 mas o Target Server Version tá SQL Server 2003.


    Rodrigo Ataíde.

    • Marcado como Resposta Andre_Machado segunda-feira, 5 de março de 2012 12:16
    sexta-feira, 2 de março de 2012 19:29

Todas as Respostas

  • Bom dia Andre,

    a Url está certa, porém no final no lugar de reports, tem que estar a informação que tiver em virtual directory. Como segue imagem abaixo.


    Rodrigo Ataíde.

    sexta-feira, 2 de março de 2012 13:21
  • Rodrigo,

    acontece que eu estou colocando igual ao que está no Virtual Directory.

    Virtual Directory: Reports

    já tentei também colocar localhost em vez do nome do pc na URL.

    http://andre-pc/Reports


    sexta-feira, 2 de março de 2012 13:51
  • André vc verificou se é a porta? Se for a porta 80, não precisa especificar, mas se porta estiver especificado diferente da porta 80 vc precisa colocar.

    Ex. http://andre-pc:8080/Reports

    Abs.


    Eduardo Gomes - http://www.h1solucoes.com.br - Twitter: @edugp_sp

    sexta-feira, 2 de março de 2012 16:09
  • Eduardo,

    Já tinha colocado a porta 80 e mesmo assim assim não funcionou.

    sexta-feira, 2 de março de 2012 17:56
  • Ok Andre,

    Tente acessar com http://nomedoservidor/reportserver.


    Rodrigo Ataíde.

    sexta-feira, 2 de março de 2012 18:06
  • Rodrigo,

    pelo navegador eu consigo acessar normalmente, criar pastas, permissões...

    ele dá erro apenas na hora de dar o deploy.

    sexta-feira, 2 de março de 2012 18:20
  • Andre,

    O usuário que você está criando o relatório e tentando dar o deploy tem acesso no virtual directory, certo?


    Rodrigo Ataíde.

    sexta-feira, 2 de março de 2012 18:29
  • Tem sim, é o administrador.
    sexta-feira, 2 de março de 2012 19:12
  • No solution Explorer do BIDS, clica com o botão direito no projeto e depois vai em propriedades ou properties se tiver em ingles. Verifica se o Target Server Version está o mesmo do ReportServer instalado.

    Ou seja, não adianta você ter instalado o SQL Server 2008R2 mas o Target Server Version tá SQL Server 2003.


    Rodrigo Ataíde.

    • Marcado como Resposta Andre_Machado segunda-feira, 5 de março de 2012 12:16
    sexta-feira, 2 de março de 2012 19:29
  • funcinou, valeu Rodrigo
    segunda-feira, 5 de março de 2012 12:16
  • De nada Andre,

    Precisando só avisar.


    Rodrigo Ataíde.

    segunda-feira, 5 de março de 2012 14:56