none
MAP 5.5 Problem with connection and collection status

    Pergunta

  • Question 01: MAP 5.5 not inventory with Windows 2003 Server with ISA 2006.

    I have the MAP 5.5 and despite having followed all requirements for their operation (WMI, Remote Registry enabled), the same can not connect with Windows Server 2003 with ISA 2006 installed, not connected the inventory information showing where the error "Failed - Other Reasons ". How to solve the problem.

    Question 02: MAP 5.5 not inventory with Ubuntu, Fedora 6, CentOS 5

    Same error "Failed - Other Reasons ". How to solver the problem.

    Question 03: On screen - Status: The gathering of key performance metrics is running

    I have 26 machines where only 2 had connection problems (see question 01) but the status report that a successful connection 11 and 15 are with problems.

    Another problem is the collection status who do not report success just not applicable. not understand why.


    Connection Status

    Computer currently encountering errors collecting some performance counter: 15

    Collection Status
    WMI e Registry    not applicable = 24
    But dont have any Success

    Do not really understand the meaning and wonder if there are logs that might better inform the problem of connection


    Gorki P. Pinheiro
    segunda-feira, 28 de fevereiro de 2011 14:05

Respostas

  • Hi Gorki,

    I’ve restated your questions as I understood them, if my understanding is incorrect please let me know.

     

    Q1: MAP 5.5 will not inventory a Windows Server 2003 machine with ISA 2006 installed.

    Use WBEMTEST as shown in this video to check your WMI connectivity.  You can also visit the TechNet library (WMI Isn’t Working!) for more tips regarding troubleshooting WMI connectivity.  If you would like to post any errors you receive, we can try to help determine the appropriate next steps.

     

    Q2: MAP 5.5 is not inventorying the Ubuntu, Fedora 6, CentOS 5 linux machines.

    Do you have ssh keys enabled?  If so, MAP does not currently support this.

     

    Q3: Multiple questions regarding performance data gathering.

    1: Only 2 of the 26 machines were known to have connectivity problems, but while the performance metrics was running, it reported a successful connection on 11 machines, and 15 machines had problems.

    Check the last tab of the performance report for the details on what happened. It’s possible that you had some computers that failed one or more 5 minute cycles of performance collection, but succeeded on other cycles.  The last tab of the performance report will show this detail.

     

    2. In the collection status, those machines that did not report success showed N/A.

    We need more information as to where you are seeing the N/A.  For example, WMI will show N/A on a linux machine and SSH will show N/A on a Windows machine.

     

    3. Don’t understand what it means when the collection status is not showing as successful and WMI registry is showing 24 as N/A

    If WMI fails, or if ssh succeeds, then Registry won’t be attempted (and thus is marked as N/A).

     

    Thanks,

    Michael Switzer

    • Marcado como Resposta Gorki Pinheiro quarta-feira, 31 de agosto de 2011 14:31
    quarta-feira, 2 de março de 2011 20:05
    Moderador
  • ...

    SSH is enabled and i suposed that fedora, ubuntu and centOS not supported by MAP 5.5.

    ...

    PS.: It´s possible send picture by forum?

    Linux is supported by MAP, but only using SSH.  If you use SSH Keys to connect to your Linux machines, then MAP cannot connect to them.  Here is a useful article describing SSH Keys.

     

    https://wiki.archlinux.org/index.php/Using_SSH_Keys

     

    And it is not possible to post a picture in the forum, sorry.  Once your scan is complete you can look at the reports and get a better idea of what kind of problems came up during the run.  Here is a useful article that explains what the status messages mean.

     

    http://social.technet.microsoft.com/wiki/contents/articles/microsoft-assessment-and-planning-toolkit-inventory-status-messages.aspx

     

    If you still have issues or questions that you can't resolve, please post them and I will be happy to help you work through them :)

     

    Thanks,

    Michael Switzer

     

    quinta-feira, 3 de março de 2011 17:40
    Moderador
  • Dear Michael;

    Thanks for you answer.

    My schedule will finish in 07/03/2011 12:00am.

    I believe I can see the tab report of errors when the scan finished.

    SSH is enabled and i suposed that fedora, ubuntu and centOS not supported by MAP 5.5.

    When I take a print screen of MAP I'll return the picture and you will understand better what I am trying to say with success and error about WMI and Registry scan. awaiting image

    PS.: It´s possible send picture by forum?


    Gorki P. Pinheiro
    • Marcado como Resposta Gorki Pinheiro quarta-feira, 31 de agosto de 2011 14:30
    quarta-feira, 2 de março de 2011 20:25
  • Question 01: MAP 5.5 not inventory with Windows 2003 Server with ISA 2006.

    I have the MAP 5.5 and despite having followed all requirements for their operation (WMI, Remote Registry enabled), the same can not connect with Windows Server 2003 with ISA 2006 installed, not connected the inventory information showing where the error "Failed - Other Reasons ". How to solve the problem.

    Question 02: MAP 5.5 not inventory with Ubuntu, Fedora 6, CentOS 5

    Same error "Failed - Other Reasons ". How to solver the problem.

    Question 03: On screen - Status: The gathering of key performance metrics is running

    I have 26 machines where only 2 had connection problems (see question 01) but the status report that a successful connection 11 and 15 are with problems.

    Another problem is the collection status who do not report success just not applicable. not understand why.


    Connection Status

    Computer currently encountering errors collecting some performance counter: 15

    Collection Status
    WMI e Registry    not applicable = 24
    But dont have any Success

    Do not really understand the meaning and wonder if there are logs that might better inform the problem of connection

     


    Gorki P. Pinheiro
    Hi.. Did you get a response to this WMI collection status N/A question!? I'm running an assesment now but cant be sure it's capturing correctly
    • Marcado como Resposta Gorki Pinheiro quarta-feira, 31 de agosto de 2011 14:30
    quinta-feira, 9 de junho de 2011 12:29

Todas as Respostas

  • Hi Gorki,

    I’ve restated your questions as I understood them, if my understanding is incorrect please let me know.

     

    Q1: MAP 5.5 will not inventory a Windows Server 2003 machine with ISA 2006 installed.

    Use WBEMTEST as shown in this video to check your WMI connectivity.  You can also visit the TechNet library (WMI Isn’t Working!) for more tips regarding troubleshooting WMI connectivity.  If you would like to post any errors you receive, we can try to help determine the appropriate next steps.

     

    Q2: MAP 5.5 is not inventorying the Ubuntu, Fedora 6, CentOS 5 linux machines.

    Do you have ssh keys enabled?  If so, MAP does not currently support this.

     

    Q3: Multiple questions regarding performance data gathering.

    1: Only 2 of the 26 machines were known to have connectivity problems, but while the performance metrics was running, it reported a successful connection on 11 machines, and 15 machines had problems.

    Check the last tab of the performance report for the details on what happened. It’s possible that you had some computers that failed one or more 5 minute cycles of performance collection, but succeeded on other cycles.  The last tab of the performance report will show this detail.

     

    2. In the collection status, those machines that did not report success showed N/A.

    We need more information as to where you are seeing the N/A.  For example, WMI will show N/A on a linux machine and SSH will show N/A on a Windows machine.

     

    3. Don’t understand what it means when the collection status is not showing as successful and WMI registry is showing 24 as N/A

    If WMI fails, or if ssh succeeds, then Registry won’t be attempted (and thus is marked as N/A).

     

    Thanks,

    Michael Switzer

    • Marcado como Resposta Gorki Pinheiro quarta-feira, 31 de agosto de 2011 14:31
    quarta-feira, 2 de março de 2011 20:05
    Moderador
  • Dear Michael;

    Thanks for you answer.

    My schedule will finish in 07/03/2011 12:00am.

    I believe I can see the tab report of errors when the scan finished.

    SSH is enabled and i suposed that fedora, ubuntu and centOS not supported by MAP 5.5.

    When I take a print screen of MAP I'll return the picture and you will understand better what I am trying to say with success and error about WMI and Registry scan. awaiting image

    PS.: It´s possible send picture by forum?


    Gorki P. Pinheiro
    • Marcado como Resposta Gorki Pinheiro quarta-feira, 31 de agosto de 2011 14:30
    quarta-feira, 2 de março de 2011 20:25
  • ...

    SSH is enabled and i suposed that fedora, ubuntu and centOS not supported by MAP 5.5.

    ...

    PS.: It´s possible send picture by forum?

    Linux is supported by MAP, but only using SSH.  If you use SSH Keys to connect to your Linux machines, then MAP cannot connect to them.  Here is a useful article describing SSH Keys.

     

    https://wiki.archlinux.org/index.php/Using_SSH_Keys

     

    And it is not possible to post a picture in the forum, sorry.  Once your scan is complete you can look at the reports and get a better idea of what kind of problems came up during the run.  Here is a useful article that explains what the status messages mean.

     

    http://social.technet.microsoft.com/wiki/contents/articles/microsoft-assessment-and-planning-toolkit-inventory-status-messages.aspx

     

    If you still have issues or questions that you can't resolve, please post them and I will be happy to help you work through them :)

     

    Thanks,

    Michael Switzer

     

    quinta-feira, 3 de março de 2011 17:40
    Moderador
  • Question 01: MAP 5.5 not inventory with Windows 2003 Server with ISA 2006.

    I have the MAP 5.5 and despite having followed all requirements for their operation (WMI, Remote Registry enabled), the same can not connect with Windows Server 2003 with ISA 2006 installed, not connected the inventory information showing where the error "Failed - Other Reasons ". How to solve the problem.

    Question 02: MAP 5.5 not inventory with Ubuntu, Fedora 6, CentOS 5

    Same error "Failed - Other Reasons ". How to solver the problem.

    Question 03: On screen - Status: The gathering of key performance metrics is running

    I have 26 machines where only 2 had connection problems (see question 01) but the status report that a successful connection 11 and 15 are with problems.

    Another problem is the collection status who do not report success just not applicable. not understand why.


    Connection Status

    Computer currently encountering errors collecting some performance counter: 15

    Collection Status
    WMI e Registry    not applicable = 24
    But dont have any Success

    Do not really understand the meaning and wonder if there are logs that might better inform the problem of connection

     


    Gorki P. Pinheiro
    Hi.. Did you get a response to this WMI collection status N/A question!? I'm running an assesment now but cant be sure it's capturing correctly
    • Marcado como Resposta Gorki Pinheiro quarta-feira, 31 de agosto de 2011 14:30
    quinta-feira, 9 de junho de 2011 12:29
  • In general, N/A applies to the fact that the particular collector technology does not apply to a machine.  For example, if there are a mix of Linux and Windows machines, then SSH will be “N/A” for the Windows machines and WMI and Registry will be “N/A” for Linux machine because those hosts don’t have that collector available.

    I understand that these numbers can be troubling when in fact everything is ok, and we are working on ways to improve this.  When it comes to performance collection, I recommend that you run a 1 hour collection as a smoke test and review the reports to make sure you are connecting to the machines you want and don’t have any significant failures.  It would be very frustrating to find out at the end of a multi-day or week run that MAP was unable to connect to many of the machines. Hope this helps.

    Thanks,

    Michael Switzer

    quinta-feira, 9 de junho de 2011 21:37
    Moderador
  • Dear Michael Switzer;

    First, thanks for you collaboration.

    Good observation about use SSH Key to connect internal servers, but it´s not available in my scenario, and i will analize next time. I know that it´s necessary the HAL installed in computers with linux plataform, but when i have problems in inventory, how the best way or metodology i use to finish jobs in mix enviroments Linux and Windows plataform.

    Manually enter data in reports?? How can i do this?

    Thanks;

    Regard;

    Gorki Pinheiro

     

     


    Gorki P. Pinheiro
    quarta-feira, 31 de agosto de 2011 14:30
  • To manual enter data in reports, simply open the Excel file and enter information like you would with any other spreadsheet.

     

    I’m afraid I don’t understand your question regarding how to finish jobs in mixed environments, can you restate the question or explain further?


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    sexta-feira, 2 de setembro de 2011 16:42
    Moderador