none
XML Web Services in HIS 2010

    Pergunta

  • Hi,

    Is it possible to expose TI Component definitions (.dll) as XMl Web services (.asmx) in HIS 2010 (Windows Initiated Processing) for access to/calling Host programs? In TIManager I only find choise "WCF Service". In the "Product Overview" white paper is says that XML Web Service should be possible in addition to WCF Service .

     

    segunda-feira, 23 de janeiro de 2012 11:59

Respostas

  • Hi Tor,

    In my case it has worked migrating HIS 2006 to HIS 2010 using the TIConverterTool but also new native HIS 2010 objects.

    Do I understand you correctly that you've upgraded the same box from 2009 to 2010 ? If this is the case I recommend you to setup a new server box, install than HIS 2010 RTM, configure TI Manager (REs) and SNA-Server (if needed) than install CU1 or CU2 (best would be CU2) and don't forget to reboot the server.

    I had several issues related to yours doing the migration from 2006 to 2010. In my case the issues were solved installing a new clean server.

    Best Regards,


    Steve Melan - BCEE My Blog : http://stevemelan.wordpress.com
    terça-feira, 24 de janeiro de 2012 10:24

Todas as Respostas

  • As WCF services can be configured to be backwards compatible to WS, we decided to forgo the inclusion of WS in TI Manager. I am not sure what the twiddly bits are to make WCF look like WS (maybe it is as simple as using BasicHttpBinding or something like that)...but a Bing search might bring it to light if no-one on here knows for sure.

     

    Rob

    segunda-feira, 23 de janeiro de 2012 16:29
    Moderador
  • Hi,

    HIS 2010 RTM doesn't support classic Webservices (asmx) but ... :-) I've opened a DCR at Microsoft to reimplement that feature in HIS 2010. That DCR is available in HIS 2010 CU1 and CU2 :-)

    The only thing that you need to do is to take that assembly (.dll), put it in a bin directory on your IIS. Manualy create the classic asmx file :

    <%@ WebService Class=“CICSLibrary.WebService.CICSInterface,CICSLibrary“ %>

    You don't even have to deploy the TI assembly to the TI Manager if you are using CU1 or CU2 :-)

    Best Regads,


    Steve Melan - BCEE My Blog : http://stevemelan.wordpress.com
    segunda-feira, 23 de janeiro de 2012 21:02
  • Hi Steve,

    Thanks for the quick reply. I've followed your instructions, added CU1 and manually created the asmx-file. It seems promising, but when I try to hit the asmx-file I get:

    Cannot serialize member Microsoft.HostIntegration.TI.BaseRemoteEnvironment.VendorREEntries of type System.Collections.Hashtable, because it implements IDictionary.

    The DLL is created in VS2010 w/HIS 2010 + CU1.

    Any Idea what might be the reason to the error or how to get around it? I am working on an upgraded server (2009->2010) and need to run the services as XML Web Services to avoid modifications to the clients of the services when we upgrade the prod. server.

    Best Regards,

    Tor Korten

    terça-feira, 24 de janeiro de 2012 08:52
  • Hi Tor,

    In my case it has worked migrating HIS 2006 to HIS 2010 using the TIConverterTool but also new native HIS 2010 objects.

    Do I understand you correctly that you've upgraded the same box from 2009 to 2010 ? If this is the case I recommend you to setup a new server box, install than HIS 2010 RTM, configure TI Manager (REs) and SNA-Server (if needed) than install CU1 or CU2 (best would be CU2) and don't forget to reboot the server.

    I had several issues related to yours doing the migration from 2006 to 2010. In my case the issues were solved installing a new clean server.

    Best Regards,


    Steve Melan - BCEE My Blog : http://stevemelan.wordpress.com
    terça-feira, 24 de janeiro de 2012 10:24
  • Hi Tor,

    I'd like to inform you that I could reproduce the issue you are seeing and that I've opened a case at Microsoft to fix that "Bug" :-)

    As soon as I get some feedback and the fix I will let you know !

    Best Regards,


    Steve Melan - BCEE My Blog : http://stevemelan.wordpress.com

    terça-feira, 14 de fevereiro de 2012 19:12
  • Hi Tor,

    The bug is fixed ! :-)

    The fix will be included in the next Cumulative Update Pack !

    Best Regards,

    Steve


    Steve Melan - BCEE My Blog : http://stevemelan.wordpress.com

    sexta-feira, 17 de fevereiro de 2012 09:29