none
How to pass repeating field data from infopath to sql data base through web service

Respostas

  • Hi sireeshab,

    Given that when you have a repeating table or section you see the xml data in a format similar to this:

      <my:group3>
       <my:field6>a</my:field6>
       <my:field7>b</my:field7>
       <my:field8>c</my:field8>
      </my:group3>

    And with a repeating field you will see the xml look like this:

      <my:Field7>big</my:Field7>
      <my:Field7>small</my:Field7>
      <my:Field7>large</my:Field7>
      <my:Field7>tiny</my:Field7>

    What you may need to do is wrap that repeating field within a group so that its formatted similarly to a repeating table.  Next you will have to look at how you are sending that data.  Are you sending as field for field or are you sending the entire xml subtree - however this may only pass only the first item.  You may have to see what the different options are in the data connection when setting it up to the web service.


    Regards, Aaron Suoja - Microsoft Online Community Support

    terça-feira, 26 de junho de 2012 14:26

Todas as Respostas

  • Hi,

    Thank you for your post.

    I'm trying to involve someone familiar with this topic to further look at this issue. There might be some time delay. Appreciate your patience.

    Thanks & Regards,
    Emir


    Emir Liu

    TechNet Community Support

    segunda-feira, 18 de junho de 2012 09:13
  • Hi sireeshab,

    Given that when you have a repeating table or section you see the xml data in a format similar to this:

      <my:group3>
       <my:field6>a</my:field6>
       <my:field7>b</my:field7>
       <my:field8>c</my:field8>
      </my:group3>

    And with a repeating field you will see the xml look like this:

      <my:Field7>big</my:Field7>
      <my:Field7>small</my:Field7>
      <my:Field7>large</my:Field7>
      <my:Field7>tiny</my:Field7>

    What you may need to do is wrap that repeating field within a group so that its formatted similarly to a repeating table.  Next you will have to look at how you are sending that data.  Are you sending as field for field or are you sending the entire xml subtree - however this may only pass only the first item.  You may have to see what the different options are in the data connection when setting it up to the web service.


    Regards, Aaron Suoja - Microsoft Online Community Support

    terça-feira, 26 de junho de 2012 14:26