none
The adapter "DB2" MVS Zos raised an error message SQLSTATE:HY000, SQLCODE -379

    Întrebare

  • I am new to Biztalk 2010 and the DB2 Adapter for MVS.  I am trying to execute a stored procedure that returns a result set from 4 tables and am getting the followning error:

    {4A399F90-E991-426A-A4CE-CD5364FDDA0A}
    {CBCEEF5B-4E84-4BED-BE72-CBE3F69AFCD4}
    DB2

    DB2:P1-DB2-DB2T:5203/DB2T

    DB2REQRESP

    An internal network library error has occurred. A network level syntax error has occurred. SQLSTATE:HY000, SQLCODE -379         

    Can you please help me understand this error?  I am also creating my DB2 schema using the Add Adapter Wizard and notice my result set is an 'any'.  Is this what I should expect or is this because I am still not connecting properly?  Thanks in advance for any help you can give me.

    1 martie 2012 20:02

Răspunsuri

  • So you are saying that the generated schema includes an xs:any element in it? This sounds like the schema is generating incorrectly. When you are executing the receive location, is this calling the stored procedure too or just doing a select of the data?

    Your error sounds like a problem with connectivity. I would just make sure all the connection information is correct such as being sure the passwords are still on the port. If you imported a binding file the password will not be included so you would need to retype the password.

    Thanks,


    If this answers your question, please use the "Answer" button to say so | Ben Cline

    5 martie 2012 21:57
    Moderator

Toate mesajele

  • Hi,

    The SQLCODE -379 error indicates that an undefined column or parameter name was detected (see the IBM SQL Messages and Codes book). I suggest to look at the stored procedure and check whether it executes.

    HTH

    Steef-Jan Wiggers

    MVP & MCTS BizTalk Server 2010

    http://soa-thoughts.blogspot.com/ | @SteefJan

    If this answers your question please mark it accordingly


    BizTalk

    5 martie 2012 04:57
    Moderator
  • The stored procedure does execute outside Biztalk with no errors.  I can also past the sql into a receive location configuration and get back data.  I'ts only when I try to execute the stored procedure that I get this error.  We are using DB2 version 9 and Biztalk 2010.

    5 martie 2012 17:43
  • So you are saying that the generated schema includes an xs:any element in it? This sounds like the schema is generating incorrectly. When you are executing the receive location, is this calling the stored procedure too or just doing a select of the data?

    Your error sounds like a problem with connectivity. I would just make sure all the connection information is correct such as being sure the passwords are still on the port. If you imported a binding file the password will not be included so you would need to retype the password.

    Thanks,


    If this answers your question, please use the "Answer" button to say so | Ben Cline

    5 martie 2012 21:57
    Moderator