none
Newly installed Exchange 2010 not accepting incoming port 25

    Întrebare

  • Remote COnnectivity analyzer result...

     

    Testing Inbound SMTP Mail flow for domain and@avconti.info
      Failed to test inbound SMTP mail flow.
     
    Test Steps
     
    Attempting to retrieve DNS MX records for domain avconti.info
      One or more MX records were successfully retrieved from DNS.
     
    Additional Details
      MX Records Host mail.avconti.info, Preference 0
    Testing Mail Exchanger mail.avconti.info.
      One or more SMTP tests failed for this Mail Exchanger.
     
    Test Steps
     
    Attempting to resolve the host name mail.avconti.info in DNS.
      Host successfully resolved
     
    Additional Details
      IP(s) returned: 78.133.17.200
    Testing TCP Port 25 on host mail.avconti.info to ensure it is listening and open.
      The specified port is either blocked, not listening, or not producing the expected response.
       <label for="testSelectWizard_ctl12_ctl06_ctl01_ctl01_tmmArrow">Tell me more about this issue and how to resolve it</label>
     
    Additional Details
      A network error occurred while communicating with remote host
    Exception details:
    Message: A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond 78.133.17.200:25
    Type: System.Net.Sockets.SocketException
    Stack trace:
    at System.Net.Sockets.TcpClient.Connect(String hostname, Int32 port)
    at Microsoft.Exchange.Tools.ExRca.Tests.TcpPortTest.PerformTestReally()
    Testing Inbound SMTP Mail flow for domain and@avconti.info
      Failed to test inbound SMTP mail flow.
     
    Test Steps
     
    Attempting to retrieve DNS MX records for domain avconti.info
      One or more MX records were successfully retrieved from DNS.
     
    Additional Details
      MX Records Host mail.avconti.info, Preference 0
    Testing Mail Exchanger mail.avconti.info.
      One or more SMTP tests failed for this Mail Exchanger.
     
    Test Steps
     
    Attempting to resolve the host name mail.avconti.info in DNS.
      Host successfully resolved
     
    Additional Details
      IP(s) returned: 78.133.17.200
    Testing TCP Port 25 on host mail.avconti.info to ensure it is listening and open.
      The specified port is either blocked, not listening, or not producing the expected response.
       <label for="testSelectWizard_ctl12_ctl06_ctl01_ctl01_tmmArrow">Tell me more about this issue and how to resolve it</label>
     
    Additional Details
      A network error occurred while communicating with remote host
    Exception details:
    Message: A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond 78.133.17.200:25
    Type: System.Net.Sockets.SocketException
    Stack trace:
    at System.Net.Sockets.TcpClient.Connect(String hostname, Int32 port)
    at Microsoft.Exchange.Tools.ExRca.Tests.TcpPortTest.PerformTestReally()
    Testing Inbound SMTP Mail flow for domain and@avconti.info
     Failed to test inbound SMTP mail flow.
     Test Steps
     Attempting to retrieve DNS MX records for domain avconti.info
     One or more MX records were successfully retrieved from DNS.
     Additional Details
     MX Records Host mail.avconti.info, Preference 0


    Testing Mail Exchanger mail.avconti.info.
     One or more SMTP tests failed for this Mail Exchanger.
     Test Steps
     Attempting to resolve the host name mail.avconti.info in DNS.
     Host successfully resolved
     Additional Details
     IP(s) returned: 78.133.17.200

    Testing TCP Port 25 on host mail.avconti.info to ensure it is listening and open.
     The specified port is either blocked, not listening, or not producing the expected response.
      Tell me more about this issue and how to resolve it
     Additional Details
     A network error occurred while communicating with remote host
    Exception details:
    Message: A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond 78.133.17.200:25
    Type: System.Net.Sockets.SocketException
    Stack trace:
    at System.Net.Sockets.TcpClient.Connect(String hostname, Int32 port)
    at Microsoft.Exchange.Tools.ExRca.Tests.TcpPortTest.PerformTestReally()

    ISP has repeatedly confirmed that Port 25 Incoming is open.

    Please help me find the cause of Exchange not accepting port 25 requests

    10 octombrie 2010 11:29

Toate mesajele

  • You say a newly installed Exchange server, did you have a previous one installed that was working?  Does the IP address 78.133.17.200 have a NAT translation in your firewall that maps to your newly installed Exchange server?  Is port 25 open on your firewall for this NAT translation?  You need both the port open and the NAT translation configured to get this to work.
    Tim Harrington - Catapult Systems - http://HowDoUC.blogspot.com
    10 octombrie 2010 14:08
  • Hello,

     

    no no previous one

    yes it have NAT translation and port 25 forwarded to exchange /DC server

    I have already posted this issue but unfortunately have not fixed it

    I want a way to determine where is the block point since when I forwarded port 80 it worked fine from an external internet connection.

     

    Only port 25 is giving me all the problems, and what makes me feel sad is that the ISP says that it is open.

    I do not give up however as my last resort I want you to tell me if there is any Exchange setting whch might block connections from an external connection. To test I am using telnet mail.avconti.info 25

     

    DO not try it now since I am on a dynamic IP and you will not get any response.

    I updated GODADDY IP with my external IP and set MX record to point to mail.avconti.info

     

    On my DNS server mail.avconti.info I have A record to point to the Exchange server but I have no MX record since it is at GODADDY  it should be enough like this right ?

    I checked almost anything  possible so if you have further new ideas pls suggest otherwise I will give up now :(

     

    I appreciate all feedback I got especially from my previous post since I learnt new things that before I never thought of.

     

    10 octombrie 2010 20:23
  •  

     

    a few other things to check

    1. telnet ExchangeInternalIP 25 from within your network is it working ?
    2. are you sure you have port 25 forwareded to your exchange
    3. Is the default gateway of your exchange server the firewall on which port forwarding was done ?
    4. if you go to EMC -> server confg -> hub transport -> default receive connector make sure you did not restrict smtp to a specific range of IPs


    Full time IT consultant since 1998 mainly on Exchange\ISA\AD MCSE NT4.0,2000/2003, CCNA MCITP: Enterprise Messaging Administrator 2007/2010 MCT since 2001
    10 octombrie 2010 21:23
  • A few other things...do you have AV client installed on the Exchange server?  If so, disable just to troubleshoot.  Also disable any local firewall on the server as well just to troubleshoot.
    Tim Harrington - Catapult Systems - http://HowDoUC.blogspot.com
    11 octombrie 2010 00:48
    1. telnet ExchangeInternalIP 25 from within your network is it working ? 
         yes it works internally
    1. are you sure you have port 25 forwareded to your exchange
         yes I have set it up on the dsl modem and in fact I have also port 80 forwarded to the same server which works fine
    1. Is the default gateway of your exchange server the firewall on which port forwarding was done ?
         yes the default gateway is the dsl modem
    1. if you go to EMC -> server confg -> hub transport -> default receive connector make sure you did not restrict smtp to a specific range of IPs

          No it is set to receive mail from ::  ffff etc....  and 0.0.0.0-255.255.255.255 ands under Permission Groups I have   ticked Anonymous users

     

    Also I just uninstalled the Anti-Virus and disbled Windows Firewall for the domain network. The Exchange server is running on the Server 2008 DC.

    As you have seen I have done many things to try to make it work and strangely enough it does not want to work

    11 octombrie 2010 04:48
  • well everything is setup just fine your way we have no reason to think the issue is not from the ISP since it is working internally and you have disabled any antivirus/firewall

     


    Full time IT consultant since 1998 mainly on Exchange\ISA\AD MCSE NT4.0,2000/2003, CCNA MCITP: Enterprise Messaging Administrator 2007/2010 MCT since 2001
    11 octombrie 2010 05:00
  • I am running into the same error for my virtual environment.  Did you ever figure this out?  My ISP is saying they arent blocking me either.  I turned off the firewall on all computers, and cisco r042 router.

    1 februarie 2012 20:11
  • try port 26 for test, there are few ISPs who blocks unless you buy a business internet. 
    Where Technology Meets Talent
    2 februarie 2012 03:43
  • Exchange dont allow anonymous mail as default. Have you enabled anonymous permission on the receiveconnector used by receiving mail from Internet?

    otherwise traffic can be either blocked at your ISP or your firewall.


    lasse at humandata dot se, http://anewmessagehasarrived.blogspot.com

    10 februarie 2012 21:46
  • Hi,

    In your case the ISP seems to be blocking port 25 connectivity from internet back to your mail server. (Based on what I can tell)

    Two things you need to be clear and understand. On your home network assuming you have firewall and your ISP will have another firewall before your connection reaches out to internet so it looks like something like this.

    Going out (Exchange uses Send Connector)

    Your mail Server-------àPORT25---àYour Firewall----------ISP Firewall---------àHere is INTERNET…

    Coming from internet to your network (Exchange uses Receive Connector)

    INTERNET------à ISP Firewall------à Your Firewall-----àPORT25----àYour mail Server

    Now think about this, if your ISP is blocking port 25 coming from internet or going out too, setting your Exchange server to use different port (let’s say Port 26 ) won’t help you at all ?

    Why because ISP Firewall is,  in front of your firewall and they will terminate Port 25 communication before it reaches out to your firewall. Now remember most mail servers will talk SMTP 25 by default, as it is standard port and unless they try to talk to you on different port, rather than port 25, the SMTP communication will be terminated by your ISP firewall. Same logic will apply to out bound SMTP communication.

    The bottom line is you need to short this out with your ISP, and they need to admit & allow their firewall to pass through SMTP communication In & out, or you buy trial business service ( static IP etc.) to prove them they are wrong (-: and cancel it once you made the point.

    Good Luck,

    ocd


    Oz Casey, Dedeal MCITP (EMA), MCITP (EA), MCITP (SA) Visit smtp25.blogspot.com Visit Telnet25.wordpress.com   This posting is provided AS-IS with no warranties or guarantees and confers no rights.

    2 martie 2012 03:46
  • Hell,

    exactly the same here. Only that my exchange 2010 server is not on the dc.

    i can see my isa firewall accepting incoming smtp packages, but they are never answered by exchange.

    the funny thing: the publishing connector for mail is not catching the packets, a rule does it.

    i have, on the same isa a web publishing connector working fine for years now.

    something very strange and i am working on it for 3 days by now.....

    mail sending is fine, only receiving smtp stops in between isa and exchange (and there are also a router and an endian firewall beforehand which are configured good)

    15 august 2013 18:44
  • solved by checking routing.

    as i am using dyndns there is no way of publishing an incoming mail server in isa 2006

    as i have to put the external ip of my mail server in the publishing rule.

    now i am forwarding smtp to the exchange server and i am happy.

    Only one hint on that: i just found ONE website pointing that (to explicitly give the external ip of the mail MX record in the publishing rule and that this is MANDATORY) out in 3 days of googling.

    if any there will be a reply pointing me to the help and RTFM. thx for that beforehand......

    16 august 2013 12:46