none
Incoming Email stuck in Drop folder after SP/Hotfix installation

    Întrebare

  • We recently patched our RTM SharePoint 2010 installation to the most recent service pack & hotfix level.  Everything appears to be fine thus far, except for incoming email.

    Troubleshooting today we have found that the mail for all lists makes it to the C:\inetpub\mailroot\drop folder, and stays there rather than moving to the list.  We have verified that the incoming email settings appear appropriate and that the incoming email timer job is running.

    Sometimes when the timer job runs, we get the following entry in the ULS viewer, but hunting for solutions we are coming up dry.

    "E-mail cannot be delivered because site is over quota or locked for editing"

    [IMG]http://i90.photobucket.com/albums/k280/bbredstang/Sharepointissue.jpg[/IMG]

    Thus far we have rebooted the machine, checked security on the drop folder, reset incoming mail settings, and tried the steps at the link below with no luck.  Any assistance would be more than appreciated.

    Thanks in advance.

    http://sharepointdojo.wordpress.com/2012/03/16/emails-to-sp-libraries-getting-stuck-in-drop-folder/

    1 mai 2012 01:05

Răspunsuri

  • OK Wow, just after I sent you this message I came up with an idea. I checked the Locks and the quotas and none are set. So I thought lets just make a quota anyway that bigger than my current usage. Soon as I did that. Went and checked and my e-mails were all gone out of the drop folder and in my document libraries. Wierd... probably a bug but at least I found the work around, this was about to make me mad if I had to rollback my SharePoint server :). 

    Steps to configure this. SharePoint Central Admin > Application Management > Configure Quota and Locks. Under Site Quota Information I set a quota to 120GB and current use is 90GB and alert at 115GB then Hit OK. No downtime etc. it just fixed it. Hopefully you have the same luck and this helps you out, and I'm sure many to come will have this issue! 

    • Marcat ca răspuns de BBRedStang 1 mai 2012 11:46
    1 mai 2012 05:48

Toate mesajele

  • I am having the same issue, just updated to April 2012 CU, I can almost bet it's something bugged again in this CU. Ughg, been plugging at this for hours, at first I was getting permissions errors that didn't make sense, now I seem to have gotten rid of all that and now getting the exact thing as you. Items deliver to their correct location but just sit. 
    • Propus ca răspuns de nino2004 19 noiembrie 2013 19:51
    1 mai 2012 05:40
  • OK Wow, just after I sent you this message I came up with an idea. I checked the Locks and the quotas and none are set. So I thought lets just make a quota anyway that bigger than my current usage. Soon as I did that. Went and checked and my e-mails were all gone out of the drop folder and in my document libraries. Wierd... probably a bug but at least I found the work around, this was about to make me mad if I had to rollback my SharePoint server :). 

    Steps to configure this. SharePoint Central Admin > Application Management > Configure Quota and Locks. Under Site Quota Information I set a quota to 120GB and current use is 90GB and alert at 115GB then Hit OK. No downtime etc. it just fixed it. Hopefully you have the same luck and this helps you out, and I'm sure many to come will have this issue! 

    • Marcat ca răspuns de BBRedStang 1 mai 2012 11:46
    1 mai 2012 05:48
  • Thank you so much.  The same thing worked for me.  Setting limits on this page allowed the mail to get picked up with nothing further as soon as the timer job ran.

    This certainly appears to be a bug in the newest CU.

    Again, thank you for sharing your fix!

    1 mai 2012 11:59
  • Thank you!

    This also fixed it for me on Search Server 2010 Express.

    (For more details see blog post: http://blog.christian-heindel.de/2012/05/01/april-2012-cu-causing-problems-with-incoming-e-mails-in-sharepoint-2010/ )

    1 mai 2012 12:25
  • Awesome! Thanks, fixed the same problem for me on a system I'd just put April CU on.
    2 mai 2012 04:15
  • Wow, it seems rare that I run into a problem that has such a recent forum post. The April CU definitely seems to be bugging this out.  I just installed it last week while getting user profile synch running, and email hasn't worked since.  Thank goodness for the ULSViewer or else I would have never found the error message that led me here.  This fixed it for me as well!
    8 mai 2012 15:18
  • Yeah I also checked ULS Logs and noticed errors while processing emails. I thought there was something wrong with my SMTP connection at first, but this seems to be Sharepoint hotfix bug.

    BTW I did not set up Warning level , only Limit level and it worked anyway.

    15 mai 2012 06:16
  • Good god, I've been trying to figure this one out for a while.  Worked in Dev, didn't work in QA, or Prod.  All set up the same.  Email would just sit in the drop folder.  Turns out I applied the latest CU's to QA and Prod.  Set a quota, and BAM, All is working.  Thank you thank you thank you!!!  What a pain...........

    8 iunie 2012 20:35
  • OK Wow, just after I sent you this message I came up with an idea. I checked the Locks and the quotas and none are set. So I thought lets just make a quota anyway that bigger than my current usage. Soon as I did that. Went and checked and my e-mails were all gone out of the drop folder and in my document libraries. Wierd... probably a bug but at least I found the work around, this was about to make me mad if I had to rollback my SharePoint server :). 

    Steps to configure this. SharePoint Central Admin > Application Management > Configure Quota and Locks. Under Site Quota Information I set a quota to 120GB and current use is 90GB and alert at 115GB then Hit OK. No downtime etc. it just fixed it. Hopefully you have the same luck and this helps you out, and I'm sure many to come will have this issue! 

    Thank you so much! This was bothering me and your tip did it for me as well! Great work! Thanks again!

    12 iunie 2012 04:04
  • Which Site quota are you guys setting!!!!!!!

    Please provide full information. Are you setting site quota for all site colections in all web applications !!!

    In that case you need powershell because of repititive nature of job for multiple site collections.

    Abhishek


    Abhishek

    19 iunie 2012 01:49
  • Yep - our server did an automatic patch on July 11th and no incoming mail since then was posted to the folders.  Set the quotas and everything back up and running. 


    Thanks!

    17 iulie 2012 20:27
  • This is totally LAME!  I went out of my way to apply the second re-released Cumulative Update for April 2012 and it is still broken!  FU MS!
    23 iulie 2012 18:38
  • I ran the updates and encountered the same problems as everyone else.  However, I did have an incomplete update.  SharePoint Product Configuration Wizard did not finish successfully.  I had several errors in my OWSTimer which took some time to resolve.  For the interim, I set the quota thresholds as previously mentioned and the email messages in the Drop folder began processing to their respective destinations.  Fast forward about ten days until I could have time to resolve the OWSTimer issues.  Once that was completed I was able to run the Product Configuration Wizard successfully, however, I have about 600 emails caught in the Drop folder.  Quotas are still set as before.

    I need help!

    8 august 2012 15:18
  • is no bug according to Microsoft, they have just disabled incoming emails IF quotas are not set with the April CU, as a few of us found out the hard way like you. 

    7 septembrie 2012 12:40