none
Microsoft Exchange Transport service won't start

    Вопрос

  • Hi,

    After 30 sec, upon restarting the Microsoft Exchange Transport service, it stopped.

    It only happened after remove AVG client which was installed in SBS 2010 server which hijacked the port 80 which unable me to access EMC.

    How to do restart this service because no one can receive or sent email at the moment. Please help

    3 марта 2012 г. 10:30

Ответы

  • On Mon, 5 Mar 2012 12:33:06 +0000, JJLSuper wrote:
     
    >
    >
    >Hi Rich, pls see below....my apologies Sophia...will use that link next time or should I repost my post? Please advise.
    >
    >[PS] C:\Windows\system32>get-transportagent Identity Enabled Priority -------- ------- -------- GfiAvSmtpAgent True 1 GfiAvRoutingAgent True 2 Connection Filtering Agent True 3 Content Filter Agent True 4 Sender Id Agent True 5 Sender Filter Agent True 6 Recipient Filter Agent True 7 Protocol Analysis Agent True 8 Transport Rule Agent True 9 Text Messaging Routing Agent True 10 Text Messaging Delivery Agent True 11
    >
    >How do I know if its enabled, it has only a value of 9?
     
    The "Transport Rule Agent" has a prioroty of "9", but you don't want
    to disable that agent.
     
    Are these agents associated with the software you removed?
     
    GfiAvSmtpAgent True 1
    GfiAvRoutingAgent True 2
     
    ---
    Rich Matheisen
    MCSE+I, Exchange MVP
     

    --- Rich Matheisen MCSE+I, Exchange MVP
    • Помечено в качестве ответа JJLSuper 8 марта 2012 г. 12:03
    5 марта 2012 г. 22:23

Все ответы

  • On Sat, 3 Mar 2012 10:30:26 +0000, JJLSuper wrote:
     
    >After 30 sec, upon restarting the Microsoft Exchange Transport service, it stopped.
    >
    >It only happened after remove AVG client which was installed in SBS 2010 server which hijacked the port 80 which unable me to access EMC.
    >
    >How to do restart this service because no one can receive or sent email at the moment. Please help
     
    Did removing the product also remove the transport agent? Use
    get-transportagent to see if it's still there and if it's still
    enabled.
     
    ---
    Rich Matheisen
    MCSE+I, Exchange MVP
     

    --- Rich Matheisen MCSE+I, Exchange MVP
    3 марта 2012 г. 17:53
  • Hi,

    For the Microsoft Exchange Transport services, you can try to restart the Exchange server and then check the result.

    If the issue still occurs, please collect the related event logs to analyze.

    And this forum is related to Exchange server on pure Windows server environment, for the Exchange issue in SBS, the most relevant place is http://social.technet.microsoft.com/Forums/en-US/smallbusinessserver/threads

    Hope it helps.

    Thanks


    Sophia Xu

    TechNet Community Support

    5 марта 2012 г. 7:27
  • Hi Rich, pls see below....my apologies Sophia...will use that link next time or should I repost my post? Please advise.

    [PS] C:\Windows\system32>get-transportagent

    Identity                                           Enabled         Priority
    --------                                           -------         --------
    GfiAvSmtpAgent                                     True            1
    GfiAvRoutingAgent                                  True            2
    Connection Filtering Agent                         True            3
    Content Filter Agent                               True            4
    Sender Id Agent                                    True            5
    Sender Filter Agent                                True            6
    Recipient Filter Agent                             True            7
    Protocol Analysis Agent                            True            8
    Transport Rule Agent                               True            9
    Text Messaging Routing Agent                       True            10
    Text Messaging Delivery Agent                      True            11

    How do I know if its enabled, it has only a value of 9?

    5 марта 2012 г. 12:33
  • On Mon, 5 Mar 2012 12:33:06 +0000, JJLSuper wrote:
     
    >
    >
    >Hi Rich, pls see below....my apologies Sophia...will use that link next time or should I repost my post? Please advise.
    >
    >[PS] C:\Windows\system32>get-transportagent Identity Enabled Priority -------- ------- -------- GfiAvSmtpAgent True 1 GfiAvRoutingAgent True 2 Connection Filtering Agent True 3 Content Filter Agent True 4 Sender Id Agent True 5 Sender Filter Agent True 6 Recipient Filter Agent True 7 Protocol Analysis Agent True 8 Transport Rule Agent True 9 Text Messaging Routing Agent True 10 Text Messaging Delivery Agent True 11
    >
    >How do I know if its enabled, it has only a value of 9?
     
    The "Transport Rule Agent" has a prioroty of "9", but you don't want
    to disable that agent.
     
    Are these agents associated with the software you removed?
     
    GfiAvSmtpAgent True 1
    GfiAvRoutingAgent True 2
     
    ---
    Rich Matheisen
    MCSE+I, Exchange MVP
     

    --- Rich Matheisen MCSE+I, Exchange MVP
    • Помечено в качестве ответа JJLSuper 8 марта 2012 г. 12:03
    5 марта 2012 г. 22:23
  • Hi Rich,

    Yes, the below agents are DEFINITELY associated to GFI MailEssentials.

    GfiAvSmtpAgent True 1
    GfiAvRoutingAgent True 2

    I have removed  GFI MailEssentials weeks ago...these agents should have been deleted.

    I have issued the below command, and it seems the MS Exchange transport service has remained running....

    Disable-TransportAgent -Identity "GfiAvSmtpAgent"
    Disable-TransportAgent -Identity "GfiAvRoutingAgent"

    Thank you Rich!

    Many thanks, Leo


    • Изменено JJLSuper 6 марта 2012 г. 11:20
    • Помечено в качестве ответа JJLSuper 6 марта 2012 г. 12:07
    • Снята пометка об ответе JJLSuper 8 марта 2012 г. 12:03
    6 марта 2012 г. 11:01