none
Sharepoint Title field - problem capturing a value

    Dotaz

  • I have a document library with .xml documents created with InfoPath form 2007. I need to capture a SharePoint Title field and place it as a default in a editable txt field in a SharePoint form, when a form opens.

    What I already did: created a Receive data connection to my library, selected for "Include data from active form only" option, selected Title field to provide a data for connection. Then I created a field and placed @Title as a source for a default value. But nothing is happening.

    What did I miss?

    Thanks!

    30. března 2012 17:15

Odpovědi

  • Well may that is the case, as I have tested it myself the same functionality I told you and it is working fine at my end for Form Library.

    But how did you publish the form to document Library as I will not allow to publish in Document Library.


    Dare to promise

    • Označen jako odpověď Natalie Kash 30. března 2012 19:04
    30. března 2012 18:31

Všechny reakce

  • I replied you in your previous post.

    Have you selected "Automatically retrieve data when form is opened" in Data Connection.

    Also if you are using Spaces between your file name then it will not work.

    Remove Spaces from File name and see it if it works.


    Dare to promise

    30. března 2012 18:02
  • Yes, "Automatically retrieve data when form is opened" is here and file name doesn't have spaces. One more question: does it really matter, if I use Document library or Form library, because I'm doing in in a Document library.

    Thank you!

    30. března 2012 18:20
  • Well may that is the case, as I have tested it myself the same functionality I told you and it is working fine at my end for Form Library.

    But how did you publish the form to document Library as I will not allow to publish in Document Library.


    Dare to promise

    • Označen jako odpověď Natalie Kash 30. března 2012 19:04
    30. března 2012 18:31
  • Well, I have no problem publish in a Document library. I'm kid of new to all the SharePoint stuff, so I just picked first thing that worked for me. But it seems that I better publishh in a Form library instead: more flexibility and alas! the setup works here.

    Thank you again and sorry for the trouble!

    30. března 2012 18:43
  • Great, if it works for you.


    Dare to promise

    30. března 2012 18:47