none
Installation fails on invalid sql server version, but version is ok...

    Question

  • When using the Sharepoint Products Configuration Wizard, when specifying database settings, it is failing with the following error :

    SQL server at {machinenamehere} has an unsupported version 10.0.2531.0. Please refer to http://go.microsoft.com/fwlink/?LinkId-165761 for information on the minimum required SQL Server versions and how to download them.

    Well, on the link, it says I need version 10.0.2531. I'm clueless to what can be the error. I do have the sql server running on the machine and it appears AOK with it. But still getting the error above...

    It is a test machine, I never used sharepoint before so I'm installing for first time and can play around with the machine at will, so any suggestions is appreciated.
    Thursday, May 27, 2010 5:31 PM

Answers

All replies

  • What is the Sharepoint Version and Edition you are using to install?  Is it Beta or RTM?

    Do you already have SQL Server installed? What is the Version of SQL Server?

    Please see the Software & Hardware Requirements of SharePoint 2010 here:

    http://technet.microsoft.com/en-us/library/cc262485.aspx

    Revert back, if you have any further queries.

     


    Thanks & Regards,
    Kamlesh | Blog | Twitter | Posting is provided "AS IS" with no warranties, and confers no rights.
    • Marked as answer by RafaelF82 Thursday, May 27, 2010 7:40 PM
    Thursday, May 27, 2010 5:54 PM
  • Sharepoint Server 2010 RTM from iso file (en_sharepoint_server_2010_x64_dvd_518634.iso).

    SQL Server 2008 R2 Enterprise, version is the one mentioned above, 10.0.2531.0.

    Windows is server 2008 R2 datacenter.

    All 64 bit.

    Windows update shows no updates, and I activated the options to look for updates for all MS software and new free software from MS.

    I'm installing everything as trial and not activating anything that doesn't require it, as I said it's only for testing/learning yet, could that be the reason ?

    The odd thing is that the error message says I can't install on that version but that version is listed as recommended on the link it provides.

    Image for error msgbox:
    http://img444.imageshack.us/img444/2366/errordl.png
    Thursday, May 27, 2010 6:12 PM
  • Hi Rafael,

    Thanks for providing the details.  I saw the screenshot too.  Can you check the below points:

    1) Your SQL Sever version number seems perfect.  Can you double check the Architecture, by going to SQL Server Management Studio - right click on your Server and choose Properties -  and see the value next to Product.  It should show 64-bit.

    2) Have you installed all the Prerequisites?  To double confirm, extract/mount your ISO file and double click on PrerequisiteInstaller.exe.  This will ensure that all the Pre-requisites are installed properly.

    Let me know how it goes.


    Thanks & Regards,
    Kamlesh | Blog | Twitter | Posting is provided "AS IS" with no warranties, and confers no rights.
    Thursday, May 27, 2010 6:46 PM
  • Hi, I got it to work, after closer look at the documentation I noticed I needed these apparently beta(?) hotfix.

    I installed only the first one and it worked.

    Link for the hotfix :
    http://support.microsoft.com/hotfix/KBHotfix.aspx?kbnum=970315&kbln=en-us


    I found it following your first post link so thanks for helping.
    • Marked as answer by RafaelF82 Thursday, May 27, 2010 7:40 PM
    Thursday, May 27, 2010 7:39 PM
  • Hi Rafael,

    Thats great.  Its my pleasure to assist you.

     


    Thanks & Regards,
    Kamlesh | Blog | Twitter | Posting is provided "AS IS" with no warranties, and confers no rights.
    Thursday, May 27, 2010 7:48 PM
  • Just as note, it also changed my sql server version to 10.0.2740.0, and this is the hotfix filename SQL_Server_2008_SP1_CU_Updated_Ref_KB_976761.
    Thursday, May 27, 2010 7:50 PM
  • Thanks for the information.  Hope it got installed successfully now.


    Thanks & Regards,
    Kamlesh | Blog | Twitter | Posting is provided "AS IS" with no warranties, and confers no rights.
    Friday, May 28, 2010 4:51 AM
  • Hi,

     

    I am using Win server 2008 and installed SQL Server 2008 R2, when i tried to install the Share point server 2010 in the configuration wizard it gives me error as below

    ---------------------------
    SharePoint Products Configuration Wizard
    ---------------------------
    SQL server at SP2010 has an unsupported version 10.0.1600.22. Please refer to "http://go.microsoft.com/fwlink/?LinkId=165761" for information on the minimum required SQL Server versions and how to download them.
    ---------------------------
    OK  
    ---------------------------

    I tried to install the hot fix, http://support.microsoft.com/hotfix/KBHotfix.aspx?kbnum=970315&kbln=en-us for x64 bit and when installing the hot fix there was no instances or services enabled to proceed further for the installation.

     

    Can any one help me out to resolve the issue

    SQL Server version is

    Microsoft SQL Server 2008 (RTM) - 10.0.1600.22 (X64)   Jul  9 2008 14:17:44   Copyright (c) 1988-2008 Microsoft Corporation  Enterprise Edition (64-bit) on Windows NT 6.1 <X64> (Build 7601: Service Pack 1)


    Thanks Karthikeyan Anbarasan http://f5debug.net/
    Wednesday, June 29, 2011 6:39 AM
  • Hi Karthikeyan,

    Did you ever find a fix for this issue?

    I am having the same problem the "HOTFIX" did not fix the SQL login problem (with configuration wizard sharepoint 2010)

    Any help on this issue would be greatly appriciated.

     

    Mike

     

     


    • Edited by Mikekav99 Wednesday, November 09, 2011 7:59 PM
    Wednesday, November 09, 2011 7:58 PM