none
Cannot Complete Sharepoint 2010 Configuration Wizard

    Question

  • I am trying to use the Sharepoint 2010 Configuration Wizard to "Create a new server Farm" on my physical machine without any success. I have Windows 7 x64. When I get to the "Specify Configuration Database Settings" window, there are only 2 fields available with "Database server" and "Database name" and the "Next" button greyed out,. After I fill in these 2 fields, the "Next" button is still grayed out.  See attached image.

    I already tried running the Hotfixes Windows6.1-KB976462-v2-x64.msu, Windows6.1-KB982307-x64.msu, Windows6.1-KB958830-x64-RefreshPkg.msu, Windows6.0-KB976394-x64.msu, NDP35SP1-KB982306-x64.exe & sqlncli.msi. When I do I get the message "The update is not applicable to your computer"

    The Services "SharePoint 2010 Administration" & "SharePoint 2010 Timer" were stopped and I started them before I started the wizard. I also tried while they were stopped. The wizard page "Specify Configuration Database Settings" also says "Specify Database Access Account". Should there be another field there?

    Thanks!

    Joseph Azzopardi

    Monday, April 02, 2012 12:17 PM

Answers

  • Hang on, where's the box for entering the database accout information in your screen shot.  Have you increased the font size or do you have any accessibilty options enabled?  The "Next>" button will only become "available" once you've entered credentials. 

    Something is not right with your display.

    Your window should look like this...


    Paul Turner http://redmanta.co.uk/blog Twitter: @RedMantaUK MCTS:WSS,MOSS,2010 MCITP:2010.
    Please remember to click "Mark As Answer" if a post solves your problem or "Vote As Helpful" if it was useful.


    • Edited by Paul Turner _ Monday, April 02, 2012 1:43 PM Added image
    • Proposed as answer by Mustafa.Yılmaz Monday, April 02, 2012 2:17 PM
    • Marked as answer by ncjazz Monday, April 02, 2012 2:34 PM
    Monday, April 02, 2012 1:41 PM
  • Now you've added permissions can we try without the instance name, so in SharePoint config servername is either "local" or "ITS-FVZBSN1" forget the "\MSSQLServer" bit.

    Paul Turner http://redmanta.co.uk/blog Twitter: @RedMantaUK MCTS:WSS,MOSS,2010 MCITP:2010.
    Please remember to click "Propose As Answer" if a post solves your problem or "Vote As Helpful" if it was useful.

    • Marked as answer by ncjazz Tuesday, April 10, 2012 3:40 PM
    Tuesday, April 10, 2012 3:36 PM

All replies

  • Hello,

    Try to give only the Database Server IP Address. It may help.

    Is there any event log errors?


    Kathir

    Monday, April 02, 2012 12:31 PM
  • Hi Joseph,

    Assuming ITS-FVZBSN1 is host name and that your using SQL Express, try "ITS-FVZBSN1\SQLExpress" as the "Database Server" and your own choice of Database Name, "SharePoint_Config" will do.


    Paul Turner http://redmanta.co.uk/blog Twitter: @RedMantaUK MCTS:WSS,MOSS,2010 MCITP:2010.
    Please remember to click "Mark As Answer" if a post solves your problem or "Vote As Helpful" if it was useful.

    Monday, April 02, 2012 1:07 PM
  • I placed the IP address of my PC in the Data Server field, it did not help.

    When I tried to apply Hotfixes, the Event Viewer Log Setup errors displayed:

    Windows update  could not be installed because of error 2149842967 "" (Command line: ""C:\Windows\system32\wusa.exe" "C:\SharePoint HotFixs\Windows6.1-KB976462-v2-x64.msu"        ")

    Windows update  could not be installed because of error 2149842967 "" (Command line: ""C:\Windows\system32\wusa.exe" "C:\SharePoint HotFixs\Windows6.1-KB982307-x64.msu"        ")

    Windows update  could not be installed because of error 2359302 "" (Command line: ""C:\Windows\system32\wusa.exe" "C:\Sharepoint Prerequisites\Microsoft Identity Foundation\Windows6.1-KB974405-x64.msu"        ")


    Joseph Azzopardi

    Monday, April 02, 2012 1:12 PM
  • I removed the SQLExpress database earlier at the recommendation of co-workers who removed his. the only database I have is MSSQLSERVER.I tried using as a Database Server: ITS-FVZBSN1\MSSQLSERVER and Database Name: SharePoint_Config. The Next button is still grayed out.

    Joseph Azzopardi

    Monday, April 02, 2012 1:17 PM
  • Joseph,

    Which version of SQL are you now running?  If you've removed SQL Express you must have another installation of SQL running.  Take a look at your services.msc and ensure you do at least have SQL running on your box.  If you do, this will also show you the instance name to add to your "ITS-FVZBSN1\instanceName" in the "Database Server" field.


    Paul Turner http://redmanta.co.uk/blog Twitter: @RedMantaUK MCTS:WSS,MOSS,2010 MCITP:2010.
    Please remember to click "Mark As Answer" if a post solves your problem or "Vote As Helpful" if it was useful.

    Monday, April 02, 2012 1:21 PM
  • I am running SQL Server 2008. All the other SQL Server Services are running. I did notice that SQLBrowser "SQL Server Browser" is disabled. I left that as is.

    I noticed that the SQLSERVERAGENT "SQL Server Agent (MSSQLSERVER)" was not running in Services, so I started it. I then cancelled out of the Config Wizard and tried again. Still no luck. I tried using as a Database Server: ITS-FVZBSN1\MSSQLSERVER and ITS-FVZBSN1 with the Database Name: SharePoint_Config.


    Joseph Azzopardi

    Monday, April 02, 2012 1:34 PM
  • Hang on, where's the box for entering the database accout information in your screen shot.  Have you increased the font size or do you have any accessibilty options enabled?  The "Next>" button will only become "available" once you've entered credentials. 

    Something is not right with your display.

    Your window should look like this...


    Paul Turner http://redmanta.co.uk/blog Twitter: @RedMantaUK MCTS:WSS,MOSS,2010 MCITP:2010.
    Please remember to click "Mark As Answer" if a post solves your problem or "Vote As Helpful" if it was useful.


    • Edited by Paul Turner _ Monday, April 02, 2012 1:43 PM Added image
    • Proposed as answer by Mustafa.Yılmaz Monday, April 02, 2012 2:17 PM
    • Marked as answer by ncjazz Monday, April 02, 2012 2:34 PM
    Monday, April 02, 2012 1:41 PM
  • That did it, I can now see the Username & Password fields in :Specify Database Access Account". My wizard now looks the way it should.

    I changed my Desktop font size from Large (150%) to Medium (125%).

    Thank you All!


    Joseph Azzopardi

    Monday, April 02, 2012 1:55 PM
  • Amazing isn't it?  Sometimes the answer is obvious I I'll try to complicated it :-p  Should've spotted that early but at least we got there.

    Paul Turner http://redmanta.co.uk/blog Twitter: @RedMantaUK MCTS:WSS,MOSS,2010 MCITP:2010.
    Please remember to click "Mark As Answer" if a post solves your problem or "Vote As Helpful" if it was useful.

    Monday, April 02, 2012 2:13 PM
  • Now I'm having problems completing the Configuration wizard. I tried using the defaults when installing SQL Server 2008 & SP2. It created a MSSQLSERVER instance and it is running. I included myself in the DB Security Server Roles of dbcreator, processadmin, public, securityadmin & sysadmin.

    MY MSSQLSERVER is running on NT AUTHORITY\NETWORK SERVICE. I already tried uninstalling & reinstalling MSSQLSERVER to run on NT AUTHORITY\LOCAL SERVICE & DST/asd1007. The username & password is my Windows Authentication login.

    When I try to create the db SharePoint_Config, I get the error an error.


    Joseph Azzopardi

    Tuesday, April 10, 2012 1:31 PM
  • Hi Joseph,

    You still need to add "Servername\instance" name in the database server field.  Your instance name is MSSQLServer but whats the servername of the host it's running on?


    Paul Turner http://redmanta.co.uk/blog Twitter: @RedMantaUK MCTS:WSS,MOSS,2010 MCITP:2010.
    Please remember to click "Propose As Answer" if a post solves your problem or "Vote As Helpful" if it was useful.

    Tuesday, April 10, 2012 1:36 PM
  • Maybe I'm missing something. here is my db. I tried 10.0.4000\MSSQLSERVER, local\MSSQLSERVER & (local)\MSSQLSERVER to no avail. I get the same message.


    Joseph Azzopardi

    Tuesday, April 10, 2012 1:42 PM
  • Are you sure the database SharePoint_Config does not already exist?  Expand the Databases just to make sure, and try with the server hostname and instance name, just to rule it out.

    Paul Turner http://redmanta.co.uk/blog Twitter: @RedMantaUK MCTS:WSS,MOSS,2010 MCITP:2010.
    Please remember to click "Propose As Answer" if a post solves your problem or "Vote As Helpful" if it was useful.

    Tuesday, April 10, 2012 1:48 PM
  • SharePoint_Config does not exist. Which server hostname are you referring to?


    Joseph Azzopardi

    Tuesday, April 10, 2012 1:53 PM
  • The actual name of the server your SQL installation is sitting on.  Another thing to check, just make sure you have no other SQL instances by checking under services.msc from the Start > Run command line.

    Paul Turner http://redmanta.co.uk/blog Twitter: @RedMantaUK MCTS:WSS,MOSS,2010 MCITP:2010.
    Please remember to click "Propose As Answer" if a post solves your problem or "Vote As Helpful" if it was useful.

    Tuesday, April 10, 2012 1:57 PM
  • As a SP newbie, I'm sorry that this I'm not getting it that quickly. I tried <computer name>\MSSQLSERVER, <full computer name (includes domain)>\MSSQLSERVER & <domain name>\MSSQLSERVER. I checked Services and there is no duplicate SQL Server instances running. The only other is SQLEXPRESS and that is stopped. However, I did notice that SharePoint 2010 Administration was not running, so I started it.

    Joseph Azzopardi

    Tuesday, April 10, 2012 2:15 PM
  • So just to get an update, you're on a server, logged in as yourself and your account has securityadmin and dbcreator rights to your desired sql server?  Is SQL on the same box you're running the SharePoint config from?

    Paul Turner http://redmanta.co.uk/blog Twitter: @RedMantaUK MCTS:WSS,MOSS,2010 MCITP:2010.
    Please remember to click "Propose As Answer" if a post solves your problem or "Vote As Helpful" if it was useful.

    Tuesday, April 10, 2012 2:25 PM
  • Yes, I am logged into my Developer station as myself. My SQL Server local server has me as a user with Security Server Roles of dbcreator, processadmin, public, securityadmin & sysadmin. SQL Server 2008 and SharePoint 2010 are both running on my developer machine. Thanks!

    Joseph Azzopardi

    Tuesday, April 10, 2012 2:31 PM
  • Ok, can you check which rights you have to the master database on your SQL instance. Also, what OS is your developer station?

    Paul Turner http://redmanta.co.uk/blog Twitter: @RedMantaUK MCTS:WSS,MOSS,2010 MCITP:2010.
    Please remember to click "Propose As Answer" if a post solves your problem or "Vote As Helpful" if it was useful.

    Tuesday, April 10, 2012 2:40 PM
  • I am working on Windows 7 x64.

    I had no rights on the master database. I changed that by creating a new user with my username in there with the same privileges as dbo, which happens to be db_owner. I then checked the Security Roles for the master database and it has dbo & my new user listed.

    I then cancelled out of the SP Configuration Wizard and restarted it. For the Database Server, I used my computer name ITS-FVZBSN1\MSSQLSERVER.

    Still not letting me in.


    Joseph Azzopardi

    Tuesday, April 10, 2012 3:00 PM
  • Are you getting the same message?  "Cannot connect to database Master"?

    Paul Turner http://redmanta.co.uk/blog Twitter: @RedMantaUK MCTS:WSS,MOSS,2010 MCITP:2010.
    Please remember to click "Propose As Answer" if a post solves your problem or "Vote As Helpful" if it was useful.

    Tuesday, April 10, 2012 3:06 PM
  • Yes same answer.


    Joseph Azzopardi

    Tuesday, April 10, 2012 3:09 PM
  • Snapshot attached.


    Joseph Azzopardi

    Tuesday, April 10, 2012 3:10 PM
  • Ok Joseph,

    Let's start keeping things simple.  Close SQL Server Management Studio and open it backup, the server name that you connect to is what we're going to put in the SharePoint dialog box, so what is it?

    Secondly, ensure the "username" field which should be greyed out if using windows authentication on the SQL Management Studio connect box is your domain account?


    Paul Turner http://redmanta.co.uk/blog Twitter: @RedMantaUK MCTS:WSS,MOSS,2010 MCITP:2010.
    Please remember to click "Propose As Answer" if a post solves your problem or "Vote As Helpful" if it was useful.

    Tuesday, April 10, 2012 3:20 PM
  • When I connect to SQL Server, the connection is "Server Name: (local)". Yes my Windows Authentication with my username is grayed out. It still says "Cannot connect to database master at SQL server at  local\MSSQLSERVER..." (with & w/o the parentheses).

    Joseph Azzopardi

    Tuesday, April 10, 2012 3:34 PM
  • Now you've added permissions can we try without the instance name, so in SharePoint config servername is either "local" or "ITS-FVZBSN1" forget the "\MSSQLServer" bit.

    Paul Turner http://redmanta.co.uk/blog Twitter: @RedMantaUK MCTS:WSS,MOSS,2010 MCITP:2010.
    Please remember to click "Propose As Answer" if a post solves your problem or "Vote As Helpful" if it was useful.

    • Marked as answer by ncjazz Tuesday, April 10, 2012 3:40 PM
    Tuesday, April 10, 2012 3:36 PM
  • It worked by just using "Server Name: (local)" w/o MSSQLSERVER. I am now at the "Specify Farm Security Settings" window.

    Thank you very much, this is a big relief!

    Joe

    Joseph Azzopardi

    Tuesday, April 10, 2012 3:40 PM
  • Process of elimination is a wonderful thing.  Good luck with the rest of it, if you have any future issues (I'm sure you won't), I would consider starting a new thread, more people might jump in with ideas that way.

    Paul Turner http://redmanta.co.uk/blog Twitter: @RedMantaUK MCTS:WSS,MOSS,2010 MCITP:2010.
    Please remember to click "Propose As Answer" if a post solves your problem or "Vote As Helpful" if it was useful.

    Tuesday, April 10, 2012 3:42 PM