none
Excel not refreshing

    Question

  • hi -  

    i have a simple Excel spreadsheet in a document library.    Excel Services is enabled and trusted locations is set up.     I check out the spreadsheet, modify it, and version it.   It saves the version and takes me back to SharePoint.   When I open the Excel file, the changes haven't refreshed.  However, when I look at the same file from the version history, it's updated with the new data.    Also, if I close the browser, and relaunch it, it shows the updated data.    

    Any ideas why its not refreshing directly after check in?     My IE 8 browser setting is set to refresh every time I visit the page.

     

    thanks
    Friday, July 29, 2011 6:53 PM

Answers

  • Hi,

    There is no good way to meet this need completely since excel service application will use cache. however, you can go to central administration > manage service applications > excel service application > reusted file locations > select on location and click edit > session management section to downsize the session timeout.

    Regards,

    Seven

    • Marked as answer by XRS Wednesday, August 03, 2011 4:50 PM
    Wednesday, August 03, 2011 7:18 AM

All replies

  • Is the excel connecting to external data ? if yes , have you configured refresh options under connection properties? Open your excel data connection file, go to data->connections ->Properties ->Usage  tab , check the options configured for data refesh


    Amrita Talreja
    Friday, July 29, 2011 11:30 PM
  • Amrita -   It's not connecting to any external data.     Even if its a simple change to a field, it doesn't refresh after check in.     I did find that if I click on File > Reload Workbook, the changes show up right away.   
    Monday, August 01, 2011 11:54 AM
  • Hi,

    There is no good way to meet this need completely since excel service application will use cache. however, you can go to central administration > manage service applications > excel service application > reusted file locations > select on location and click edit > session management section to downsize the session timeout.

    Regards,

    Seven

    • Marked as answer by XRS Wednesday, August 03, 2011 4:50 PM
    Wednesday, August 03, 2011 7:18 AM
  • thanks Seven!  that appears to make things much better for the moment. 
    Wednesday, August 03, 2011 4:50 PM