locked
"There was an error in the callback" error in People Picker look up

    Question

  •  
    Hi,
     
    We have been getting "There was an error in the callback" error while searching for users in the people picker user look up box. We started getting this error only after  we executed the stsadm -o setproperty -url http://<server:port> -pn peoplepicker-searchadforests -pv <url>, <LoginName>, <Password> command for implementing cross forest user search in People Picker look up box.
     
    Any idea what might be the issue?
     
      Regards,
    Vipul Mehta
    Friday, August 29, 2008 11:39 AM

Answers

  • We experience the same error on 2 of our 3 front-end servers.  We resolved the issue by running the peoplepicker commands (as stated above by Arash) on each front-end web server.  
    Tuesday, August 18, 2009 2:37 PM

All replies

  • The error is most likely indicating that the callback never returned data, or the client page timed out before the callback returned.

    It's possible the queries are timing out, or taking too long now that you are searching additional forests.

    Perhaps try playing with another people-picker property:

    peoplepicker-activedirectorysearchtimeout

    Try setting it very low, and also relatively high, and see how it affects your results.
    Sunday, August 31, 2008 5:35 PM
  • Hi Vipul,

    I had same issue and i resolved it.
    you should use correct command format for this purpose.

    1- use this command :
    stsadm -o setpassword -password "SOMEKEY" --> SOMEKEY like ABCD

    2- use this command :
    stsadm -o setproperty -propertyname peoplepicker-searchadforests -propertyvalue "dom
    ain:SAMPLE.NET",SAMPLE\ADMINUSERNAME,PASSWORD -url http://WebApplication.net

    3- do IISREST


    regards,
    Arash Aghajani

     

    Moderator Note: NEVER propose your own posts as answers

    • Proposed as answer by Arash Aghajani Sunday, May 24, 2009 10:36 AM
    • Unproposed as answer by Mike Walsh FIN Monday, August 01, 2011 4:22 PM
    • Edited by Mike Walsh FIN Monday, August 01, 2011 4:22 PM Moderator note added about not proposing own posts
    Sunday, May 24, 2009 10:34 AM
  • We experience the same error on 2 of our 3 front-end servers.  We resolved the issue by running the peoplepicker commands (as stated above by Arash) on each front-end web server.  
    Tuesday, August 18, 2009 2:37 PM