none
Retract Solution Error again and again.

    Question

  • I've had an error ocurr twice, which required a complete reinstall of
    sharepoint 2010 that ocurrs randomly when deploying a solution to
    sharepoint 2010. The full error is:

    Error occurred in deployment step 'Retract Solution': The
    language-neutral solution package was not found.

    I have no idea what is causing this, and have tried everything under
    the sun, reboots restart vis stu etc. I'm using beta 2 of visual
    studio if that helps.

    Thanks

    Wednesday, November 25, 2009 8:21 PM

Answers

  • If you open a sharepoint powershell prompt, i believe they are calling it SharePoint Management Console now in the start menu, run the following commands


    Uninstall-SPSolution -identity {name of wsp file.wsp} -allwebapplications

    remove-spsolution -identity {name of wsp file.wsp} -force

    add-spsolution -literalpath C:\{FULL file system location\name of wsp file.wsp}

    install-spsolution -identity {name of wsp file.wsp} -webapplication http://{URL of SharePoint site to deploy to} -GACDeployment -force


    what are the results that come back?


    Tony Testa www.tonytestasworld.com
    Wednesday, December 02, 2009 1:29 PM

All replies

  • Based on the error message I am thinking that its not finding the solution, therefore the retract step is "failing".  Although its failing it doesn't really mean that its an error, it just means that there is nothing to retract.  Does this error prevent you from actually deploying your solution?  If so, can you paste in the log from the output window in visual studio?

    Tony Testa www.tonytestasworld.com
    Thursday, November 26, 2009 2:57 AM
  • Hi Tony, below is the output log.  As you can see once the retract fails, it won't deploy.

    Active Deployment Configuration: Default

    Run Pre-Deployment Command:

    Skipping deployment step because a pre-deployment command is not specified.

    Recycle IIS Application Pool:

    Recycling IIS application pool 'SharePoint - 80'...

    Retract Solution:

    Retracting solution 'sitepages.wsp'...

    Error occurred in deployment step 'Retract Solution': The language-neutral solution package was not found.

    ========== Build: 2 succeeded or up-to-date, 0 failed, 0 skipped ==========

    ========== Deploy: 1 succeeded, 1 failed, 0 skipped ==========

    Thursday, November 26, 2009 3:00 PM
  • If you go to Central Administration and under Solution Management, do you see "sitepages.wsp" in the list of installed Solutions?

    Tony Testa www.tonytestasworld.com
    Thursday, November 26, 2009 5:59 PM
  • Hi Tony, Under Central Administration I do not see any "Solution Management" link.   You are talking about 2010 right? 
    Monday, November 30, 2009 2:29 PM
  • The URL is http://{CENTRAL ADMIN}/_admin/Solutions.aspx

    Or go to Central Admin -> system settings -> manage farm solutions

    Tony Testa www.tonytestasworld.com
    Monday, November 30, 2009 3:53 PM
  • No solutions in the solution store.
    Monday, November 30, 2009 3:56 PM
  • Can you tell us what you are trying to build? May be there is something to do with the code?

    Given that you cant find any solutions in the store, I doubt SP2010 is even installing the WSP file from VS2010. Can you try manually installing the WSP?


    Regards,
    Chakkaradeep || SharePoint Developer - MCTS SharePoint Dev, WSS Dev
    http://www.intergen.co.nz || Twitter: http://twitter.com/chakkaradeep || http://www.chakkaradeep.com
    Monday, November 30, 2009 8:04 PM
  • What OS are you using? Server 2008? Server 2008 SP2?  What version of Visual Studio are you using?  I know that there are some issues where certain versions of visual studio 2010 don't work with certain builds of SharePoint 2010.

    Tony Testa www.tonytestasworld.com
    Tuesday, December 01, 2009 3:42 PM
  • The solution I'm building is just a sharepoint project with application pages.  I've tried using the powershell scripts to remove/add and get the same error.   I'm using Windows 7 x64 and SQL Server 2008 SP1, Visual Studio 2010 Beta 2.   

    Thanks

    Wednesday, December 02, 2009 12:54 PM
  • What version of SharePoint 2010 are you running?  Tech Preview? Beta?  Also, is SharePoint 2010 installed on the same machine or are you trying to deploy to a remote machine?
    Tony Testa www.tonytestasworld.com
    Wednesday, December 02, 2009 1:14 PM
  • Foundation public beta, Sharepoint 2010 is on the same Windows 7 installation as Visual Studio
    Wednesday, December 02, 2009 1:20 PM
  • If you open a sharepoint powershell prompt, i believe they are calling it SharePoint Management Console now in the start menu, run the following commands


    Uninstall-SPSolution -identity {name of wsp file.wsp} -allwebapplications

    remove-spsolution -identity {name of wsp file.wsp} -force

    add-spsolution -literalpath C:\{FULL file system location\name of wsp file.wsp}

    install-spsolution -identity {name of wsp file.wsp} -webapplication http://{URL of SharePoint site to deploy to} -GACDeployment -force


    what are the results that come back?


    Tony Testa www.tonytestasworld.com
    Wednesday, December 02, 2009 1:29 PM
  • I think Tony has the right idea here. I've sen this before and if you can use STSADM to get the solution undeployed you should be okay again. This seems to be a problem common to SharePoint 2007 and SharePoint 2010. Here's someone else solving it on SharePoint 2007.

    http://mindsharpblogs.com/aaron/archive/2007/08/23/2603.aspx

    Cheers,
    Paul
    SharePoint Product Manager. Posting is provided "AS IS" with no warranties, and confers no rights
    Sunday, December 06, 2009 3:46 AM
  • Thanks Tony.  

    I had the same issue, and couldn't retract the solution via the Central Admin UI or via stsadm command, even when using execadmsvcjobs.  The first script was all I needed:  Uninstall-SPSolution.  After that, it was retracted, and I could remove through the web UI.

    Best,

    Aaron

    Thursday, April 22, 2010 1:44 AM
  • Hi Jason,

    I've had this issue before and solved it by creating a new deployment configuration from within Visual Studio 2010.

    In VS2010, access the project setting and then the SharePoint tab. Then view the 'Default' configuration and make a note of the sequence of the steps this configuration executes.

    Now create your own new configuration called something like 'Deploy - no retract' and add all the steps the default configuration has but exclude the step 'Retract Solution'.

    Using this new configuration you'll be able to deploy the solution successfully from VS2010. Then before you deploy it again for a second time you may need to switch the Active Deployment Configuration back to 'Default'.

    I hope this helps...

     


    Brian C | Blog Site
    • Proposed as answer by Karl0s Thursday, October 21, 2010 2:54 PM
    Thursday, April 22, 2010 9:36 PM
  • Hi,

    I had this issue today and resolved using the following steps:

    (1) Run following powershell command:           get-spsolution

    (2) This should then list all deployed solutions. The one causing me problem had a blank value under the Deployed column (the rest had true).

    (3) Delete the problematic solution using the command:          (get-spsolution solutionname.wsp).Delete()

    (4) Tried a Deploy from Visual Studio 2010 and the problem had now been resolved.

     

    • Proposed as answer by Cutty Monday, May 02, 2011 6:45 AM
    Monday, July 26, 2010 10:23 AM
  • Thanks Brian,

    I Found a load of fixes on the web that did not work for me, but this one did the trick.

     

    Mike Parris


    mikeparris
    Thursday, August 19, 2010 1:37 PM
  • Hi Jason,

    I've had this issue before and solved it by creating a new deployment configuration from within Visual Studio 2010.

    In VS2010, access the project setting and then the SharePoint tab. Then view the 'Default' configuration and make a note of the sequence of the steps this configuration executes.

    Now create your own new configuration called something like 'Deploy - no retract' and add all the steps the default configuration has but exclude the step 'Retract Solution'.

    Using this new configuration you'll be able to deploy the solution successfully from VS2010. Then before you deploy it again for a second time you may need to switch the Active Deployment Configuration back to 'Default'.

    I hope this helps...

     


    Brian C | Blog Site
    This has fixed the issue for me - Thanks Brian!
    Thursday, October 21, 2010 2:54 PM
  • Robbea, you rock man, I tried this solution and it resolved my problem.

     

    Thanks a ton!!

    Tuesday, March 22, 2011 9:20 PM