none
Security, Configure Managed Accounts Gives object reference not set to an instance of an object error

    Question

  • I've seen some other posts on the web about this error but no real solution.  I have a managed accounts that have been set to automatically reset the password.  Unfortunately, now when I try to click on configure managed accounts in the Central Admin->Security, I receive an error "object reference not set to an instance of an object"

    Many posts on the web have suggested this is caused by turning on the autogeneratepassword functionality, but since the page won't render to turn this off, I can make the change in Central Admin.

    If I try to turn off -autogeneratepassword with powershell and set-spmanagedaccount I receive an access denied error message.  Is there anyway to turn off autogeneratepassword without removing and recreating the managed account?  At this point I just want to turn the "feature" off all together, but I don't want have to reset permissions for all service accounts on a LIVE production farm.

    Thanks

    Wednesday, August 31, 2011 7:50 PM

Answers

  • Hi,

     

    From your narration, you can use the following steps to fix your issue:

     

    1. Run the command "get-spmanagedaccount".

    2. Locate the account the problematic managed account.

    3. Run the command to delete the user from the configure managed account.

          Remove-SPManagedAccount domain\username.

    4. After this, check if you can click on configure managed accounts.

    5. You can add this account back.

     

    Thanks,

    Rock Wang


    Regards, Rock Wang Microsoft Online Community Support
    • Marked as answer by Wayne Fan Friday, September 09, 2011 6:37 AM
    Friday, September 02, 2011 9:35 AM

All replies

  • Hi,

     

    From your narration, you can use the following steps to fix your issue:

     

    1. Run the command "get-spmanagedaccount".

    2. Locate the account the problematic managed account.

    3. Run the command to delete the user from the configure managed account.

          Remove-SPManagedAccount domain\username.

    4. After this, check if you can click on configure managed accounts.

    5. You can add this account back.

     

    Thanks,

    Rock Wang


    Regards, Rock Wang Microsoft Online Community Support
    • Marked as answer by Wayne Fan Friday, September 09, 2011 6:37 AM
    Friday, September 02, 2011 9:35 AM
  • Hi,

    You could work around this by using powershell cmdlets to change the Automatic Update of password to false on the managed accounts. You would then not need to remove the managed account.

    Best regards,

    Chandra

    Friday, March 30, 2012 10:03 AM
  • You recommend:

    1. Run the command "get-spmanagedaccount".

    2. Locate the account the problematic managed account.

    3. Run the command to delete the user from the configure managed account.

         Remove-SPManagedAccount domain\username

    I have an account listed: domain\spsearch(1) along with the expected domain\spfarm and domain\spwebapp ones.

    Running "Remove-SPManagedAccount domain\spsearch(1) fails with an error:

    Remove-SPManagedAccount : A positional parameter cannot be found that accepts a
    rgument '1'.
    At line:1 char:24
    + Remove-SPManagedAccount <<<<  domain\spsearch(1)

    Any advice?

    -Sue

    Saturday, January 26, 2013 2:12 AM