none
SharePoint 2010: Browsing to newly created web app says cannot display webpage (windows server 2008R2)

    Question

  • Hi,

    I have created a http site with no SSL (SSL turned off). I created this site in port 4500. Instead of the default URL which defaults to name of the webserver, I gave it a different name to the web app URL.I then created a Site collection. Now when I browse the site it says “IE cannot display the webpage”

    Things I tried:-

    1. Made sure that Application pool related to this website is started.
    2. I typed the URL correctly
    3. Ensured that Virtual directory for this site is created
    4. There is only one web app created on the port 4500
    5. Ensured that I have correct password for managed account
    6.  I created a site on port 80 and it shows up without any issue
    7. No error message in Event vwr (windows logs)
    8. No error is logged in ULS logs (14\Logs)
    9. I have created another HTTP site with default URL(Name of the web server) on port 26214 and this one shows up without any issue.

    Why does the web app with custom URL (other than the default URL, which defaults to server name) doesn’t show up? Is it that,one can’t create an http site with custom URL?

    Thanks



    • Edited by vilas6_it Tuesday, February 14, 2012 12:41 AM
    Tuesday, February 14, 2012 12:39 AM

Answers

  • Hi, if your server is TSTSVR and the default URL is http://tstsvr:4500, you will be able to browse to it without issues.
    However, if you give the URL as http://customurl:4500, then there has to be a server named CUSTOMURL where this app is hosted on port 4500 or the host header has to exist in the DNS or the local system's host file.


    Arvit

    • Marked as answer by vilas6_it Tuesday, February 14, 2012 5:52 PM
    Tuesday, February 14, 2012 1:22 AM
  • If you give a custom url you need to configure this at couple of places:

    1. Have the DNS entry to point to the server or a host header file on the client machine

    2. For the sharePoint site have a host header entry for the web application. Ensure this has been set in the iis. You can check the bindings in the web site (Web application)

    3. Ensure you have a setting in your alternate access mapping. THis can be checked in central admin.

    4. Lastly, check the zone you are working for that web application. 


    Varun Malhotra
    =================
    If my post solves your problem could you mark the post as Answered or Vote As Helpful if my post has been helpful for you.

    • Marked as answer by vilas6_it Tuesday, February 14, 2012 5:52 PM
    Tuesday, February 14, 2012 2:16 AM

All replies

  • Hi, if your server is TSTSVR and the default URL is http://tstsvr:4500, you will be able to browse to it without issues.
    However, if you give the URL as http://customurl:4500, then there has to be a server named CUSTOMURL where this app is hosted on port 4500 or the host header has to exist in the DNS or the local system's host file.


    Arvit

    • Marked as answer by vilas6_it Tuesday, February 14, 2012 5:52 PM
    Tuesday, February 14, 2012 1:22 AM
  • If you give a custom url you need to configure this at couple of places:

    1. Have the DNS entry to point to the server or a host header file on the client machine

    2. For the sharePoint site have a host header entry for the web application. Ensure this has been set in the iis. You can check the bindings in the web site (Web application)

    3. Ensure you have a setting in your alternate access mapping. THis can be checked in central admin.

    4. Lastly, check the zone you are working for that web application. 


    Varun Malhotra
    =================
    If my post solves your problem could you mark the post as Answered or Vote As Helpful if my post has been helpful for you.

    • Marked as answer by vilas6_it Tuesday, February 14, 2012 5:52 PM
    Tuesday, February 14, 2012 2:16 AM