none
Hide "Manage Content and Structure from Site Action

    Question

  • Hi All,

    I Have a SharePoint 2007 Intranet. We have Home Visitors Group having "Read" Access and We had to check "Browse Directories" in this group's permission because only Read Access permission user is not able to access tyhe website and getting "Access Denied" error. But a User having Read access is able to "Site Actions" and under it the "Manage Content and Structure". I want to hide this link for a specific Role like Read. Any ideas. please suggest.


    Thanks and Regards, Amreesh Sharma| MCTS MOSS 2007| SharePoint Administrator
    Tuesday, January 11, 2011 12:35 PM

All replies

  • Hi Amressh,

    You can achive this by following two ways

    Either

    Go to site Action > Site settings > Site Administration > Site features > Office SharePoint Server Publishing and deactivate it


    Or by modifying code in siteaction.xml file

    When the publishing page feature is activated, the data source for the “SiteAction” comes from the XML file which lies in the C:\Program Files\Common Files\Microsoft Shared\web server extensions\12\TEMPLATE\LAYOUTS\EditingMenu\Siteaction.xml.
    The menu items of Site Action is contained in that file and you can add easily new item in two ways:

    • with features if you want to have the ability to switch the feature on or off depending on site
    • editing a sharepoint file used to customize the menu item for all the sites


    To remove existing item you have to browse to the master page gallery in the site collection and edit “CustomSiteAction.xml” under “EditingMenu” folder.  Here you have to write custom node and set “ChangedNodeId” and “ConfigeMenu” property you can replace your custom console node with existing console node.


    Regards, Pratik Vyas | SharePoint Consultant | http://sharepointpratik.blogspot.com/
    Tuesday, January 11, 2011 1:53 PM
  • Can you be more specific please. i have this node for "Manage Content and Structure":

    <ConsoleNode Action="cms:ManageSiteAction" 
             DisplayText="cms,siteactions_managecontentandstructure_displaytext" 
             Description="cms,siteactions_managecontentandstructure_description" 
             UseResourceFile="true" 
             MenuGroupId="300" 
             Sequence="370" 
             PermissionContext="CurrentSite" 
             ImageUrl="/_layouts/images/smt_small.png"  
             ID="wsaManageSite"/>
       </structure>
    </Console>

    what changes do i need to make to disable "Manage Content and Structure" link in Site Actions.


    Thanks and Regards, Amreesh Sharma| MCTS MOSS 2007| SharePoint Administrator
    Tuesday, January 11, 2011 2:26 PM
  • Ok,

    exclude above code by making it as a comment

    <!-- <ConsoleNode Action="cms:ManageSiteAction" 
             DisplayText="cms,siteactions_managecontentandstructure_displaytext" 
             Description="cms,siteactions_managecontentandstructure_description" 
             UseResourceFile="true" 
             MenuGroupId="300" 
             Sequence="370" 
             PermissionContext="CurrentSite" 
             ImageUrl="/_layouts/images/smt_small.png" 
             ID="wsaManageSite"/>
       </structure>
    </Console> -->

    This will hide "Manage Content and Structure" link from site action


    Regards, Pratik Vyas | SharePoint Consultant | http://sharepointpratik.blogspot.com/
    Tuesday, January 11, 2011 2:35 PM
  • hi prateek ..thanks for your reply..but i am getting "object reference not set to an instance of an object" .

    what could be the reason.

     


    Thanks and Regards, Amreesh Sharma| MCTS MOSS 2007| SharePoint Administrator
    Tuesday, January 11, 2011 3:11 PM
  • Is that after changing xml file ?We just commented that parameter.

    if yes just revert back all changes and try to hide "Manage Content and Structure" by deactivating Publishing feature as I have mentioned earlier.


    Regards, Pratik Vyas | SharePoint Consultant | http://sharepointpratik.blogspot.com/
    Tuesday, January 11, 2011 3:16 PM
  • ok....for the user having Read permission he is not able to se the whole Site Actions and for the System account who is site Collection admin, its giving object reference not set to an instance of an object on the home page and other subsites. Do i need to deactivate publishing feature of whole site collection? Because on pre-production when i deactivated publishing feature it started giving this error:

    Server Error in '/' Application.

     


     

    Value does not fall within the expected range.

    Description:

     

    An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below.

    Stack Trace:


    [ArgumentException: Value does not fall within the expected range.]
       Microsoft.SharePoint.SPListCollection.GetListByName(String strListName, Boolean bThrowException) +418
       Microsoft.SharePoint.SPListCollection.get_Item(String strListName) +54
       Clx.Nb.SharePoint.Intranet.Controls.UploadDocumentLink.CreateChildControls() +101
       System.Web.UI.Control.EnsureChildControls() +146
       System.Web.UI.Control.PreRenderRecursiveInternal() +61
       System.Web.UI.Control.PreRenderRecursiveInternal() +224
       System.Web.UI.Control.PreRenderRecursiveInternal() +224
       System.Web.UI.Control.PreRenderRecursiveInternal() +224
       System.Web.UI.Control.PreRenderRecursiveInternal() +224
       System.Web.UI.Control.PreRenderRecursiveInternal() +224
       System.Web.UI.Control.PreRenderRecursiveInternal() +224
       System.Web.UI.Control.PreRenderRecursiveInternal() +224
       System.Web.UI.Control.PreRenderRecursiveInternal() +224
       System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) +3394

     
    Which i am not able to resolve yet. please suggest.


    Thanks and Regards, Amreesh Sharma| MCTS MOSS 2007| SharePoint Administrator
    Tuesday, January 11, 2011 3:35 PM
  • Anyone with his ideas about this issue here. Thanks in advance.
    Thanks and Regards, Amreesh Sharma| MCTS MOSS 2007| SharePoint Administrator
    Thursday, January 13, 2011 1:13 PM
  • I solved it by just updating the access right within all the lists. I heat this issue i spent 2 days till I solved it

    hudaalbar

    Thursday, April 19, 2012 4:05 PM