none
limit search for specific subsites

    Question

  • Hi to all!
    Such a question: can I configure search scope in way where I'll crawl only some range of subsites?
    I have root site collection / and site collections /sites/peers/ and /sites/it/. I want to configure my scopes in such way, where I''ll get search rezults only for "peers" in first way, and only for "it" in second.
    Can I do it with crawl rules?
    Monday, December 21, 2009 4:14 PM

Answers

  • You have asked two questions: "crawl only some range of subsite" and "configure my scopes", and I'm guessing it's a scopes questions. (let me know otherwise)


    Just add a custom search scope.

    You can do this for a site collection from Site Actions, or for the server from Central Administration.

    Here's the steps for a site collection:

    1) Go to your top level site in the site collection
    2) Go to Site Actions, Site Settings
    3) In the Site Collection Administration column click Search Scopes
    4) Click New Scope, enter a name (this will be displayed in the scope dropdown), description and checkmark where you want it displayed
    5) Click OK
    6) Find your new scope in the list and click Add Rules
    7) Click Web Address and enter the site URL  (http://servername/sites/peers), leave Include checked
    8) Click OK

    It may be a few minutes until the new scope shows up in the search dropdown list.

    Of course, the search service and timer jobs must be running.


    Mike Smith TechTrainingNotes.blogspot.com
    Monday, December 21, 2009 4:52 PM

All replies

  • You have asked two questions: "crawl only some range of subsite" and "configure my scopes", and I'm guessing it's a scopes questions. (let me know otherwise)


    Just add a custom search scope.

    You can do this for a site collection from Site Actions, or for the server from Central Administration.

    Here's the steps for a site collection:

    1) Go to your top level site in the site collection
    2) Go to Site Actions, Site Settings
    3) In the Site Collection Administration column click Search Scopes
    4) Click New Scope, enter a name (this will be displayed in the scope dropdown), description and checkmark where you want it displayed
    5) Click OK
    6) Find your new scope in the list and click Add Rules
    7) Click Web Address and enter the site URL  (http://servername/sites/peers), leave Include checked
    8) Click OK

    It may be a few minutes until the new scope shows up in the search dropdown list.

    Of course, the search service and timer jobs must be running.


    Mike Smith TechTrainingNotes.blogspot.com
    Monday, December 21, 2009 4:52 PM
  • One additional note... Custom scopes are only displayed in MOSS, not WSS and you must enable custom scopes: Site Actions, Site Settings, Search Settings, click Custom Scopes and enter the path to a MOSS search center site. (If your top level site is a publishing site then this typically the example shown: /SearchCenter/Pages
    Mike Smith TechTrainingNotes.blogspot.com
    Monday, December 21, 2009 5:15 PM
  • thx a lot :)

    And one more question: I can't understand why do I have rezults only for some of site collections during crawl content. All site collections (top and others) have publishing template and a lot off pages. All have anonimous access. I add default crawl account to all top level sites in site collections but have ruzelts only for top and one of below. For one of my below site collection I have only 2 crawled rezults http://sitename/sites/colection1 and http://sitename/sites/colection1/pages. What is the reason of such rezults?


    Tuesday, December 22, 2009 7:19 AM
  • I have added new custop scope at the top level site collection. But no rezult. Item Count - 0.
    I forgot to add - this is public internet site. I perfom search for local address in Central SP administration. And have no access (no ruzults in crawl) to internet web application of my portal. It's very dificalt to configure SP search :(
    Tuesday, December 22, 2009 7:41 AM
  • And one more note: this web application was migrated from CMS 2002. May it be the problem?
    Tuesday, December 22, 2009 8:51 AM