none
The tool was unable to install Application Server Role, Web Server (IIS) Role

    Question

  • when I install prerequisiteinstaller.exe in sharepoint 2013, got the below error:

    Error when enabling ASP.NET v4.0.30319

    Error: The tool was unable to install Application Server Role, Web Server (IIS) Role.

    Last return code (-2146646015)

    anyone can help this? thanks in advance.


    Awen

    Wednesday, October 31, 2012 7:02 AM

Answers

  • fixxed. just run te command:

    C:\Windows\Microsoft.NET\Framework64\v4.0.30319\aspnet_regii -enable -i


    Awen

    • Marked as answer by Awen Hu Friday, November 02, 2012 2:03 AM
    Friday, November 02, 2012 2:03 AM

All replies

  • Does the account you're logged in as belong to the "Local Administrators" group Awen?

    Have you tried adding the IIS Role via "Server Manager" > "Roles"


    Paul Turner http://redmanta.co.uk/blog Twitter: @RedMantaUK MCTS:WSS,MOSS,2010 MCITP:2010.
    Please remember to click "Propose As Answer" if a post solves your problem or "Vote As Helpful" if it was useful.

    Wednesday, October 31, 2012 8:39 AM
  • yes, it is.  added IIS role


    Awen

    Wednesday, October 31, 2012 9:44 AM
  • fixxed. just run te command:

    C:\Windows\Microsoft.NET\Framework64\v4.0.30319\aspnet_regii -enable -i


    Awen

    • Marked as answer by Awen Hu Friday, November 02, 2012 2:03 AM
    Friday, November 02, 2012 2:03 AM
  • I am facing the same issue..I have tried following things,

    1.Added IIS Roles

    2. Run aspnet_regii -enable -i

    2. Install Windows Features for SharePoint manually using Powershell( as suggested in http://support.microsoft.com/kb/2765260)

    But still it's giving the same error.

    Any clues?

    Rajesh

    Friday, December 28, 2012 6:50 AM
  • Create two roles one for "Application server" and "Web server (IIS)" in Server manager.

    Below are the links for creation in case of windows server 2012-

    http://support.simpledns.com/KB/a200/adding-application-server-server-role-net-framework.aspx

    http://www.iis.net/learn/get-started/whats-new-in-iis-8/installing-iis-8-on-windows-server-2012

    I faced the same issue and followed the above links for creation and later tool ran successfully.

    Tuesday, February 26, 2013 9:09 AM
  • Thanks a lot, this command working.

    i hope my issue has been resolved.

    Wednesday, March 13, 2013 8:44 AM
  • Hi,

    This issue has been addressed by following knowledge based article

    http://support.microsoft.com/kb/2765260

    There are three or four sections to this document, for me following section did the trick.

    "

    1. Offline method: Server is not connected to the Internet

      To install the Roles and Features that are required by SharePoint 2013 on Windows Server 2012 in an offline environment, you must have access to the Windows Server 2012 installation media. You can then run the same Windows PowerShell commands that you used in Method 2, but you must use the -source parameter to specify the location of the required files on the installation media.

      For example, assume that you mounted the Windows Server 2012 installation media (ISO) to drive D of the server. Then, the path to provide for the -source parameter is as follows:
      D:\sources\sxs

      Note Be aware that you can also copy the files locally or specify a UNC path where the installation files are stored.

      Open an elevated Windows PowerShell prompt on the SharePoint server (that is, Run as Administrator), and execute the following commands:
      Import-Module ServerManager
      Add-WindowsFeature NET-WCF-HTTP-Activation45,NET-WCF-TCP-Activation45,NET-WCF-Pipe-Activation45
      Add-WindowsFeature Net-Framework-Features,Web-Server,Web-WebServer,Web-Common-Http,Web-Static-Content,Web-Default-Doc,Web-Dir-Browsing,Web-Http-Errors,Web-App-Dev,Web-Asp-Net,Web-Net-Ext,Web-ISAPI-Ext,Web-ISAPI-Filter,Web-Health,Web-Http-Logging,Web-Log-Libraries,Web-Request-Monitor,Web-Http-Tracing,Web-Security,Web-Basic-Auth,Web-Windows-Auth,Web-Filtering,Web-Digest-Auth,Web-Performance,Web-Stat-Compression,Web-Dyn-Compression,Web-Mgmt-Tools,Web-Mgmt-Console,Web-Mgmt-Compat,Web-Metabase,Application-Server,AS-Web-Support,AS-TCP-Port-Sharing,AS-WAS-Support, AS-HTTP-Activation,AS-TCP-Activation,AS-Named-Pipes,AS-Net-Framework,WAS,WAS-Process-Model,WAS-NET-Environment,WAS-Config-APIs,Web-Lgcy-Scripting,Windows-Identity-Foundation,Server-Media-Foundation,Xps-Viewer <var>-Source D:\Sources\sxs</var>

      Your server will require a restart after you run this Windows PowerShell code.
    2. Install the other prerequisites that are required by SharePoint 2013.
    3. Run the Products Preparation Tool - PrerequisiteInstaller.exe again. "


    • Edited by Mandeep G Friday, May 03, 2013 2:06 AM
    • Proposed as answer by sstyhoo Tuesday, September 24, 2013 10:42 AM
    Friday, May 03, 2013 2:05 AM
  • After hours spent trying to figure this out, I tracked it down to the prereq installer and SharePoint not installing due to systemmangercmd.exe not being present in the system32 folder and thus not being able to run the step for the Roles.

    The blog post here will show you how to get the missing files and where to upload them. You will probably need to modify the folder security on the System32 to modify and add folders.

    http://danielcai.blogspot.co.nz/2012/05/install-crm-2011-on-windows-server-8.html

    Once the file was in place both prereq installer and full installer worked correctly.

    • Proposed as answer by Joachim Løe Tuesday, December 03, 2013 7:33 PM
    Friday, May 24, 2013 3:43 PM
  • Hi there,

    In my case it had to be aspnet_regiis -enable -i

    because without the s never ran.

    Thanks

    Big ups to you folks

    • Proposed as answer by Tracy'S Friday, July 11, 2014 7:29 PM
    Thursday, June 27, 2013 1:09 PM
  • This worked in my case. Thanks :)
    Thursday, November 28, 2013 1:22 PM
  • Worked on Server 2012 R2. Yet its not supported. But to get it installed, it worked. Thanks

    Joachim Løe | Crayon AS | MCITP: Enterprise Messaging Administrator 2010 / Lync Administrator 2010 / MCSA 2012

    Tuesday, December 03, 2013 7:33 PM
  • Thx a lot. I just copied/pasted the ServerManagementCMD.exe to the System32 forlder and the prerequisites worked great.
    Sunday, March 30, 2014 5:34 PM
  • rename the file C:\windows\System32\ServerManager.exe with ServerManagerCMD.exe

    then run prerequisiteinstaller

    • Proposed as answer by Retro.ru Tuesday, May 13, 2014 5:23 PM
    Monday, March 31, 2014 8:39 AM
  • I copied and then renamed, this also fixed my issue.  "rename the file C:\windows\System32\ServerManager.exe with ServerManagerCMD.exe"

    • Proposed as answer by JV_SubtleTech Wednesday, April 16, 2014 6:11 AM
    Tuesday, April 01, 2014 7:27 PM
  • Thanks , its working for me.
    • Proposed as answer by Search Wednesday, August 20, 2014 5:29 AM
    Friday, April 11, 2014 12:22 PM
  • Thanks a lot, it worked for me.
    Tuesday, April 15, 2014 10:45 AM
  • The option to make a copy and then rename the file is a much better solution than simply renaming the file.  This will ensure that anything else looking for the old version can find it (since it's an exe file and not a DLL).
    Wednesday, April 16, 2014 6:13 AM
  • To solve the issue I set the following Local Policy:

    1. – Windows Start

    2. – run MMC

    3. – Click File, Add/Remove Snap-in…

    4. – Select Group Policy Object Editor and ADD it

    5. – Navigate to Administrative templates / System

    6. – Select and edit “Specify Settings for optional component installation and component repair”

    7. – Enable and select “Contract Windows Update directly to download repair content instead of Windows Server Update Services (WSUS)”

    http://sharelockpoint.wordpress.com/2013/09/09/sharepoint-2013-pre-requisites-install-fail-error-the-tool-was-unable-to-install-application-server-role-web-server-iis-role/

    Friday, April 18, 2014 7:57 AM
  • Yes. This works! Thanks
    Tuesday, April 29, 2014 7:51 AM
  • Thanks, this worked for me too
    Monday, May 05, 2014 10:15 AM
  • why did we have this problem, why does it make sense to have this type of problems in a clean installation

    why are these problem legal? why can't we get our money back?


    Fer

    Wednesday, May 07, 2014 6:15 PM
  • Hi! This one helped, I think along with other tasks I made according to list above. I did:

    1. Powershell feauture online installation,

    2. Permissions set on system32 folder

    3. Finally, when nothing worked, I renamed servermanager.exe to servermanagercmd.exe

    After that it worked like a charm!

    DON'T FORGET to rename this file back from servermanagercmd.exe to servermanager.exe! Because after restart you will see error saying that server manager link is not available, and setup of sharepoint will start again (no harm though, it will finish witn note that nothing requires to update).

    BR,

    Retro

    Tuesday, May 13, 2014 5:22 PM
  • Copying ServerManager.exe to ServerManagerCMD.exe on W2k12R2 for SP2013 resolved the issue.
    Thursday, May 15, 2014 8:47 PM
  • rename the file C:\windows\System32\ServerManager.exe with ServerManagerCMD.exe

    then run prerequisiteinstaller


    This worked for me.
    Monday, May 19, 2014 3:59 PM
  • I copied and then renamed, this also fixed my issue.  "rename the file C:\windows\System32\ServerManager.exe with ServerManagerCMD.exe"


    This is what I did actually and it worked.
    Monday, May 19, 2014 4:00 PM
  • am logged in as Administrator, but don't have permission to change the find name ServerManager.exe and can't even change the permission,! 

    Sameh Sabil

    Tuesday, May 20, 2014 10:58 PM
  • I was able to copy the file, paste onto my desktop, rename, and paste back into system32.  It worked after that.  Does anybody have advice on how to give oneself permission?  I am also logged in as root system administrator and unable to change permissions so I can actually delete/change the original file. 
    Friday, May 23, 2014 6:41 PM
  • this worked for me to. Awesome
    Tuesday, May 27, 2014 9:47 AM
  • Awesome! you are a Star, thank you :)
    Saturday, July 19, 2014 10:16 AM
  • Yes, make a copy. This worked for me.
    Monday, August 25, 2014 3:51 PM
  • I am on Windows Server 2008 R2 SP1 and the command was "aspnet_regiis" instead of "aspnet_regii". THANKS!!
    Sunday, September 14, 2014 7:36 PM
  • Yeah! Year 2014 and still this bug not fixed!
    Monday, September 22, 2014 12:13 PM
  • WORKED!!
    Monday, September 22, 2014 2:55 PM
  • After following the below steps I was able to get the issue resolved.

    To solve the issue I set the following Local Policy:

    1. – Windows Start

    2. – run MMC

    pre1

    3. – Click File, Add/Remove Snap-in…

    pre2

    4. – Select Group Policy Object Editor and ADD it

    pre3

    5. – Navigate to Administrative templates / System

    pre4

    6. – Select and edit “Specify Settings for optional component installation and component repair”

    7. – Enable and select “Contract Windows Update directly to download repair content instead of Windows Server Update Services (WSUS)”

    pre5

    9.- Re run the prerequisite installation

    Reference: http://sharelockpoint.wordpress.com/2013/09/09/sharepoint-2013-pre-requisites-install-fail-error-the-tool-was-unable-to-install-application-server-role-web-server-iis-role/

    Wednesday, September 24, 2014 3:35 AM