none
NT Authority getting forbidden error in MOSS teamsites

    Question

  • Hello,

    I am really finding myself in a weird situation now. We have a teamsite in MOSS, and for some reason, it is not allowing NT Authority\Authenticated Users to get into the site, even when making it authenticated to all.

    The home page of the teamsite is completely clean, no page viewer or other user control that can cause this. Strange thing is, if i add the user as a reader, then he can access, but if i remove him and just have authenticated users, it's giving forbidden error. Not sure why this is happening, but it seems like this is the problem with just one teamsite, other teamsites are working perfectly OK.

    any idea why this could be happening? Could it be the case that the content DB is corrupted? But in that case, all site collections in that content DB should have been affected, but that is not the case....am not finding any clue!!!

    Help needed!

    -xwindow

    Thursday, March 19, 2009 11:51 PM

Answers

  • Hello,

     

    Based on my experience with similar issues. This case is very possible due to some wrong values in the columns from the content database.

     

    I include a workaround for this possibility:

     

    1. Open the site you are having trouble with, but make sure you open the site with site collection admin/owner rights.


    2. Site Actions> Site Settings> Advanced Permissions> Click on the All People link in quick launch> Then select List Settings, then Advanced Settings.

    3. Change the Read Access Value to “All Items”

     

    4. Change the Edit Access to “All Items”. This will modify those values in the database back to normal.


    Then, test the issue again and let us know the result. Thanks.

     

    Best Regards,

    Lionel

    • Marked as answer by xwindow Friday, March 27, 2009 8:27 PM
    Thursday, March 26, 2009 11:12 AM

All replies

  • Hello,

     

    Based on my experience with similar issues. This case is very possible due to some wrong values in the columns from the content database.

     

    I include a workaround for this possibility:

     

    1. Open the site you are having trouble with, but make sure you open the site with site collection admin/owner rights.


    2. Site Actions> Site Settings> Advanced Permissions> Click on the All People link in quick launch> Then select List Settings, then Advanced Settings.

    3. Change the Read Access Value to “All Items”

     

    4. Change the Edit Access to “All Items”. This will modify those values in the database back to normal.


    Then, test the issue again and let us know the result. Thanks.

     

    Best Regards,

    Lionel

    • Marked as answer by xwindow Friday, March 27, 2009 8:27 PM
    Thursday, March 26, 2009 11:12 AM
  • Thanks Lionel!

    That did the trick, but I am still not sure why simply changing the Edit access to "All items" resolved the issue.

    If you can let me know like which column value in the content DB was wrong, then that would be great. Also, what can cause this wrong values to be there in the content DB?

    But anyways, thanks for your help and the issue is resolved.

    Regards,
    -xwindow

    • Proposed as answer by Smail BRADAI Thursday, February 28, 2013 3:13 PM
    Friday, March 27, 2009 8:30 PM
  • Hi Lionel,

    could you please describe point two of your solution in more detail?

    As I understand in no. 2 you talk about Site settings, whereas points 3 and 4 refer to settings that are available in list permissions only. Aren't you talking about two different things at the same time?

    Thank you for your answer.

    Rene21

    EDIT: Think I got your point: these "list settings" are available on site collection level only, aren't they? I checked there but the settings were already as you recommended. Is there another possible reason for the problem?
    Friday, May 08, 2009 7:52 AM
  • Hello, I'm accessing the site as key user. Still I can't find the advanced permissions you are talking about. What kind of access do I need to have in order to change this setting?
    Monday, April 08, 2013 1:24 PM