none
blank site template in sharepoint 2013

    Question

  • Hi,

    In sharepoint 2010 when we want to create a blank sub site it is possible to choose blank site templates. But in sharepoint 2013 blank site template is not displayed in the selection. Is there any configuration to be made to make blank site template to be available for selection.

    Thanks

    Monday, November 26, 2012 11:08 AM

Answers

  • In 2013 (RTM) you can only create a blank site using Powershell.  Its been removed from the UI even when creating a Site Collection.  However you can still create one using Powershell by referencing Template STS#1.

    Paul Stork SharePoint Server
    MVP Principal Solutions Architect: BlueChip Consulting Group
    Blog: http://dontpapanic.com/blog
    Twitter: Follow @pstork
    Please remember to mark your question as "answered" if this solves your problem.

    • Proposed as answer by Paul Turner _ Monday, November 26, 2012 1:47 PM
    • Marked as answer by rbmanian75 Monday, November 26, 2012 2:18 PM
    Monday, November 26, 2012 1:16 PM

All replies

  • In 2013 (RTM) you can only create a blank site using Powershell.  Its been removed from the UI even when creating a Site Collection.  However you can still create one using Powershell by referencing Template STS#1.

    Paul Stork SharePoint Server
    MVP Principal Solutions Architect: BlueChip Consulting Group
    Blog: http://dontpapanic.com/blog
    Twitter: Follow @pstork
    Please remember to mark your question as "answered" if this solves your problem.

    • Proposed as answer by Paul Turner _ Monday, November 26, 2012 1:47 PM
    • Marked as answer by rbmanian75 Monday, November 26, 2012 2:18 PM
    Monday, November 26, 2012 1:16 PM
  • HI,

    Thank you...managed to create with sharepoint server api sdk.

    thanks

    Monday, November 26, 2012 2:18 PM
  • The easiest way to permanently add blank site template is through the server files.

    "C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\15\TEMPLATE\1033\XML\WEBTEMP.XML"

    Change the Hidden=true to false and you're good to go.

    Cheers


    Benjamin Niaulin Blog: http://bniaulin.wordpress.com

    Twitter: @bniaulin


    • Edited by Benjamin NiaulinMVP Thursday, November 29, 2012 3:06 PM spelling
    • Proposed as answer by JLSF Monday, March 18, 2013 12:01 PM
    Thursday, November 29, 2012 3:06 PM
  • Sweet.  I hadn't noticed that they removed it from the UI.  I for one am glad because it always causes things to trip up as I'm building solutions out.  There have historically been too many behind the scenes pieces missing from Blank sites.  I recommend using the Team site template and removing the lists you don't want.  That way you don't run into something mysteriously not working only to find out its because you used the Blank template. 

    Just my 2c. 

    Wes


    SharePoint Consultant | SharePoint MVP | My Blog | Minnesota SharePoint User Grop (MNSPUG)

    Friday, November 30, 2012 8:17 PM
  • The Blank Site template is hidden in the UI, but you can unhide it.

    Navigate to C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\15\TEMPLATE\1033\XML\WEBTEMP.XML and update the following section:

    <Configuration ID="1" Title="Blank Site" Hidden="TRUE" ImageUrl="/_layouts/15/images/stbs.png?rev=23" Description="A blank site for you to customize based on your requirements." DisplayCategory="Collaboration" AllowGlobalFeatureAssociations="False" > </Configuration>

    Thursday, January 23, 2014 9:34 PM