none
insert webpart - page error

    Question

  • Hi,

    i have created a webpart, and tested this locally on my computer.

    after this i have uploaded to the server, and activated the feature on a site collection.

    when i add the web part on a page i recieve a " An unexpected error has occurred.".

    when i take a look at my page with the designer, i can see the webpart without errors.

    what i'm i missing

    Monday, June 18, 2012 3:08 PM

Answers

  • This is a user friendly error.I was telling the same thing as the error details says...If you enable page trace by editing web config , you would see , actual error.

    Ashish Ranjan (Please click "Marked As Answer" if a post solves your problem or "Vote As Helpful" if a post has been useful to you)

    • Marked as answer by kim.vlas Monday, June 18, 2012 3:54 PM
    Monday, June 18, 2012 3:35 PM

All replies

  • Enable Page level error trace  and call stack from web config to see the actual problem.

    in the web application web config make following changes to two attributes

    CallStack="true"

    AllowPageLevelTrace="true"

    and search for  customErrors and make to Off. This will show you exact error. Let me know


    Ashish Ranjan (Please click "Marked As Answer" if a post solves your problem or "Vote As Helpful" if a post has been useful to you)

    Monday, June 18, 2012 3:28 PM
  • now i see more detail.

    i have not yet deployed alot of web parts on the server so i'm a little confused what the issue is.

    Runtime Error

    Description: An application error occurred on the server. The current custom error
    settings for this application prevent the details of the application error from
    being viewed remotely (for security reasons). It could, however, be viewed by
    browsers running on the local server machine.

    Details: To enable
    the details of this specific error message to be viewable on remote machines,
    please create a <customErrors> tag within a "web.config" configuration
    file located in the root directory of the current web application. This
    <customErrors> tag should then have its "mode" attribute set to "Off".
    Monday, June 18, 2012 3:32 PM
  • This is a user friendly error.I was telling the same thing as the error details says...If you enable page trace by editing web config , you would see , actual error.

    Ashish Ranjan (Please click "Marked As Answer" if a post solves your problem or "Vote As Helpful" if a post has been useful to you)

    • Marked as answer by kim.vlas Monday, June 18, 2012 3:54 PM
    Monday, June 18, 2012 3:35 PM
  • thankx i think i see the fault.

    i'm missing a list, this is quit strange because if no list i available il show a message.

    Monday, June 18, 2012 3:54 PM