none
Server Error in '/' Application.

    Question

  • There is one website I used to be able to access, http://www.breckenridge.com , that now generates this message on one of my computers.

    Why all of a sudden am I blocked on this one computer, and how can I fix this?

    Runtime Error

    Description: An application error occurred on the server. The current custom error settings for this application prevent the details of the application error from being viewed remotely (for security reasons). It could, however, be viewed by browsers running on the local server machine.

    Details: To enable the details of this specific error message to be viewable on remote machines, please create a <customErrors> tag within a "web.config" configuration file located in the root directory of the current web application. This <customErrors> tag should then have its "mode" attribute set to "Off".

    <!-- Web.Config Configuration File -->
    
    <configuration>
        <system.web>
            <customErrors mode="Off"/>
        </system.web>
    </configuration>

    Notes: The current error page you are seeing can be replaced by a custom error page by modifying the "defaultRedirect" attribute of the application's <customErrors> configuration tag to point to a custom error page URL.

    <!-- Web.Config Configuration File -->
    
    <configuration>
        <system.web>
            <customErrors mode="RemoteOnly" defaultRedirect="mycustompage.htm"/>
        </system.web>
    </configuration>
    Friday, January 06, 2012 4:08 AM

All replies

  • Hi,

    It seems that it is related to one of the web servers you have in your farm. The computer from where you are fcaing this issue might be hitting that and getting such response. Check the following:

    1. Login to each WFE server in your farm.

    2. Try browsing the site.

    3. If you find the above problem do an app pool recycle to fix if this does not help do the IISRESET to check as well.

    4. If the above step does not work then enable stack trace as shown in the error message and observe it exactly to take further actions.


    Thanks, Rahul Rashu
    Friday, January 06, 2012 4:27 AM
  • Hi Rsmith3400,

    You should go on the server and open the virtualdirectory of you're web application.. (breckenrigde)

    open the Web.Config file and change the customerros from "remoteLonly" to "Off" and set the callstack to "true".

     

    Gokan


    Founder of SharePoint CookBook: http://www.GokanOzcifci.be
    Microsoft Certified Technology Specialist: SharePoint 2010, Configuring
    Microsoft Certified Personal
    Friday, January 06, 2012 10:22 AM
  • An error like this will also generate an error in the Windows Event Log on the server, you should be able to check this for details. There should also be even more detail in the SharePoint ULS logs which by default will be in C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\12\LOGS on the server.
    Friday, January 06, 2012 12:05 PM
  • Sorry, but you lost me on that one.  Don't have a clue how to do that.
    Saturday, January 07, 2012 12:56 AM
  • So I should go to the web page that is causing the error, then open the Web.Config file and change the customerros from "remoteLonly" to "Off" and set the callstack to "true".

    Saturday, January 07, 2012 12:58 AM
  • Hi,

    No you nreed to go to the directory where you have stored your virtual directories in the server.

    There you need to open the web.config for this specific web application and then you can open web.config to do the same.

    I hope this will help you out.


    Thanks, Rahul Rashu
    Saturday, January 07, 2012 4:14 AM
  • Rsmith3400,

    You should go to you're application server or web front end server .. and open you're virtual directory so you can change you're web.config ..

     

    1) %systemroot%\inetpub\wwwroot\VIRTUALDIRECTORY\web.config Open it with NotePad and search "customErrors" and set the property to "off".. Even still search for callstack and set the propertie to "true"

    2) Open IIS, go to you're website, rightclik and select "explore" it should open the same path as  %systemroot%\inetpub\wwwroot\VIRTUALDIRECTORY\web.config ...


    Founder of SharePoint CookBook: http://www.GokanOzcifci.be
    Microsoft Certified Technology Specialist: SharePoint 2010, Configuring
    Microsoft Certified Personal
    • Marked as answer by Pengyu Zhao Thursday, January 12, 2012 7:38 AM
    • Unmarked as answer by Mike Walsh FIN Friday, January 13, 2012 4:33 AM
    Saturday, January 07, 2012 8:27 AM
  • Hi RSmith3400,

    WAIT - Uh, hold on before you add that <customErrors> tag -

    Having SharePoint give a runtime error that is this generic is a DELIBERATE act by Microsoft to enhance security to the SharePoint Farm. Changing the web.config files to drop this security allows people outside to see the actual cause of the error, which could result in your farm being vulnerable to attack.

    Simply put, certain types of attack on your servers could result in an error; this could in turn, show a potential vulnerability if the web.config allows errors to be shown via the web browser. Hacker forces an error, server shows things you don't want it to - not good.

    Instead -

    1. Build a host entry in /drivers/etc/hosts on a client PC (preferably two - one inside and one outside the network). Point this entry with the http://www.breckenridge.com name to each Web server in turn and see if a particular server is giving you trouble.

    2. Once you've determined which server is giving you trouble, Remote Desktop directly into its console and open the http://www.breckenridge.com URL; if it gives you issues, the error message will again be displayed, but should show you a detailed error instead of the generic one.

    Oh, and by the way, altering the web.config in any way for a Web App will immediately result in it being automatically being reset, resulting in a potential outage, even a momentary one. If the web.config is not correctly altered (make a backup first), the Web App will not start back up correctly.

    If you do need to alter a web.config to show the errors, make sure to not expose that server to the outside world (perform a drainstop in your load balancer, temporarily remove it from external DNS, etc.). Just my 2 cents.

    Hope this helps,

     


    Troy Lanphier -- MCT/MCSE/MCITP SharePoint Server 2010 Administration -- Author: Microsoft SharePoint Foundation 2010 Inside Out -- http://blog.sharepointcookbook.com
    Sunday, January 08, 2012 4:08 AM
  • Troy,

    You're funny with you're "Changing the web.config files to drop this security allows people outside to see the actual cause of the error, which could result in your farm being vulnerable to attack. Simply put, certain types of attack on your servers could result in an error; this could in turn, show a potential vulnerability if the web.config allows errors to be shown via the web browser. Hacker forces an error, server shows things you don't want it to "

    It's not totaly wrong, but you can always set the value as is was, when you're finished with debugging.. So where is the problem? You're making you're live miserably, when you can do everything easy..

    I'am not saying thay you're wrong or something like that, just, it can easier.. LOT of easier. :) just change values, debug, and set values again as it was..

    Gokan


    Founder of SharePoint CookBook: http://www.GokanOzcifci.be
    Microsoft Certified Technology Specialist: SharePoint 2010, Configuring
    Microsoft Certified Personal
    Monday, January 09, 2012 10:18 PM
  • Maybe I'm at the wrong place.  I'm just having a difficulty viewing someone else website.  I don't own a server or have a "farm"  Just a pc owner running xp.  I checked the config file and it has no "customerros"  C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\CONFIG
    Friday, January 13, 2012 4:05 AM
  • If you are only running a client PC you will need to contact the people in control of the SharePoint system you are accessing.

    They are the ones who will need to change the web.config file as described in your first post. Even that will only mean that next time you try to access the site you will get a more specific error message that again you will need to report to them in order for them to take appropriate action.

    In short the problem is with the server and only people administrating the server can clear it.


    SP 2010 "FAQ" (mainly useful links): http://wssv4faq.mindsharp.com/default.aspx
    WSS3/MOSS FAQ (FAQ and Links) http://wssv3faq.mindsharp.com/default.aspx
    Both also have links to extensive book lists and to (free) on-line chapters
    Friday, January 13, 2012 4:32 AM
  • Hi rsmith3400,

    I see what you mean now. If you had been able to see the site but can no longer, it may be that they have changed the configuration of the web servers and your client PC is remembering a connection to a server that is no longer intended to be one of the web servers. If this is the case, there may be a simple fix, to get your computer to "forget" the wrong web server.

    On your computer, click Start -> Run and then type Cmd and press <Enter>. Next, type: ping www.breckenridge.com and press <enter>. On my client PC, I see an address of 72.246.120.54 as their web server(s), pointed to a dns name of e3980.c.akamaiedge.net. You should see the same...

    Hope this helps

     


    Troy Lanphier -- MCT/MCSE/MCITP SharePoint Server 2010 Administration -- Author: Microsoft SharePoint Foundation 2010 Inside Out -- http://blog.sharepointcookbook.com
    Saturday, January 14, 2012 2:23 AM
  • Hi Troy, thanks for helping.  When I ping, here is the result:

    Microsoft Windows XP [Version 5.1.2600]
    (C) Copyright 1985-2001 Microsoft Corp.

    C:\Documents and Settings\Richard>ping www.breckenridge.com

    Pinging e3980.c.akamaiedge.net [184.86.88.54] with 32 bytes of data:

    Reply from 184.86.88.54: bytes=32 time=43ms TTL=56
    Reply from 184.86.88.54: bytes=32 time=39ms TTL=56
    Reply from 184.86.88.54: bytes=32 time=44ms TTL=56
    Reply from 184.86.88.54: bytes=32 time=40ms TTL=56

    Ping statistics for 184.86.88.54:
        Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
    Approximate round trip times in milli-seconds:
        Minimum = 39ms, Maximum = 44ms, Average = 41ms

    C:\Documents and Settings\Richard>

    When I try going to www.breckenridge,com I get directed to:

    http://www.breckenridge.com/VailResorts/Util/500.aspx?aspxerrorpath=/default.aspx

    Thanks, Rick Smith

    Saturday, January 14, 2012 3:56 AM
  • Hi Rick,

    Not quite sure what to do next - I checked this evening and got an entirely different IP address. You might contact the breckenridge folks and let them know about their issue - I checked on my PC again and had no issue, but they may have a misconfiguration (I am assuming you did the ipconfig /flushdns)...

    Regards, 


    Troy Lanphier -- MCT/MCSE/MCITP SharePoint Server 2010 Administration -- Author: Microsoft SharePoint Foundation 2010 Inside Out -- http://blog.sharepointcookbook.com
    Sunday, January 15, 2012 5:20 AM
  • Hi troy, I hadn't tried ipconfig/flushdns, but unfortunately it didn't work.  Since this only happens on this one pc, I'm thinking it's not the website, just a setting on this pc.  Any suggestion who might know what to do next somewhere on the web?  Thanks, Rick.
    Monday, January 16, 2012 3:05 AM