none
Central Admin not opening

    Question

  • error: 501 service
    unavailable error
    Application pool ofcentral admin is getting stopped automatically( Version moss 2007 and app pool
    is 7)
    Steps done but did not help :

     1.Reset the password of app
         pool account

     2.Updated farm credentials by
         using stsadm

     3.Changed the app pool of
         central admin site , here my finding is which ever the app pool I assign
         to central admin site that app pool is getting stopped automatically. I
         assume this is something wrong with web site.

    Please help me out. This issue occurred all of sudden...


    Thanks, Ram Ch

    Thursday, April 05, 2012 8:03 PM

Answers

  • Have you performed all the steps on ALL the SharePoint Servers.

    Make sure the account is a part of following groups on all the SharePoint servers and has a db_owner/creator and db_securityadmin roles in SQL.

    Administrators
    IIS_IUSRS
    WSS_ADMIN_WPG
    WSS_WPG
    WSS_RESTRICTED_WPG

    Before you follow the steps on all the servers please try to clear the config cache from all the servers by

    http://blogs.msdn.com/b/josrod/archive/2007/12/12/clear-the-sharepoint-configuration-cache-for-timer-job-and-psconfig-errors.aspx

    > stopping the SharePoint Administration and the Timer services from services.msc

    > take a back up of the xml files and deleting them

    > set the cache.ini to 1

    > run stsadm -o execadmsvcjobs

    > make sure xml files are getting generated and then start the SharePoint Administration and the Timer services from services.msc

    > Follow all the steps as per http://support.microsoft.com/kb/934838

    > Manually update the app pool identity for CA site

    > Once CA site is up > Update the App pool identity for each Application pool by going to CA > Operations > Service Accounts


    Regards, Vishwas

    Monday, April 09, 2012 5:33 AM

All replies

  • Are there errors in the Application Log?

    Jason Warren
    Infrastructure Specialist
    Habañero Consulting Group
    www.habaneros.com/blog

    Thursday, April 05, 2012 8:15 PM
  • Thanks for the reply.Here is the Event Logs Error Jason.


    Thanks, Ram Ch

    Friday, April 06, 2012 3:38 AM
  • Hi,

    Try to restart below service.

     Go to Start->Run and type services.msc and restart the Windows Timer services(which should use the newly changed password).

    Let us know your result


    Cheers, Hemendra-MCTS "Yesterday is just a memory,Tomorrow we may never see"

    Friday, April 06, 2012 5:51 AM
    Moderator
  • Tried Agarwal. No luck..still the same error :(


    Thanks, Ram Ch

    Friday, April 06, 2012 9:24 AM
  • Check this thread answer. Peoples have solved their problem by following Manjesh.V.C answer.

    http://social.technet.microsoft.com/Forums/en-US/sharepointadmin/thread/46d8667f-c0f6-4f8c-8c65-a6d4cd398e02/

    Let us know if it works


    Cheers, Hemendra-MCTS "Yesterday is just a memory,Tomorrow we may never see"

    Friday, April 06, 2012 10:13 AM
    Moderator
  • HI ramch,

    according to your description and screenshot you attached here. i think you updated farm credentials with a wrong approach , especially if you farm contains multiple servers . so my recommendation for you is ReUpdate farm Credentials again but you have to follow the instructions from here http://support.microsoft.com/kb/934838  this is an official article , so try to apply my recommendations and give me your feed back.

     


    Best Regrads, Ahmed Madany MCTS @twitter http://twitter.com/ahmed_madany @Blog http://ahmedmadany.wordpress.com @tumblr http://ahmedmadany.tumblr.com

    Saturday, April 07, 2012 10:58 AM
  • Thanks Ahmed for the reply.

    This is getting solved when i changed crawling settings to crawl all servers in farm. but this problem is keep occuring If i change crawl server to dedicated front end server. I am not sure what is happening here. Our requirement is to set dedicated front server for crawling, but if i chose this option I am facing above issue.

    Can you please help me out drill down the issue.

    I have referred following blogs but did not help much. Thanks.

    http://sharepointdungeon.blogspot.com/2010/02/moss-2007-search-config-and-ssp-admin.html

    http://technet.microsoft.com/en-us/library/cc261810(v=office.12).aspx


    Thanks, Ram Ch

    Saturday, April 07, 2012 9:00 PM
  • And Ahmed, I have followed the article which you have specified but did not work.

    Thanks, Ram Ch

    Sunday, April 08, 2012 8:06 AM
  • Have you performed all the steps on ALL the SharePoint Servers.

    Make sure the account is a part of following groups on all the SharePoint servers and has a db_owner/creator and db_securityadmin roles in SQL.

    Administrators
    IIS_IUSRS
    WSS_ADMIN_WPG
    WSS_WPG
    WSS_RESTRICTED_WPG

    Before you follow the steps on all the servers please try to clear the config cache from all the servers by

    http://blogs.msdn.com/b/josrod/archive/2007/12/12/clear-the-sharepoint-configuration-cache-for-timer-job-and-psconfig-errors.aspx

    > stopping the SharePoint Administration and the Timer services from services.msc

    > take a back up of the xml files and deleting them

    > set the cache.ini to 1

    > run stsadm -o execadmsvcjobs

    > make sure xml files are getting generated and then start the SharePoint Administration and the Timer services from services.msc

    > Follow all the steps as per http://support.microsoft.com/kb/934838

    > Manually update the app pool identity for CA site

    > Once CA site is up > Update the App pool identity for each Application pool by going to CA > Operations > Service Accounts


    Regards, Vishwas

    Monday, April 09, 2012 5:33 AM
  • Hello Ramch011,

    As per your reply on Saturday, April 07, 2012 9:00 PM. you mentioned that if you select all servers for crawl issue doesn't reproduce.

    Can you verify when you select as dedicated server does any entry get created in Host file of the server as added by office search service ?

    Also uncheck the IPv6 option in the NIC.

    Thank you,

    SUSHD

    Monday, April 09, 2012 1:10 PM