none
Excel Services - hide sheet tabs

    Question

  • I have a PivotChart linked to a SharePoint list which I am displaying in a SharePoint page using the Excel Web Access web part.

    The Excel file does not display sheet tabs (there is only one sheet) as I have set the option to hide sheet tabs in this workbook. However Excel Web Access displays a navigation bar below the chart with the sheet tab showing. I can't find an option in the Web Part Properties relating to this. Is this by design, or a bug? Or am I just missing the option and it is there somewhere?

    Thursday, February 23, 2012 10:02 AM

All replies

  • Hello,
     
    you could try to set the sheets to VeryHidden in the VBE. Do they still show then?
     
     

    cheers, teylyn
    Thursday, February 23, 2012 10:22 AM
  • Excel requires that at least one sheet is visible at all times, meaning that this will not work.

    Thanks for the idea though...


    RMeek

    Thursday, February 23, 2012 11:41 AM
  • Hi Rob,

    Did the Excel Web Access Web Part add and connect to the Excel file before you hide sheets for the Excel file?

    If so, please delete the Excel Web Access Web Part and add a new one, then the hidden sheets will not show any more.

    Best regards,
    Emir


    Emir Liu

    TechNet Community Support

    Tuesday, February 28, 2012 11:07 AM
  • Actually it's not the sheets that I am concerned with; as my original post stated it is the sheet TABS that won't hide.

    The setting was changed in Excel Options to hide the tabs for the relevant workbook, and then the workbook was saved to SharePoint. After that the Excel Web Access web part was added to a new page and linked to the workbook.

    It seems that the web part ignores the setting and displays the tabs. The only workaround I can think of is to use named items - setting the web part to use a named item seems to ignore any peripheral content.

    Unfortunately this workaround is not practical as my workbook has two pivotcharts and two slicers.


    RMeek

    Tuesday, February 28, 2012 11:39 AM
  • Hi,

    Sorry for my mistake. And I'm trying to involve someone familiar with this topic to further look at this issue. There might be some time delay. Appreciate your patience.

    Thanks & Regards,
    Emir


    Emir Liu

    TechNet Community Support

    Thursday, March 01, 2012 12:05 PM
  • You can use 'Publish' function provided by Excel. Then choose only the sheet you want to publish


    Regards, Nighting Liu

    Thursday, March 01, 2012 1:09 PM
  • Thanks for the idea - unfortunately it didn't solve the problem!

    Just tried it and - yes - it does only show the worksheet that is selected to be published.

    But the tab bar (with just the one tab for the published sheet) is still showing...


    RMeek

    Thursday, March 01, 2012 1:41 PM
  • Hi RMeek,

    I do believe you can hide it by the excel web part settings. I ever made this done, trust me.


    Regards, Nighting Liu

    Thursday, March 01, 2012 1:49 PM
  • The only setting in the Excel Web Access web part that can achieve this is to restrict the web part to displaying a named object.

    I have tried grouping the two charts and slicers on my worksheet, naming the object and putting that name in the Web Part setting.

    Excel Web Access displays an error stating that Grouped Slicers are not supported.


    RMeek

    Thursday, March 01, 2012 2:13 PM
  • Hello RobMeek,

    The issue sounds like a design limitation. You may open a support ticket with MS to find more - 

    http://support.microsoft.com/default.aspx?id=fh;en-us;offerprophone

    However, other members of the community may still have encountered the issue you're seeing, and have a solution to offer!

    Regards,

    Jing Wang | Microsoft Online Community Support

    Friday, March 16, 2012 4:04 PM
  • Maybe you can add a bit of CSS/Style modification to a Content Editor Web part to hide the "tab bar".

    /bac

    Friday, March 16, 2012 6:26 PM
  • Adding the below CSS worked for me:


    <style type="text/css"> ul.ewa-stb-tabs li { visibility : hidden } </style>
    Wednesday, April 17, 2013 4:24 PM