none
Is SharePoint Compatible With Firefox ?

    Question

  • Hi
    i want to review my word documents by Selecting this item : Edit In Microsoft Office Word in firefox, but the following message display me :

    'Edit Document' requires a Windows SharePoint Services-compatible application and Microsoft Internet Explorer 6.0 or greater.

    wheras when follow those steps with IE6, it works correctly.
    my question is that does sharepoint Document Library compatible with firefox 3.0 ?
    thanks

    this is my Signature
    • Edited by Mike Walsh FIN Tuesday, October 28, 2008 12:42 PM Does changed to Is in Subject
    Tuesday, October 28, 2008 10:24 AM

Answers

All replies

  • For full functionality always use IE 5.5 and upwards.

    You can use Firefox; Chrome; Safari etc. with SharePoint sites and most things will work but for instance anything that requires ActiveX support will not work and the integration with the Office products (as you have seen) is not complete if you are not using IE.
    Tuesday, October 28, 2008 12:43 PM
  • You could take a look at this add-on for Firefox: https://addons.mozilla.org/en-US/firefox/addon/1419 . It gives you an "IE View" in a Firefox tab. I have heard it is an option for people who are FireFox fans and really don't want to install IE on a machine.
    • Marked as answer by Hamed_1983 Tuesday, October 28, 2008 5:07 PM
    Tuesday, October 28, 2008 12:47 PM