none
Sharepoint 2010 and IE repeated asking to login to documents

    Question

  • Windows 7 IE9  Users are repeatedly asked to login when accessing documents.  Research showed to add the site to the local intranet but that did not change anything.  Users login then when they click on a word document for example the box they just logged in with is prompting them again.  Not sure what to do.  Bunch of unhappy sharepoint users who at the moment are not on board with this.  Any help would be appreciated.
    Thursday, September 20, 2012 6:59 PM

Answers

All replies

  • Hope this might help you

    Follow these steps

    1.    Open your Internet Explorer
    2.    Go to your sharepoint site
    3.    Login to the site, if you see a check box to save your credential click it
    4.    Depending on your version of IE you need to select internet options from the tools menu.  If you cant find that then it is also in the control panel.
    5.    Click the Security Tab in the internet options
    6.    Then select Intranet and click Sites
    7.    Within sites, select Automatically detect intranet network
    8.    Then click Advanced
    9.    You will see "your site" in the Add this website to the zone, just click add.
    10.    If you don’t see it there type it out in the top box and select add
    11.    Then uncheck the Require sever verification box and type http version in the top box and click add again.  You should have two sites listed there one with http and one with https.  Then click close.
    12.    In the Intranet box click ok
    13.    Next move the slider in the Intranet zone to low and uncheck the Enable Protected mode.
    14.    If you cant see the slider, then click on default level and then move the slider to the low setting.  Once that’s done click the apply and ok.


    • Edited by SPBee Thursday, September 20, 2012 8:24 PM
    Thursday, September 20, 2012 8:24 PM
  • Try this:

    Tools>>>Internet options>>>Content tab>>>AutoComplete, Settings>>>Check, User names and passwords on forms, Uncheck, Ask me before saving passwords

    http://answers.microsoft.com/en-us/ie/forum/ie9-windows_7/ie9-repeated-password-request/6bc2b128-5276-e011-8dfc-68b599b31bf5?msgId=5d5706a9-6076-e011-8dfc-68b599b31bf5

     

    I suggest that you clear your browser's cache and temporary internet files to make sure that they are not causing the issue. This is often caused by a corrupted file in the browser. Please clear your browser's cookies by following the instructions on the link below:

    How to optimize Internet Explorer browser 

    Friday, September 21, 2012 6:33 AM
  • This and the solution below seem to work when working from the office domain where the sharepoint server exists.  When I try to open the site from outside the office environment I am constantely asked for a username and password when I try to open up a document
    Friday, September 21, 2012 3:53 PM
  • Thanks for you response.

    This and the solution above seem to work when working from the office domain where the sharepoint server exists.  When I try to open the site from outside the office environment I am constantely asked for a username and password when I try to open up a document.

    Friday, September 21, 2012 3:54 PM
  • please correct me if i misunderstand.

    as you mentioned,when you try to open up a documents, the office application open up first on the client machine and try to fetch data from the server, but then ask for authentication. Browser has cookie based authenticaion which office applications doesnt understand.

    accessing documents externally through SharePoint

    http://blogs.msdn.com/b/pnayak/archive/2008/08/08/hide-sign-me-in-automatically-check-box-in-sharepoint-fba-login-page.aspx

    Saturday, September 22, 2012 9:31 AM
  • Thursday, September 27, 2012 7:08 AM
    Moderator