none
Excel Services 2010 Error - “The workbook cannot be opened.”

    Question

  • I enabled Excel Services and added a Excel Web Access viewer to my page. It's just a simple spreadsheet (which incidentally works fine on my standalone development server) that displays the error "The workbook cannot be opened." when the page loads. The trusted file locations are set up appropriately. We are using Kerberos authentication.

    My event viewer showed this "Critical" event (ID: 3760):

    SQL Database 'Prod_WSS_Content' on SQL Server instance 'servername' not found. Additional error information from SQL Server is included below.

    Cannot open database "Prod_WSS_Content" requested by the login. The login failed. Login failed for user 'domain\user'.

    In other words, the service account that ECS was running under did not have permission to the content database. So I granted the user read permission on the database. Then I got the same error and this "Error" level event in the event viewer (ID: 5617):

    There is a compatibility range mismatch between the Web server and database "Prod_WSS_Content", and connections to the data have been blocked to due to this incompatibility. This can happen when a content database has not been upgraded to be within the compatibility range of the Web server, or if the database has been upgraded to a higher level than the web server. The Web server and the database must be upgraded to the same version and build level to return to compatibility range.

    This error is typically associated with 2007 to 2010 upgrades apparently, but I did a fresh 2010 installation on a pristine machine. I found a very helpful post on the subject on the MSDN blogs:http://blogs.msdn.com/b/jjameson/archive/2010/05/04/the-workbook-cannot-be-opened-error-with-sharepoint-server-2010-and-tfs-2010.aspx

    I gave the ECS service account db_owner permission on the content database. I'm still getting the error "The workbook cannot be opened." I ran the PowerShell commands listed at the bottom of the post, and no change.

    What's interesting now, is that nothing at all is showing up in the event viewer. I wonder if it is because of the statement in the event log that says "connections to the data have been blocked due to this incompatibility." Is there something on the SharePoint server blocking the connection to SQL Server that needs to be reset?


    Rob Wilson - MCT. MCTS, MCITP SharePoint. http://sharepointblog.kellerschroeder.com http://www.therobman.com/blog
    Friday, August 20, 2010 3:59 AM

Answers

  • So after all else failed, restarting the servers (SharePoint and DB) and creating a brand new primary site collection seemed to solve the problem. ECS now functions as expected. I think the lesson here is to be sure you do the ECS configuration steps in the right order.
    Rob Wilson - MCT. MCTS, MCITP, MCPD SharePoint. http://sharepointblog.kellerschroeder.com http://www.therobman.com/blog
    • Marked as answer by Rob Wilson MCT Tuesday, October 26, 2010 1:51 PM
    Tuesday, October 26, 2010 1:51 PM

All replies

  • Hi Rob Wilson,

     

    I suggest you to check the following things at first:

    1.       What’s the version of the excel file? Excel 2003, Excel 2007 or Excel 2010? Excel Service doesn’t support Excel 2003 and easier version;

    2.       Are there some features the Excel Service do not support?

    More information about the Supported and Unsupported Features

    http://msdn.microsoft.com/en-us/library/ff595319.aspx

    3.       If the excel is connected to SQL, did you save the connect file to the Data Connection Library?

     

    Shared your views.

    Tuesday, August 24, 2010 8:19 AM
  • Thanks for replying, Wayne Fan.

    We get the error on a Excel 2007 workbook.  In addition, the workbook has a few strings entered into the columns and that is all -- no calculations, connections or anything.  It cannot get any more basic than this.

    At this point I'm thinking the only thing to do is to kill the ECS service application and recreate it.  That is somewhat of a pain.  If after that SharePoint is still "blocking the connection to the data" I am going to be greatly disappointed.  What does that even mean?  Does SharePoint have an internal firewall?


    Rob Wilson - MCT. MCTS, MCITP SharePoint. http://sharepointblog.kellerschroeder.com http://www.therobman.com/blog
    Tuesday, August 24, 2010 2:18 PM
  • Hi Rob,

     

    Sorry for the delayed reply.

    You have added the ECS account the db_owner permissions to the SQL as I know. Have you tried to add the current user account to the db_owner permissions to the SQL?

    I think you should pay more attention to the Kerberos authentication. The ECS works fine on my server, which is windows authentication.

    Friday, September 03, 2010 8:20 AM
  • Wayne Fan, those are some interesting comments, but I'm not sure I follow.  The farm admin and the ECS service account (confirmed) are both db_owners.  Are you suggesting that I make every user that would want to use ECS a db_owner on the content database?  Also, there are no problems with our Kerberos configuration.  We have confirmed that Kerberos is configured properly.  I have ECS working on a few servers that I support.  This one is different -- I'm guessing because the db_owner permission was granted out of order.

    If you would, focus on the message that says "connections to the data have been blocked due to this incompatibility."  I'm confident that is the root of the problem.  What does that mean, and how do I unblock the connection?  Surely someone on the product team can determine the origin of that message as someone had to code it in the first place...

    Thanks for your response.  I'm almost at a point where I think I'm going to reinstall.


    Rob Wilson - MCT. MCTS, MCITP SharePoint. http://sharepointblog.kellerschroeder.com http://www.therobman.com/blog
    Friday, September 03, 2010 12:34 PM
  • So after all else failed, restarting the servers (SharePoint and DB) and creating a brand new primary site collection seemed to solve the problem. ECS now functions as expected. I think the lesson here is to be sure you do the ECS configuration steps in the right order.
    Rob Wilson - MCT. MCTS, MCITP, MCPD SharePoint. http://sharepointblog.kellerschroeder.com http://www.therobman.com/blog
    • Marked as answer by Rob Wilson MCT Tuesday, October 26, 2010 1:51 PM
    Tuesday, October 26, 2010 1:51 PM
  • Hi Rob,

    Thanks for your shares.


    SharePoint 2010
    Wednesday, October 27, 2010 2:08 AM
  • Hi Wayne and Rob

    I request your help for making excel file view in browser in my sharepoint site. I am getting "The workbook cannot be opened in the browser" error message while opening the excel file.

    My Server and other Details:

    SharePoint 2010 enterprise as stand alone.

    Webapplication is form based authentication and

    Installed office web app on SharePoint box.

    No MS-Office on SharePoint box (i read it is not required)

    Excel file which i am trying to view in browser is: 2010 i.e., with .xlsx extention. File doesnot contain any objects/macros. its just a blank workbook.

    Error message when openining: "The workbook cannot be opened in the browser"

    I tried below options

    1. Both content db owner and login by which i am opening excel file are same and hence i didnt  grant any permission that was suggested.

    2. Deleted and Recreated Excel Service Application and activated web app feature in site collection.

    3. Restarted related excel services in SharePoint and also in services.msc

    4. restarted the SharePoint server box

    ---

    Other useful Informtaion:

    In same webapplication's site collection, i am able to view word document and powerpoint file in browser.

    ---

    Please help me out if i am missing any configaration.

    thanks a lot beforehand.


    Thanks & Regards Raj


    • Edited by RajKumarBathula Thursday, December 20, 2012 4:20 AM added some more information
    Thursday, December 20, 2012 4:16 AM
  • Hi All,

    My issue was solved by just removing the existing excel service application and recreating.


    Thanks & Regards Raj

    Monday, December 24, 2012 5:33 AM