none
Error "Stop running this script?" while submitting data to webservice in custom list

    Question

  • Hi,

    I have a custom list in sharepoint 2010 site, which is modified in Infopath 2010. I have a submit button in the list, which sends data to web service. The webservice sends data to custom sql database.

    The above operation is working, but when the submit button is clicked, i am getting a popup message as "Stop running this script?  A script on this page is causing your web browser to run slowly. If it continues to run, your computer might become unresponsive."

    I am getting a "Yes" and "No" button in it. Clicking on the "No" button, submits the data and the record is saved.

    How to hide this popup and submit the data?

    Thank you

    Monday, February 07, 2011 5:57 AM

Answers

All replies

  • It's an IE issue.  How much data are you downloading into the form with data connections?  If it's a lot, then it stays there in the browser cache, so when you perform other postback operations, IE will be likely to show that script error, because it thinks something malicious is happening.  My guess is if you test the form in Firefox, then it won't happen - go try it and see.  The only way around it that I've found is to clear the browser cache by emptying the data connections with null queries.  If you only rarely get it, then try optimizing the form by setting the control postbacks to "Never" unless a rule needs to fire on that control.
    SharePoint Architect || Microsoft MVP || My Blog
    Planet Technologies || SharePoint Task Force
    Monday, February 07, 2011 6:05 AM
  • HI Clayton,

    I am always getting the error, when i try to submit the data to a custom web service. And, I am getting that error around 16 times.

    Is there any IE settings which can be done, to avoid this error?

    Thank you

    Saturday, February 12, 2011 5:37 AM
  • I answered above.
    SharePoint Architect || Microsoft MVP || My Blog
    Planet Technologies || SharePoint Task Force
    Saturday, February 12, 2011 6:58 AM
  • Hi Clayton,

    I checked this:

    http://support.microsoft.com/kb/175500

    Need your suggestion, if the above solution may be used?

    Thank you

    Saturday, February 12, 2011 11:38 AM
  • Thanks Clayton,

     

    How do we clear the browser cache by emptying the data connections with null queries or set the control postbacks to never if I am working from INFOPATH 2010 ?

    Wednesday, November 09, 2011 6:35 PM
  • ...emptying the data connections with null queries....
    SharePoint Architect || Microsoft MVP || My Blog
    Planet Technologies || SharePoint Task Force


    Please Clayton or somebody can you advise how to do this? This error message

    A script on this page is causing your web browser to run slowly. If it continues to run, your computer might become unresponsive.

    Is driving me crazy. My users mostly have to use IE, so they can't simply switch to Firefox.

    I found:

    1) The error message seems not to have been there from the beginning my form was launched. I am quering to an 'events' list for people to select and subscribe  to a certain event. We didn't add events after it was launched.

    2) No error message or warning in Infopath preview itself

    Wednesday, September 12, 2012 8:01 AM