none
User Profile Service Application

    Question

  • Hi,

    I have been struggling with the User Profile Service Application under Central Administrarion -> Manage Service Application. The moment I click the link "User Profile Service Application" I got an Unepxpected error has occurred message. I then modified the web.config file to show the exact error message but am always getting the usual 

    Server Error in '/' Application.

    Runtime Error

    Description: An application error occurred on the server. The current custom error settings for this application prevent the details of the application error from being viewed.

    Details: To enable the details of this specific error message to be viewable on the local server machine, please create a <customErrors> tag within a "web.config" configuration file located in the root directory of the current web application. This <customErrors> tag should then have its "mode" attribute set to "RemoteOnly". To enable the details to be viewable on remote machines, please set "mode" to "Off".

     

    Though I update the CustomError's mode to RemoteOnly/Off I dont see any change.

    Any help would be greatly appreciated.

    Friday, February 25, 2011 2:05 AM

Answers

  • I had the same problem User Profile sync was stuck up in starting mode... This is what i did.

    1. User Powershell cmdlet Get-SPServiceInstance to get the GUID of User Profile Sync.

    2. Stopped the Service using the cmdlet Stop-SPServiceInstance <GUID>

    3. Stopped Sharepoint Timer Service. force started forefront Services(there will be two with disabled mode. need to make it start and put it to automatic mode.)

    4. Used the Cmdlet Get-SPServiceApplicationPool to check if app pool is existing. else u should create by using the commands: New-SPServiceApplicationPool, then type UserProfileServiceApplication and then give the user account something like ur domain\adminid. this should be the account u used to install sharepoint 2010.  Now after doing this, need to confirm if it is created properly by the first Get-SPServiceApplicationPool cmdlet.

    5. Major step that I thought made magic was this: 

    from the command prompt, run: cliconfg.exe

    Enable “named pipes” and “TCP/IP” (if not already there)

    After all this, try starting the user profile sync with crossed fingers...for sure it will work as it did so for me.

    • Marked as answer by Cutloo Monday, March 14, 2011 6:45 AM
    Friday, March 04, 2011 2:46 AM

All replies

  • Hi,

    I think the user profile service is stopped, check services in administrative tools if the user profile service is running.

     

    regards

    Friday, February 25, 2011 10:35 AM
  • The User profile service is running, checked under the services console.

    However I thought I'll restart the service but I got a message saying "Error 1061 : The service cannot accept control messages at this time".

    Friday, February 25, 2011 10:49 AM
  • Try restarting the server. 
    Friday, February 25, 2011 10:58 AM
  • Hi Ernie,

    The service is dependent on "Application Information" service. The first time I restart the service I get the message 

    "Error 1051 : A stop control has been sent to a service that other running services are dependent on"

    After a while if I try to restart the User Profile Service once again I get the same message I used to get earlier.


    Friday, February 25, 2011 11:53 AM
  • Hi,

    I am assuming what you’ve restarted is the User Profile Service on Services.msc. Have you tried restart the “User Profile Service” and “User Profile Synchronization Service” by going to Central Administration -> Manage Services on Server? If any of these services get stuck on Starting or pop-up an error, it would be worth having a look at this troubleshooting blog from Spence:
    http://www.harbar.net/articles/sp2010ups2.aspx

    If recreating a User Profile Service isn’t just too much trouble, I suggest you create a new User Profile Service Application followed another walk through from Spence in case any configuration steps was missing or incorrectly performed.
    http://www.harbar.net/articles/sp2010ups.aspx

    Thanks & Regards.


    Lily Wu || Microsoft Online Community Support Engineer || SharePoint
    Wednesday, March 02, 2011 7:51 AM
  • Thanks Lily, will try this today and let you know my results.
    Thursday, March 03, 2011 4:59 AM
  • I thought I'll start clean by deleting and recreating the UPA.Hence used the windows power shell mentioned at http://www.harbar.net/articles/sp2010ups2.aspx


    $syncDBType = "Microsoft.Office.Server.Administration.SynchronizationDatabase"
    $upaSAType = "User Profile Service Application"
    $syncDB = Get-SPDatabase | where-object {$_.Type -eq $syncDBType}
    $upa = Get-SPServiceApplication | where-object {$_.TypeName -eq $upaSAType}
    $syncDB.Unprovision()
    $syncDB.Status = "Offline"
    $upa.ResetSynchronizationMachine()
    $upa.ResetSynchronizationDatabase() 
    $syncDB.Provision() 
    restart-service SPTimerV4

    When I call the Provision method am gettting the error "CREATE DATABASE permission denied in the database 'master'. Though I have logged with the sys admin credentails of SQL server..

    I thought of recreating the "User Profile Service" application but for that I need the User Profile Synchronisation Service which has got stuck in "Starting" state.
    Friday, March 04, 2011 1:47 AM
  • The access denied error is gone now, I opened the management shell under the required credential.

    I thought the Power shell script is to reset the state of the User Profile Synch. Service as its stuck on Starting. But even after executing these scripts successfully the state still remains as "Starting" in the "Manage services on Server" page.

    Friday, March 04, 2011 2:06 AM
  • I had the same problem User Profile sync was stuck up in starting mode... This is what i did.

    1. User Powershell cmdlet Get-SPServiceInstance to get the GUID of User Profile Sync.

    2. Stopped the Service using the cmdlet Stop-SPServiceInstance <GUID>

    3. Stopped Sharepoint Timer Service. force started forefront Services(there will be two with disabled mode. need to make it start and put it to automatic mode.)

    4. Used the Cmdlet Get-SPServiceApplicationPool to check if app pool is existing. else u should create by using the commands: New-SPServiceApplicationPool, then type UserProfileServiceApplication and then give the user account something like ur domain\adminid. this should be the account u used to install sharepoint 2010.  Now after doing this, need to confirm if it is created properly by the first Get-SPServiceApplicationPool cmdlet.

    5. Major step that I thought made magic was this: 

    from the command prompt, run: cliconfg.exe

    Enable “named pipes” and “TCP/IP” (if not already there)

    After all this, try starting the user profile sync with crossed fingers...for sure it will work as it did so for me.

    • Marked as answer by Cutloo Monday, March 14, 2011 6:45 AM
    Friday, March 04, 2011 2:46 AM
  • Hi Gai3kannan,

    I followed your steps, when you try to start the User Profile Synch. Service it asks for Service Account Name and Password. By default am not sure  I get NT Authority\Network Services and it asks for a password too. I dont want this account as this is not the administrator account. Any way to change this account or you know from where its picking the account name from?

    Saturday, March 05, 2011 1:26 PM
  • Hi,

    Who was the one to do installation of sharepoint 2010 in the server? Have read that if you specify different account names for User Profile Sync while installing, we will get issues starting up. May be the account that is coming in by default is the account that was mentioned during installation..

     

    Thursday, March 10, 2011 2:26 AM
  • Yeah you are correct, it was the account that was used during installtion.

    Is there any way to change it?

    Thursday, March 10, 2011 4:43 AM
  • Hi,

    you can configure "managed accounts" via "CA > Security > Configure managed accounts" and then assign this account to the appropriate service via "CA > Security > Configure service accounts" I would suggest you to create all the service accounts you use as "managed account" - It will make the management of your farm a bit easier.

    FYI: Getting the "error in / application" message when trying to open the UPS Service usually isn't caused by a not-running UPS Sync Service. Disabling the Custom Errors is not the best way to get behind the problems cause (especially in a production environment!). If having troubles with SharePoint always have a look at the SharePoint Logs (C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\14\LOGS\) and/or check the server's application- & systemlogs. You'll get far more better information about the problem there and therefore can fix troubles faster/easier.

     

    Concerning the UPS Sync Service Problem:
    It doesn't matter which account you use for UPS Sync Service as long this account has the appropriate permissions. I'd suggest you to use the Farm-Service Account because it's the most convenient way! Further check the following:

    • Does the Account has the "Log on locally"-Permission on the server where the service is running? (usually solved by adding the account to the local admin group)
    • Does the Account misses any permission on any database? (should be no problem when using the Farm-Service-Account)
    • Does the Secure Store Service is running and configured properly?
    Please do not start/stop/edit the FIM-Services using services.msc - always use the SP-Mechanism to do so (PS or CA).

    BR,J

    Thursday, March 10, 2011 10:40 AM
  • Go to Central Administration --> Security --> Configure Service accounts

    You will be taken to Credential management. Select the first dropdown. in that select User Profile syncronisation.

    Click on Register new managed account.

    Specify the username and password(default administrator account). and click OK.

     

    Visit for more detailed view:

    http://gai3kannan.wordpress.com/2011/03/11/manage-service-accounts/

    • Proposed as answer by Jayaraj S Friday, July 27, 2012 6:41 AM
    Friday, March 11, 2011 1:58 AM
  • Restart the Sharepoint 2010 Timer Job.. This has been resolved my issue
    Friday, July 27, 2012 6:42 AM
  • first, restart the user profile service from central admin, then check web application service connection if not solved yet recreate the user profile service application and restart the timer job.

    Ashraf
    www.MrOffice365.com

    • Proposed as answer by Ashraf H Friday, July 27, 2012 8:52 AM
    Friday, July 27, 2012 8:52 AM