none
SharePoint 2010: Variations

    Question

  • Hi All,

    after i created variation labels and clicked on Create Hierarchies. i got the following error in Variation Logs:

    "•The Variations Create Hierarchies job failed with the following error message: File or arguments not valid for site template 'BLANKINTERNET#2'. Parameter name: WebTemplate"

    Thanks,

    Sunday, June 06, 2010 9:52 AM

Answers

  • Hi,

    That sounds like the language pack didn't install properly.

    Did you get the right language pack? There is one for SharePoint Server and one for SharePont Foundation. If you have SharePoint Server you should only install the language pack for SharePoint Server (this is different from the 2007 behaviour).


    Mirjam
    sharepointchick.com
    Tuesday, June 08, 2010 7:07 AM

All replies

  • Hi,

    Based on that error I can't tell you why, but the error occured on a site that was created based on the "Publishing site with workflows" template.

    Were changes made to the site based on that template, or were changes made to the site definition itself maybe?


    Mirjam
    sharepointchick.com
    Sunday, June 06, 2010 1:50 PM
  • Mirjam, Thanks for your reply

    let me explain more for you:

     

     I installed Arabic Language Pack 2010 from Microsoft site . Then I tried to create variations “Arabic/English” but I got this error in Variation Logs:

                    “The Variations Create Hierarchies job failed with the following error message: File or arguments not valid for site template 'BLANKINTERNET#2'. Parameter name: WebTemplate”.

                    I tried creating new site with Arabic Language but there is no selections in Template option! I didn’t get any error when installing Arabic Language Pack and configuration done successfully.

                    I didn’t find anything wrong is central administration as well.

     

    Thanks

    Monday, June 07, 2010 11:19 AM
  • Hi,

    That sounds like the language pack didn't install properly.

    Did you get the right language pack? There is one for SharePoint Server and one for SharePont Foundation. If you have SharePoint Server you should only install the language pack for SharePoint Server (this is different from the 2007 behaviour).


    Mirjam
    sharepointchick.com
    Tuesday, June 08, 2010 7:07 AM
  • Thanks Mirjam .. yes, you are right. i installed SharePoint Foundation Language pack. everything is Ok now after i installed Sharepoint Server 2010 Language pack :))

    Thanks in Advance

    Mohamed Abdel Ghaffar
    SharePoint Team Leader
    http://sharepointfoundation2010.blogspot.com/

    Thursday, June 17, 2010 2:05 PM
  • Hi Mohamed:

    Can you please share the sharepoint Language pack url?

     I downloaded the from the below link and installed Spanish, but still getting the same error

    " The Variations Create Hierarchies job failed with the following error message: File or arguments not valid for site template 'BLANKINTERNET#2'. Parameter name: WebTemplate”.

    URL: http://www.microsoft.com/downloads/details.aspx?displaylang=en&FamilyID=646e311a-aaf3-4d30-b03c-2f3c70d19a22 

    Thanks!

    Ravi


    Ravi
    Monday, August 09, 2010 2:12 PM