none
How to make Infopath Designer 2010 respect the default selected types (New, Edit, Display) for list forms?

    Question

  • In Sharepoint Designer 2010 (SPD2010), in List Setting of my list under Forms sections I am trying to stick to the following configuration:

    • DisplayForm.aspx (Default)
    • EditForm.aspx  (Default)
    • NewForm.aspx 
    • displayIFS.aspx 
    • editifs.aspx 
    • newIFS.aspx  (Default)

    After Quick Publish of the list form from Infopath Designer 2010, the last 3 forms:

    • displayIFS.aspx 
    • editifs.aspx 
    • newifs.aspx 

     are factually being used as default by Sharepoint Server 2010 Infopath Form Services.

    But SPD2010 (*) shows as default the first 3 ("default sharepoint forms"), incorrectly: 

    • DisplayForm.aspx (Default)
    • EditForm.aspx  (Default)
    • NewForm.aspx  (Default)
    • displayIFS.aspx 
    • editifs.aspx 
    • newifs.aspx  

     So, each time after editing in Infopath Designer 2010 and publishing  I should go to my list in SPD2010

    • List and Libraries  --> my list --> Forms

    and set back  newifs.aspx as Default  to have the desired default type/actions (in blue color above):

    • Edit on (Sharepoint form) EditForm.aspx
    • Display on (Sharepoint form) DisplayForm.aspx
    • New (Infopath form) newifs.aspx

    Though, this still doesn't restore my lost configurations until I navigate (now in browser) to myList's List Settings--> Form Settings  to change to:

    •  Use the default Sharepint form
       --> OK
    from reset by Infopath list form publishing option to: 

    • Modify the existing Infopath form

    If to reopen Form Setting, the only available choice is now really:

    • Customize the current form using Microsoft Infopath

    Well, this is tedious and boring.

    Are there any ways that I am missing to prevent Infopath Designer 2010 to reset the already set default form types during publishing a list fOrm from Infopath Designer 2010 ?

    (*) 
    Note also that any changes in configuration outside of SPD2010 they are NOT reflected in SPD 2010 until closing, re-opening SPD2010 and navigating again to a list.


    Thursday, June 21, 2012 7:09 AM

All replies

  • You can check in sharepoint designer > list and libraries and forms > select the default form you want. Refresh . Open the site.

    Many a times closing and reopening works in many cases. I guess, the cache files are refreshed and teh latest files will be loaded.

    Thursday, June 21, 2012 4:58 PM
  • You can check in sharepoint designer > list and libraries and forms > select the default form you want. Refresh . Open the site.

    Many a times closing and reopening works in many cases. I guess, the cache files are refreshed and teh latest files will be loaded.

    I unmarked the reply as answer since I still hope for answer and this reply is not even related to my issue. It is repeating what I already described in my question what makes me believe that you did not even bother to read my question 

    Let me to formulate my issues more briefly (with more details above):

    • on publishing a sharepoint list Infopath form (from Infopath Designer 2010) my custom setting of default Display, Edit, New forms are overwritten (lost).
    • My custom defaults are mixture of Infopath and non-IP forms (web pages) while Infopath Designer 2010 makes all defaults to Infoapth forms.

     


    Gennady Vanin (Novosibirsk) -- Геннадий Ванин (Новосибирск) Currently posting in context of Office 365 (Plan E3), trial (Sharepoint 2010 Online/ Infopath 2010)


    Friday, June 29, 2012 4:39 PM
  • I had a similar experience.  SharePoint Designer 2010 will give you a "false positive" on what is set as the default.  It will show EditForm.aspx is the default when in fact Editifs.aspx is the default page being rendered.  But, in some ways this is beneficial.  If you have links to EditForm.aspx?ID=22, then these links will still work as it performs a redirect for you to the customized infopath form.  After a little searching I found where the infopath forms were being called.  You have to go to the content type on the lower left box in SP Designer 2010 and click on the content type for Item.  There, you will see the reference to the customized infopath pages for Display, Edit, and New.  I had some legacy customized aspx pages and they were still being referenced there.  I changed the url to the infopath pages and all was good.

    On a related note, we had an issue with the InfoPath forms showing the default blue color theme on any page that was customized when there was no visual upgrade performed.  I finally found a resolution and have written it up here.  http://surfpointtech.com/2012/09/04/customize-infopath-forms-in-sharepoint-2010-changes-color-theme-to-default-blue-no-visual-upgrade/

    Miles

    Surfpointtech.com

    Tuesday, September 04, 2012 10:12 PM
  •  You have to go to the content type on the lower left box in SP Designer 2010 and click on the content type for Item.  There, you will see the reference to the customized infopath pages for Display, Edit, and New.  I had some legacy customized aspx pages and they were still being referenced there.  I changed the url to the infopath pages and all was good.


    The issue is that after I configure a mixed set of, say, using custom Infopath form web part page for new items (newifs.aspx instead of newForm.aspx) and default sharepoint template pages for display and edit (dispForm.aspx and EditForm.aspx) , then next publishing from Infopath Designer will reset all three pages to custom infopath form web part pages (displayifs.aspx, editifs.aspx, newifs.aspx). Disrespecting manual settings

    Tweaking on the content type for Item does not help to prevent this or help to preserve the manual settings (after publishing).  


    Gennady Vanin (Novosibirsk) -- Геннадий Ванин (Новосибирск) Currently posting in context of developing against Office 365 (Sharepoint 2010 Online) Plan E3 trial from 32-bit (x86) Windows XP SP3 Engl. using Infopath Designer 2010, Sharepoint Designer 2010 and Internet Explorer 8

    Wednesday, September 05, 2012 4:33 PM