locked
Where is the Sharepoint Draft folder?

    Question

  • Hi,

     

    I am wondering where is this folder?

    Actually where is the file on a local PC when you do a check out of a .doc?

     

    On my own PC it is in "my documents/sharepoint draft", but on the PC of all my colleague, the file is not on the PC at all!! (I am using Office 2002, they are using Office 2003. We all use XP and are on the same domain and use the same portal with the same right access).

     

    I mean when they check out a document on their PC, the file is checked out, but the file is not copied on their PC.

    So they can't update the document from their laptop when they are not connected to the portal for example.

     

    They can only select "edit in microsoft office", do some modifications and click on save (the same day!!).

    I mean they can't start a modification one day, switch off the computer and do some other modification the day after without saving the document on the portal before they switch off the pc at the end of the day.

     

    Could you help me to understand why they can't check out a local copy of a .doc document and work on the local copy??

    By the way, when I click on "check out", a windows popup and ask me whether I want to use the local draft folder or not. But when my colleague try to check out, there is no popup, no question, just a check out of the file on the portal....

     

    Thanks you

     

    Rod

    PS: I'm speacking about SPS based on WSS 3 (2007)

    Tuesday, April 10, 2007 10:31 AM

Answers

  • Whether the "Use my local drafts folder" appears is driven by a few things:

    1. The Require documents to be checked out before they can be edited setting on the Document Library. Select 'Yes' to have the prompt appear. This affects both Word 2003 and Word 2007
    2. Offline Editing settings in Word 2007
      1. Word 2007:
      2. Office button > Word Options
      3. Save
      4. See the Offline editing options for document management server files setting

    Enjoy your day, Joe
    Tuesday, March 29, 2011 4:00 PM

All replies

  • According to documentation, you only get that dialog about "Use my local drafts folder" if the application being used is compatible with SPS3.0. For me, I get the dialog when I use a box with Office 2007 and I do not get the dialog when I use a box with Office 2002.

    See http://office.microsoft.com/en-us/help/HA100929181033.aspx.

    That might be what is happening for your colleague. If so, then the file is being saved back to the server every time they do a save.

    You say you are on Office 2002, so I do not totally understand what is happening to you, but that's the information I have so I thought I'd share it.

    Good luck!

    Tuesday, April 24, 2007 5:53 PM
  •  

    I am using Office XP and I am able to use the local drafts folder.  However, my collegues who is also using Office XP does not have the option.  When he clicks on a file he only has the standard file download pop-up from where he can open or save the file but nothing more.

     

    I cannot figure out why this is the case or how to solve it as our PCs seem to have similar setups.

    Friday, May 16, 2008 10:42 AM
  • There is no "SPS based on WSS 3 (2007)".

    Can we assume you are asking about Microsoft Office SharePoint Server 2007 (= MOSS 2007) ?
    Friday, May 16, 2008 12:37 PM
  •  

    I'm not sure I understand the question entirely but I am running WSS 3.0 with SP1.  I am using IE 7 on Windows XP.
    Friday, May 16, 2008 3:47 PM
  • There are a couple of things going on here.  You must have some application on your PC that is part of Office 2007.  (You don't have to have the entire suite.)  You may have Visio, One Note, Groove or many others.  That put the 2007 sharepoint component on your pc and gave you a different message box than your comrades.  If you have this component, you will only see this draft folder if you have check out required turned on for the document Library.
    Can't live without water
    Tuesday, February 17, 2009 10:01 PM
  • All,

    This is what's going on:

    1. The Sharepoints draft folder will not appear until after the first time an item is checked out as a draft from a document library in sharepoint. 
    2. The drafts feature is not enabled by default when a library is created.  To enable this on a particular library follow these steps:
     i. Open the library you want to enable drafts in.
    ii. Click on the setting drop down tab, then click on Document library settings.
    iii. Under the 'General Settings' column click on 'Versioning Settings'
    iv. Under the 'Document Version History click the radio button that says 'Create major and minor (draft) versions'
    v. click 'OK' to save the changes.

    Now, when you check out the item a pop up will appear that asks if you want to work from your local drafts folder, which is set as the 'Sharepoint Drafts' folder in the users My Documents folder.  Other wise, you have to check out the document, save it locally, edit it, and check it back in.

    Also, as others have said, you need to have a component of Office 2007 on your client machine.  This is what provides the integration for the draft folder.  As it happens, installing Sharepoint Designer (which is a free download) will enable this integration.

    Mark Nikirk
    Sharepoint Admin.
    Praxair, Inc
    • Proposed as answer by Grub00 Thursday, July 23, 2009 2:35 PM
    • Edited by Grub00 Thursday, July 23, 2009 7:29 PM
    • Unproposed as answer by Mike Walsh FIN Tuesday, March 29, 2011 4:15 PM
    Thursday, July 23, 2009 2:32 PM
  • I understand that having an Office 2007 application on your computer can enable the use of the local drafts folder with in SharePoint. However, is there a way to have just that one part of the application (such as SharePoint Designer) that will give me this capability. I can definetly forsee having to spend 60-80 hours of manpower to push this program to 50-60 machines over a large network (or calling the users) --which is a 295 MB file. Either that or spending several thousands of dollars updating those computers to Office 2007.

    The goal here I guess is finding a cheap and time-effective solution to integrating Office 2003 with SharePoint. And when it comes down to completing budgets, I'm sure the users in accounting are gonna have to/want to take their work home with them and go offline.
    Thursday, August 20, 2009 7:41 PM
  • Whether the "Use my local drafts folder" appears is driven by a few things:

    1. The Require documents to be checked out before they can be edited setting on the Document Library. Select 'Yes' to have the prompt appear. This affects both Word 2003 and Word 2007
    2. Offline Editing settings in Word 2007
      1. Word 2007:
      2. Office button > Word Options
      3. Save
      4. See the Offline editing options for document management server files setting

    Enjoy your day, Joe
    Tuesday, March 29, 2011 4:00 PM