none
Web application could not be found. Verify that you have typed the URL correctly.If the URL should be serving existing content the system administrator may need to add a new request URL mapping to the intended application null'

    Question

  • I am getting this error " Web application could not be found. Verify that you have typed the URL correctly.
     If the URL should be serving existing content,
    the system administrator may need to add a new request URL mapping to the intended application null'

    I am using VS2010 and Sharepoint 2010.Even i am running VS2010 as a administrator. Even i set TARGET TYPE 64 bit. Even if i use Run as Security Privelege BEFORE SPSite.Even my Sharepoint appication pool and .net application pool are running on "Integrated" Local System.Can you tell me the exact steps where i need to change so that i could be able to open Sharepoint SPSite 2010.I am struggling last 2 days..please help me .

    Thanks,

    Tuesday, May 31, 2011 9:14 AM

Answers

  • Hi Wardhan,

    Did you talk about a development problem? Can you visit your SharePoint site with browser?

    If you could visit your SharePoint site, could you clarify whether you developed applicatoin on SharePoint server.

    Server object model can only be accessed on server.

    Finally make sure that you set target framework for your application to .Net Framework 3.5 and the Plateform target to 'Any CPU' with Visual Studio.

    You can right click your application in Visual Studio and select the proerties. You can set the Plateform target in Build tab.


    Microsoft Online Community Support
    • Marked as answer by Porter Wang Monday, June 06, 2011 7:36 AM
    Wednesday, June 01, 2011 6:50 AM

All replies

  • Verify that you application has been build upon x64 CPU and .NET framework 3.5.

    If above do not solve your problem you have a permission issue.

     

    Tuesday, May 31, 2011 9:45 AM
  • Hi Wardhan,

    Did you talk about a development problem? Can you visit your SharePoint site with browser?

    If you could visit your SharePoint site, could you clarify whether you developed applicatoin on SharePoint server.

    Server object model can only be accessed on server.

    Finally make sure that you set target framework for your application to .Net Framework 3.5 and the Plateform target to 'Any CPU' with Visual Studio.

    You can right click your application in Visual Studio and select the proerties. You can set the Plateform target in Build tab.


    Microsoft Online Community Support
    • Marked as answer by Porter Wang Monday, June 06, 2011 7:36 AM
    Wednesday, June 01, 2011 6:50 AM
  • Hi Chen,

    1.Hi I have created an asp.net application which is running on X64 bit or Any CPU.Even i am running  VS2010 as administrator.

    2.I have targeted my asp.net application on .NET FRAMEWORK 3.5

    3.I have targeted platform Any CPU or X64

    4.I have created a Sharepoint site ie http://james:9090 and application pool for this site is [Sharepoint Portal 9090]

    5.Now i am trying to opne this site  SPSite sharePointSite = new SPSite("http://james:9090");

    6.When i copy this url and paste in browser then this site is running fine(means existing)

    7.Open Server Manager -> expand role->Clicking IIS Manager(My site and application pools are existing under [JAMES\Administrator].

    8.I have set Managed pipeline mode of my site application pool [Sharepoint Portal 9090] to "Integrated"  Identity to "Local system" or "James\Administrator"

    9.Now i am trying to opne this site  SPSite sharePointSite = new SPSite("http://james:9090"); and getting error

    "Web application could not be found. Verify that you have typed the URL correctly.If the URL should be serving existing content.the system administrator may need to add a new request URL mapping to the intended application null'"

    Can you please tell me exact steps where i need to change and what i need to change so that i can be able to open Sharepoint 2010 site?

    As i remembered same thing i was using on Sharepoint 2007, It was working fine but i know why its not working on Sharepoint 2010.

    Thanks,

    Tuesday, June 07, 2011 2:10 PM
  • Hi Anders,

    Yes, I have verified this so many times.

    1.Hi I have created an asp.net application which is running on X64 bit or Any CPU.Even i am running  VS2010 as administrator.

    2.I have targeted my asp.net application on .NET FRAMEWORK 3.5

    3.I have targeted platform Any CPU or X64

    4.I have created a Sharepoint site ie http://james:9090 and application pool for this site is [Sharepoint Portal 9090]

    5.Now i am trying to opne this site  SPSite sharePointSite = new SPSite("http://james:9090");

    6.When i copy this url and paste in browser then this site is running fine(means existing)

    7.Open Server Manager -> expand role->Clicking IIS Manager(My site and application pools are existing under [JAMES\Administrator].

    8.I have set Managed pipeline mode of my site application pool [Sharepoint Portal 9090] to "Integrated"  Identity to "Local system" or "James\Administrator"

    9.Now i am trying to opne this site  SPSite sharePointSite = new SPSite("http://james:9090"); and getting error

    "Web application could not be found. Verify that you have typed the URL correctly.If the URL should be serving existing content.the system administrator may need to add a new request URL mapping to the intended application null'"

    Can you please tell me exact steps where i need to change and what i need to change so that i can be able to open Sharepoint 2010 site?

    As i remembered same thing i was using on Sharepoint 2007, It was working fine but i know why its not working on Sharepoint 2010.

    Thanks,

    Tuesday, June 07, 2011 2:14 PM
  • Hi,

    Did you mean you change the site application account manually? If it was, please see the following video and try it again.

    http://blog.rafelo.com/2010/03/how-to-video-change-application-pool.html


    Microsoft Online Community Support
    Wednesday, June 08, 2011 1:45 AM
  • Hi Chem,

    1.I am working on my personal system which is having only one server named "James"

    2.and I have created sharepoint site under james\administrator (Primary)

    3.I have also tried (http://blog.rafelo.com/2010/03/how-to-video-change-application-pool.html) which you sent to me.

    4.I have selected My sharepoint site"http://james:9090" from Credential Management and selected james\administrator from Select an account for this component .

    But still getting same error.

    When i am opening the site http://james:9090 Its running under james\administrator. i am not changing sign in as different user because i am using my personal system.so always i will create site under james\administrator. but i dont know why .net application is not opeing the sharepoint 2010 site.I think someting permission issue But i dont know what...Anyways Thanks for you respond..Hope with the help of you I will be able to fix this issue.

    Note:-Application pool name - Sharepoint Portal 9090,  Identity -james\administrator,   Status- Started,  Framework- v2.0(Under Application Pool)

    Thanks,


    • Proposed as answer by Shekhar R Wednesday, June 08, 2011 7:29 AM
    • Unproposed as answer by Shekhar R Wednesday, June 08, 2011 7:29 AM
    Wednesday, June 08, 2011 6:54 AM
  • Hello Wardhan,

    I don't know whether the solutions solved your problem or not. If its solved then well and good or else try this. Instead of this:

    "SPSite sharePointSite = new SPSite("http://james:9090");"

    try this:

    "SPSite sharePointSite = new SPSite("http://local:9090");"

    Let me if know if it works.


    Thanks & Regards, Chandra Shekhar Rameneni
    Wednesday, June 08, 2011 7:31 AM
  • Hi Shekhar,

    Thanks to respond me. I tried this

               string str = "http://local:9090/";
                SPSite site=new SPSite(str);

    But still getting same error.When i am debugging its showing null site but this site is existing and working fine...

    Is anything also need to change in Application pool or in Site Advanced settings?

    Thanks,

    Wednesday, June 08, 2011 9:19 AM
  • Hello,

    Ok. Please also try this:

    http://localhost:9090/

    Look into these links

    http://sahilsagar.blogspot.com/2007/05/web-application-at-could-not-be-found.html

    http://blogs.msdn.com/b/ekraus/archive/2009/11/13/sp2010-spfarm-local-is-null-or-web-application-could-not-be-found.aspx

    http://paulgalvinsoldblog.wordpress.com/2008/02/05/solution-system-io-filenotfoundexception-on-spsite-new-spsiteurl/

     

    Please let us know the outcome.


    Thanks & Regards, Chandra Shekhar Rameneni
    Wednesday, June 08, 2011 9:59 AM
  • Hi Shekhar,

    Thanks to respond once again.I also tried this http://localhost:9090/ but getting same error.

    Now i am going to take a look on the links which you have posted.Lets see how it goes.

    Ok, I have seen the links which you have sended.....But I already tried this as I mentioned in above post My sharepoint application pool is running under "james\administrator" and my sharepoint site is created under same "james\administrator" and I tried both X64 and Any CPU.

    Thanks,


    Wednesday, June 08, 2011 12:17 PM
  • Hi Wardhan,

    Facing the same problems here, tried everything you mentioned...

    Please let us know if your problem has been resolved and how.

    Thanks.

    Tuesday, June 21, 2011 8:32 AM
  • Hi Wardhan,


    Changing the build platform target to x64, worked fine for me. By default the console project is build for the .Net 4 framework and and the x86 platform. Because SharePoint is only available as a 64bit version, the console app should also be compiled for the 64bit platform.

    Update_Platform_To_x64_FileNotFoundException

    By changing the framework to .Net 3.5 and the target platform to x64 the issue was resolved.

    Thursday, December 01, 2011 5:11 PM
  •  

    Amazing how people seem to lack any interest in the actual problem. I've faced forums like this where the poster repeated many many many times he did all which is being adviced. I mean..come on, the whole internet says "set it to 3.5", "set it to any cpu",..the app pools...

    BUT IN HIS AND MY CASE THAT SIMPLY DOESN'T WORK, please read the poster's attempts and see that he has tried all that.

    It's amazing that it might have worked for you, but we have absolutely no interest in that at all,  so please stop sharing that one of the above attempts DID work for you...no use at all

    after days of trying to debug this, I got a bit frustrated, please forgive me.

    Friday, December 23, 2011 9:55 PM