none
how to disable html encoding in xslt data view in sharepoint pages

    Question

  • hi, 

    I have an xslt dataview webpart in a sharepoint blog page. In descripition column, the &, >, < are getting converted into &amp;, &gt, &lt, etc .

    How to disable this encoding?.

    ______________________________________________________________

    <xsl:otherwise>
    <xsl:variable name="VarIDADZITB" select="ddwrt:SetVar('HasBody', '1')" />
    <xsl:text disable-output-escaping="yes">&lt;TR&gt;</xsl:text>
    <TD colspan="2"><font color="#333333" face="Arial, Helvetica, sans-serif" size="2"><div dir="{ddwrt:GetVar('Direction')}"><xsl:value-of disable-output-escaping="yes" select="ddwrt:AutoNewLine(string(@Body))" /></div></font></TD>
    </xsl:otherwise>
    ______________________________________________________________

    this is the piece of code, im using for displaying the body. 



    pepsin s

    Wednesday, February 15, 2012 5:24 AM

Answers

All replies