none
User Profile Sync - Profile Picture Export to AD Problem

    Question

  • To start, I think I've read every post/blog/etc there is on this subject.  Currently I have user profile import to Sharepoint 2010 working.  It imports profile data just fine.  Everything in the FIM Synchronization manager show success even.  Its the export from Sharepoint to AD of the user profile picture that isn't working at all.  I've gone thru the steps of adding the thumbnailphoto export under the picture properties.  I can see the export inside of the FIM manager.  I notice though that in FIM there is there a DS_EXPORT of the objects.  I've looked into the SyncDB and noticed in the metaverse table the SPS_MV_OctetString_PictureURL never gets updated with the information from the PictureURL column of the ProfileDB.  It is always Null.  Actually in FIM it only shows one person with an update, and keep showing the PictureURL property as being not applied, which is probably because it is showing it as blank only.  In the connector for the object in FIM, I get the error that I've seen in some blog posts where it says PictureURL (String) is not compatible with SPS_MV_OctetString_PicutreURL (binary), but that seems to be how Sharepoint builds the connection even though FIM finds it invalid.  I've had that created, deleted several times, so I guess that is ordinary, and not sure that is even the problem.  There isn't much in either the ULS Logs or event logs to lead me anywhere, so does anyone have any ideas of where to go from here?

    Thanks.


    Dave
    Monday, September 13, 2010 5:26 PM

All replies

  • Additional Note.  I tried mapping another property (i.e. Sharepoint title to AD extentionattribute3) and it works perfectly fine.  I think at this point, the problem has something to do with the variable type being incompatible with each other when it comes to the PictureURL (String - OctetString) and thumbnailphoto (binary as listed in FIM, although AD shows it as OctetString).  Has anyone got this working with just simply setting export on the Picture property for users?

    Thanks again.. Dave


    Dave
    Tuesday, September 14, 2010 3:05 PM
  • I've got the same problem. Thumbnail export worked fine for a couple of times, but fails without an error.

    Thursday, February 03, 2011 9:10 AM
  • I too am having a problem exporting the photos to AD.  Sync is working.  The SPS_MV_OctetString_PicutreURL type is undefined in FIM?  I can't define it and there is no way to create an octetstring type.  Driving me Crazy!!

    Edit to update that not only is it not populating the AD ThumbNailPhoto Attribute - it is clearing it.  So if I have an AD Thumbnailphoto, when I sync, it clears the attribute.

    Thursday, April 14, 2011 11:47 PM
  • I've got the same issue. I see that this post is old, but I don't see any answers.

    Also, I am running the Decumber CU on my Farm with other export attributes working fine.

    Thursday, May 05, 2011 10:45 PM
  • Hi,

    It worked on my farm till I applied April 2011 CU. Now I'm facing the same as you guys. I did not applied any updates before.

    Everything is success, importing OK, UPS OK, everything seems to be ok, just picture is empty.  


    Tomas


    Tomas Paulas MCP,MCSA,MCSA-Messaging

     

    Update : During MOSSDATA import I see my PictureURl being deleted. Old value is octet stream, but new value is empty.

    Wednesday, June 15, 2011 2:37 PM
  • Hi

     

    Hi I have same issue thumbnailphoto is not Exporting to AD here is my scenario

     

     

     

    Full synchronization

    Incremental Synchronization

    New user add photo to profile

    Sync to AD without problem

    Not sync to AD

    User Delete his photo and upload another photo to profile

    Deletes the existing  AD thumnailphoto changes not applied

    Deletes the existing  AD thumnailphoto changes not applied

    Other imports

    Works fine

    Works fine

     

    Please anyone solved this issue

    Radika


    • Edited by Radika Tuesday, January 31, 2012 8:31 AM
    Tuesday, January 31, 2012 6:47 AM
  •  

    Hi

    finally got an answer since we use alternate access mapping for my site IIS need to know the mapping URL

    1. Checked IIS log of mysite, found there is no request sent to IIS when incremental sync. But full sync have requests
    2. Checked From Profile DB, found the Picture URL of the user is correct:
    3. Collect FIM log during incremental sync, found FIM is using host name to access Mysite and they failed with 401
    4. Test to directly open the URL http://<Mysite >/User Photos/Profile Pictures/<X>_LThumb.jpg in browser. Failed with 3 pop-up window.
    5. Open registry to disable loop back check on this site:
      1. Click Start, click Run, type regedit, and then click OK.
      2. In Registry Editor, locate and then click the following registry key: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa\MSV1_0
      3. Right-click MSV1_0, point to New, and then click Multi-String Value.
      4. Type BackConnectionHostNames, and then press ENTER.
      5. Right-click BackConnectionHostNames, and then click Modify.
      6. In the Value data box, type the My site <host name >
      7. Quit Registry Editor, and then restart the IISAdmin service.

    Hope this will help others

    Radika

    Thursday, February 16, 2012 8:06 AM
  • I have this issue pretty much every three months...cant' figure it out...eventually things start importing back into AD then it breaks again.  It really sucks this feature is way too fragile.  I am trying your suggestion but looks like I need to reboot?  I never am sure if I need to reboot after making these changes...
    Wednesday, May 30, 2012 5:13 AM
  • Hi

    restart the IIS by 'IISRESET' command. no need to reboot the machine ..

    Tuesday, June 12, 2012 11:39 AM