locked
IE - Do you want to open or save this file

    Question

  • I have searched everywhere on how to disable that annoying prompt... 

        DO YOU WANT TO OPEN OR SAVE THIS FILE

    Typically you would hope to see the ticker box to uncheck the always ask question. But it's not there.. 

    I have a sharepoint forms site where users open an infopath XML file(s) and it continuously opens that prompt up every time you open a file. When you open 5-10 of them up at a time it is a bit annoying.. Its like do you really want to open up the file you just clicking on?

    We don't need a double opt in here ppl! Any help in this madness would be greatly appreciated!

    Thanks
    Jack!
    Wednesday, August 06, 2008 1:05 PM

Answers

  • Jack,
    This has nothing to do with Sharepoint and it is easy fix.

    Open any folder with Windows Explorer or open My Computer, and then click on Tools in the menu bar and subsequently Folder Options in the drop down menu. Alternatively, go to Control Panel and select Folder Options.

    In the Folder Options dialog, select File Types tab. This tab lists every file type associated with Windows and may take a while to open.

    Locate and highlight (select) the file type or extension that you want to revert back the file download behavior to ask for open or save confirmation and stop the automatic opening or saving of downloaded file.
    Click on Advanced button. You have to log on or login on user account with Administrator or Power User privileges to use this function.
    In the Edit File Type window, clear (untick) the Confirm open after download check box.

    Click OK when done.
    Repeat the procedure for other filetype and ext that you want to change back to normal default.

    Regards

    Ivan Bondy - MCPD, MCDBA, MCSA, MCTS - Sharepoint consultant
    • Proposed as answer by Ivan Bondy Wednesday, August 06, 2008 3:53 PM
    • Edited by Ivan Bondy Wednesday, August 06, 2008 3:54 PM spelling
    • Marked as answer by Lionel Chen - MSFT Friday, August 08, 2008 3:30 AM
    Wednesday, August 06, 2008 3:53 PM

All replies

  • Jack,
    This has nothing to do with Sharepoint and it is easy fix.

    Open any folder with Windows Explorer or open My Computer, and then click on Tools in the menu bar and subsequently Folder Options in the drop down menu. Alternatively, go to Control Panel and select Folder Options.

    In the Folder Options dialog, select File Types tab. This tab lists every file type associated with Windows and may take a while to open.

    Locate and highlight (select) the file type or extension that you want to revert back the file download behavior to ask for open or save confirmation and stop the automatic opening or saving of downloaded file.
    Click on Advanced button. You have to log on or login on user account with Administrator or Power User privileges to use this function.
    In the Edit File Type window, clear (untick) the Confirm open after download check box.

    Click OK when done.
    Repeat the procedure for other filetype and ext that you want to change back to normal default.

    Regards

    Ivan Bondy - MCPD, MCDBA, MCSA, MCTS - Sharepoint consultant
    • Proposed as answer by Ivan Bondy Wednesday, August 06, 2008 3:53 PM
    • Edited by Ivan Bondy Wednesday, August 06, 2008 3:54 PM spelling
    • Marked as answer by Lionel Chen - MSFT Friday, August 08, 2008 3:30 AM
    Wednesday, August 06, 2008 3:53 PM
  • An interesting variation is that it works as expected (no prompt) for InfoPath XSN files, like this:
    createNewDocumentWithProgID('http:\u002f\u002fmy.formserver.com\u002fFormServerTemplates\u002fCMIM.xsn', 'http:\u002f\u002fmy.formserver.com\u002fCMIM\u002fCMIMForms','SharePoint.OpenXMLDocuments', true)

    , but not for existing Infopath XML files:

    http://my.formserver.com/CMIM/CMIMForms/CMIM2211.xml?Options=DisableSave&OpenIn=PreferClient&Action=na
    /bac
    Friday, February 26, 2010 2:29 PM
  • Try setting InfoPath as the default program for XML files. This can be done via Internet Explorer | Programs | Set Programs | Associate a file type or protocol with a program.

    The next time you are prompted to open \ save a infopath form there will be a check box at the bottom. Uncheck to supress the dialog.

    Monday, January 24, 2011 9:31 PM