none
Unrecognized attribute 'type'.

    Question

  • Hi there, hope someone can help me as I'm in a bit of a pickle...

     

    we rebooted our sharepoint server today, 2003 running MOSS 2007.

     

    we were just doing standard windows update installs and it installed .net framework 2 and 3 updates.

     

    after the reboot we get this error when trying toi access sharepoint.

     

    Server Error in '/' Application.

    Configuration Error

    Description: An error occurred during the processing of a configuration file required to service this request. Please review the specific error details below and modify your configuration file appropriately.

    Parser Error Message: Unrecognized attribute 'type'.

    Source Error:

    Line 14:       <section name="BlobCache" type="System.Configuration.SingleTagSectionHandler, System, Version=1.0.5000.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" />
    Line 15:     </sectionGroup>
    Line 16:     <sectionGroup name="System.Workflow.ComponentModel.WorkflowCompiler" type="System.Workflow.ComponentModel.Compiler.WorkflowCompilerConfigurationSectionGroup, System.Workflow.ComponentModel, Version=3.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35">
    Line 17:       <section name="authorizedTypes" type="System.Workflow.ComponentModel.Compiler.AuthorizedTypesSectionHandler, System.Workflow.ComponentModel, Version=3.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" />
    Line 18:     </sectionGroup>

    Source File: C:\Inetpub\wwwroot\wss\VirtualDirectories\80\web.config    Line: 16


    Version Information: Microsoft .NET Framework Version:1.1.4322.2407; ASP.NET Version:1.1.4322.2407

     

     

    I've tried downloading the latest workflow components, re-running the configuration wizard, restoring IIS, but so far, no joy

    Sad

     

    so our entire sharepoint site is down, which we use for call logging and everything..

     

    can anyone help?

     

    any ideas?

     

    ...

     

    Wednesday, January 23, 2008 11:00 PM

Answers

  • Solved, thanks Paul Smile

     

    We removed the offending lines from the web.config file and it fell over on another line instead 

     

    Something to do with the site map.

     

    So we googled the error and found that it could be caused by running the website under the wrong version of asp, so we checked IIS and sure enough all the sharepoint sites were running under asp v1, once we reset them to asp v2 everything worked.

     

    So somehow when the windows update installed sp1 for .net 2 and 3 it reset the asp version in IIS, weird???

     

    But we wouldnt have spotted it without your idea Paul, so cheers Smile

     

    Rob.

    Thursday, January 24, 2008 2:14 AM

All replies

  • I haven't seen this before, but as a quick work-around with an eye toward trying to get the system minimally functional, if I were your shoes, I'd make a backup of that .config file and then remove the type attribute since it doesn't want see that there.

     

    Even if that works, I doubt it would be the end of the story though.

     

    I'd probably call MS.

     

    --Paul Galvin, Conchango
      RSS @ http://feeds.feedburner.com/PaulGalvinsSharepointSpace
      Web site @ http://paulgalvin.spaces.live.com

     

    Thursday, January 24, 2008 1:11 AM
  • Solved, thanks Paul Smile

     

    We removed the offending lines from the web.config file and it fell over on another line instead 

     

    Something to do with the site map.

     

    So we googled the error and found that it could be caused by running the website under the wrong version of asp, so we checked IIS and sure enough all the sharepoint sites were running under asp v1, once we reset them to asp v2 everything worked.

     

    So somehow when the windows update installed sp1 for .net 2 and 3 it reset the asp version in IIS, weird???

     

    But we wouldnt have spotted it without your idea Paul, so cheers Smile

     

    Rob.

    Thursday, January 24, 2008 2:14 AM
  •  It was very useful. Solved my problem just in 5 mins time. Thank you very much once again.

    Regards
    Satheesh Palaniswamy
    Wednesday, July 23, 2008 4:54 AM
  • Thanks!! That was exactly what happened to me.  There was about 10 minutes of pure terror until I found this post.
    Tuesday, February 24, 2009 9:36 PM
  • Hi all,

    Had the exact problem: This is what I saw.

    1. Started installing VS 2008 on a MOSS VPC, opened up the litwaredemo home page and got the config error.

    2. Reinstalled .NET 2.0 by running aspnet_regiis -i

    Reinstallating the framework seems to fix the problem.

    Thanks!

    • Proposed as answer by Deepak Raghavan Wednesday, May 13, 2009 2:31 AM
    • Unproposed as answer by Mike Walsh FIN Wednesday, May 13, 2009 3:36 AM
    • Proposed as answer by MikeOB-HP Thursday, June 11, 2009 6:37 AM
    Wednesday, May 13, 2009 2:30 AM
  • Hi all,

    We ran the .NET 3.5 SP1 installer recently on our SharePoint farm and got exactly the same issue as outlined in the first post. Thanks to this topic I checked the ASP.NET Version setting on each of our SharePoint sites and sure enough these had all been set back to 1.1.4322. Simply re-setting these to 2.0.50727 and restarting the site immediately fixed the issue.

    I did NOT have to re-install the .NET framework in order to get this working again.

    Thanks for the initial posts!
    Tuesday, July 28, 2009 8:29 AM
  • We had this problem this morning after installing the asp.net service pack - which failed, but this is another issue.  ASP.NET 2.0 framework had become corrupt after doign this and therefore running aspnet_regiss -i worked a treat.

    Thanks,
    Monday, September 07, 2009 8:12 AM
  • Many Thanks for this post.

    Version Information: Microsoft .NET Framework Version:1.1.4322.2407; ASP.NET Version:1.1.4322.2407

    shows the problem

    aspnet_regiss -i  after backing up web.config was the repair that worked for me.

    Friday, April 23, 2010 4:05 PM
  • Changing ASP version back to 2.0 solved our issue.  Thanks!!!!
    Saturday, December 17, 2011 4:03 PM
  • Fixed me too.

    1. Stopped all IIS services

    2. Properties of each service, ASP.NET tab, changed dropdown from 1.1 to 2.0

    3. Restart services

    Thanks All!


    Steve

    Thursday, June 07, 2012 1:35 PM
  • Hi all,

    We ran the .NET 3.5 SP1 installer recently on our SharePoint farm and got exactly the same issue as outlined in the first post. Thanks to this topic I checked the ASP.NET Version setting on each of our SharePoint sites and sure enough these had all been set back to 1.1.4322. Simply re-setting these to 2.0.50727 and restarting the site immediately fixed the issue.

    I did NOT have to re-install the .NET framework in order to get this working again.

    Thanks for the initial posts!

    Having this exact issue but setting our site to V2 and restarting IIS gives me a blank page and the error 'An unxepected error has occurred." when trying to access the default.aspx page.

    I can still login to the administration page on port 1528.

    Any ideas?

    Thanks

    Pete

    Thursday, September 27, 2012 3:59 PM