none
sharepoint Designer 2010 Custom Item Form Takes up entire screen

    Question

  • Hello,

    Sharepoint Designer 2010 Custom Item Form Takes up entire screen. I'd like this form to be the approximate size of the normal Default Item Form. I created the form using the "Display" option for the specific list.

    Can someone tell me where this setting is, and what value I should use to change it?

    Thanks.


    John

    Thursday, July 05, 2012 6:20 PM

Answers

  • Hi John,

    I am unable to reproduce your problem. I had created a custom new aspx list form, remove some columns from the form and make it as default new form, or custom the form in InfoPath, but both of them will display in modal window without changing other settings. Could you tell us how you customized the list form or any customizations have made in list view page?

    To make a hyperlink to open in modal window, we need to make it like this:

    <a onclick="javascript:NewItem2(event, "http://Target URL address");javascript:return false;" href="#" >Open in modal window </a>

    As a workaround, we can use JavaScript to overwrite the onclick function of the create new item hyperlink and use the NewItem2(event,”URL”) function instead. Or create a new standard view to test if it will open is modal window to avoid any customizations in your view page has affected this behavior.

    Let me know if you have any question.

    Thanks & Regards,
    Emir


    Emir Liu

    TechNet Community Support

    Friday, July 06, 2012 9:48 AM