locked
HTTP Error 503. The service is unavailable

    Question

  • Hi,

    We are no longer able to access ANY of our Sharepoint sites running on a Windows 2008 Server SP2.

    In IE we recieve this error message:

    "Service Unavailable

    HTTP Error 503. The service is unavailable

    "

    The system event log contains this Warning (trying to access SP Central Adm.):

    "WAS, eventid 5139, A listener channel for protocol 'http' in worker process '6440' serving application pool 'SharePoint Central Administration v3' reported a listener channel failure. The data field contains the error number."

    And a little later this Error:

    "WAS, eventid 5002,

    Application pool 'SharePoint Central Administration v3' is being automatically disabled due to a series of failures in the process(es) serving that application pool."

     

    Can anyone help - please.

    Tuesday, September 22, 2009 10:50 AM

Answers

  • TRoennow,

     

    There are two reasons which may cause this issue:

    1.         IP V6 is enabled

    Please check that if you have enabled Internet Protocol version (TCP/IP v6). If yes, please disable it.

    2.         Use dedicated WFE for crawl.

    On your web front end machine, go to Central Administration à “Operation” à “Services on server” à “Office SharePoint Server Search à disable the button “Dedicated web front end for crawling”

    After the configuration, reset IIS.

     

    Hope this helps.

     

    Lu Zou

    • Marked as answer by Lu Zou-MSFT Friday, September 25, 2009 1:53 AM
    Wednesday, September 23, 2009 6:40 AM
  • Hi,

    The server was a DC before MOSS was installed.

    I have now de- and reinstalled the Central Adm Site using SP Configuration Wizard - that solved the problem.

    Thanks anyway.
    • Marked as answer by TRoennow Thursday, September 24, 2009 6:12 AM
    Thursday, September 24, 2009 6:12 AM

All replies

  • The App Pool is shutting down because it encountered errors.  Most likely this is because the account you are using will not authenticate.  If you are using a domain account make sure that it is unlocked and valid.  You may want to reenter the password info in the app pool settings.

    SharePoint Developer | Administrator | Evangelist -- Twitter -- Blog - http://nextconnect.blogspot.com
    Tuesday, September 22, 2009 11:44 PM
  • Did the following:
    - checked that the domian account is not locked
    - reset the password
    - reentered user/password for the app pool.

    This did not solve the problem.

    Still get 5 times event 5139 followed by 1 time event 5002 in the event log.

    Wednesday, September 23, 2009 6:12 AM
  • TRoennow,

     

    There are two reasons which may cause this issue:

    1.         IP V6 is enabled

    Please check that if you have enabled Internet Protocol version (TCP/IP v6). If yes, please disable it.

    2.         Use dedicated WFE for crawl.

    On your web front end machine, go to Central Administration à “Operation” à “Services on server” à “Office SharePoint Server Search à disable the button “Dedicated web front end for crawling”

    After the configuration, reset IIS.

     

    Hope this helps.

     

    Lu Zou

    • Marked as answer by Lu Zou-MSFT Friday, September 25, 2009 1:53 AM
    Wednesday, September 23, 2009 6:40 AM
  • I have now disabled IPv6  - new status is:

    1) trying to access SP Central Adm results in a completely empty page
    2) App Pool for Central Adm does not crash anymore
    3) some other SP sites can now be accessed

    Wednesday, September 23, 2009 2:01 PM
  • Hi,

     

    Thanks for your update. When Microsoft Office SharePoint Server 2007 was installed on the machine when the computer was promoted to a domain controller, the central administration web site will display a blank page. If so, I’m afraid you have to reinstall IIS and MOSS to resolve the issue.


    If this is not the issue, what's the version of IE used? If you are using IE 8, try to uninstall it and install IE 7 as it has complatibility issue with Windows Server 2008 and MOSS. You can also rerun post configuration wizard to see if it will help.

    Hope this helps.

     

    Lu Zou

    Thursday, September 24, 2009 3:23 AM
  • Hi,

    The server was a DC before MOSS was installed.

    I have now de- and reinstalled the Central Adm Site using SP Configuration Wizard - that solved the problem.

    Thanks anyway.
    • Marked as answer by TRoennow Thursday, September 24, 2009 6:12 AM
    Thursday, September 24, 2009 6:12 AM
  • IPv6 disabled. and IIS Reset. Its working for me.
    Wednesday, August 10, 2011 10:05 AM