none
SharePoint Designer not showing Master Pages or Page Layouts in Site Objects

    Question

  • First off, yes I have checked the "SharePoint Designer Permissions" both at Central admin and at the site collection level and all four boxes are checked in both places.

    What I am doing is this...

    I am standing up a new test farm. I have configured the Farm exactly the same way that the live environment was configured. I then take the content database and restore it over to the test environment using standard procedures to do so. However once I do that the Master Pages and Page Layouts are missing in SharePoint designer. Yes, I did check the site collection settings once again after the restoration of the content database.

    I can't for the life of me figure out what is causing this.....

    Thursday, August 16, 2012 12:24 AM

Answers

All replies

  • Hello,

    To be able to use SharePoint Designer and modify SharePoint content, an user needs to be a member of one of the following groups at the site collection level: Site Collection Administrators group, the Designers group, and Owners group.

    In addition, have you active the publishing feature in the site collection? If not, then active, then the page layouts will come back. Or you can use the All Files link and browse to the master pages and page layouts library (_catalogs > masterpage). Please check.

    More information:

    http://support.microsoft.com/kb/2592376

    http://www.myspblog.com/2011/04/page-layouts-missing-sharepoint.html

    Regards,

    Kelly Chen

    Friday, August 17, 2012 9:51 AM
  • Check setting in Central Admin.

    Go to Central Admin-> General Application Settings->SharePoint Designer(Configured SharePoint Designer Settings)->Select Enable Customizing Master Pages and Layouts Pages.

    Hope this will resolve the problem.

    NP


    Regards, --NP

    Thursday, October 10, 2013 3:30 PM