none
Remember My Password Doesn't Work

    Question

  • Greetings,

    First of all, I don't know if is an ie problem or a WSS problem, but here goes...

    Every time I log into WSS 3.0, I am asked to log in. I always click "Remember My Password", but it never does.

    Signing into a WSS site is unique in that a dialog box pops up. On all other web sites, I sign in using a web-based form. I probably have a hundred sites that I sign into, but this problem only occurs with WSS, which is why I'm thinking this might be a WSS problem.

    So, is there any reason that "Remember My Password" doesn't work?

    Thanks,
    Shane. 
    Windows Vista Home Premium SP2, Internet Explorer 8.0.6001.18783
    Monday, July 27, 2009 12:42 AM

Answers

  • First, please clear the cache file in IE.

    For IE6: http://www.microsoft.com/windows/ie/ie6/using/howto/customizing/clearcache.mspx

    For IE7/8: http://support.microsoft.com/kb/260897

     

    Second, you need to add your SharePoint site to Trusted Sites.

    1. In Internet Explorer, on the Tools menu, click Internet Options.
    2. On the Security tab, in the Select a Web content zone to specify its security settings box, click Trusted Sites / Local Intranet, and then click Sites.
    3. Clear the Require server verification (https:) for all sites in this zone check box.
    4. In the Add this Web site to the zone box, type the URL to your site, and then click Add.
    5. Click Close to close the Trusted Sites / Local Intranet dialog box.
    6. Click OK to close the Internet Options dialog box.

     

    Third, if you finish the previous 2 steps, IE still prompts for password. You need to double check the User Authentication in the Security Settings for your Trusted Sites / Local Intranet.

    1. In Internet Explorer, on the Tools menu, click Internet Options.
    2. On the Security tab, in the Select a Web content zone to specify its security settings box, click Trusted Sites / Local Intranet, and then click Custom Level.
    3. Scroll down to User Authentication, Logon, select the Automatic logon only in Intranet zone.
    4. Click Close to close the Trusted Sites / Local Intranet dialog box.
    5. Click OK to close the Internet Options dialog box.

     

    Forth, if all the above steps fails, you can try to re-install IE.

    For detailed steps, please visit: How to reinstall or repair Internet Explorer in Windows Vista and Windows XP (http://support.microsoft.com/kb/318378).


    Keep It Simple and Stupid.
    • Marked as answer by Chengyi Wu Thursday, July 30, 2009 7:33 AM
    Tuesday, July 28, 2009 1:30 AM

All replies

  • Have you added this site to Trusted Sites in your browser?
    Monday, July 27, 2009 1:09 AM
  • No. "Require server verification (https:) for all sites in this zone" is enabled. And I thought Trusted Sites were only for secure sites (https). My site is not secure (http).

    Thanks,
    Shane.
    Windows Vista Home Premium SP2, Internet Explorer 8.0.6001.18783
    Monday, July 27, 2009 1:18 AM
  • Sorry, I'm an idiot for not checking thoroughly and just shooting from the hip there. Blame the mid afternoon coffee cooldown. I meant "Local Intranet".
    Monday, July 27, 2009 10:23 PM
  • First, please clear the cache file in IE.

    For IE6: http://www.microsoft.com/windows/ie/ie6/using/howto/customizing/clearcache.mspx

    For IE7/8: http://support.microsoft.com/kb/260897

     

    Second, you need to add your SharePoint site to Trusted Sites.

    1. In Internet Explorer, on the Tools menu, click Internet Options.
    2. On the Security tab, in the Select a Web content zone to specify its security settings box, click Trusted Sites / Local Intranet, and then click Sites.
    3. Clear the Require server verification (https:) for all sites in this zone check box.
    4. In the Add this Web site to the zone box, type the URL to your site, and then click Add.
    5. Click Close to close the Trusted Sites / Local Intranet dialog box.
    6. Click OK to close the Internet Options dialog box.

     

    Third, if you finish the previous 2 steps, IE still prompts for password. You need to double check the User Authentication in the Security Settings for your Trusted Sites / Local Intranet.

    1. In Internet Explorer, on the Tools menu, click Internet Options.
    2. On the Security tab, in the Select a Web content zone to specify its security settings box, click Trusted Sites / Local Intranet, and then click Custom Level.
    3. Scroll down to User Authentication, Logon, select the Automatic logon only in Intranet zone.
    4. Click Close to close the Trusted Sites / Local Intranet dialog box.
    5. Click OK to close the Internet Options dialog box.

     

    Forth, if all the above steps fails, you can try to re-install IE.

    For detailed steps, please visit: How to reinstall or repair Internet Explorer in Windows Vista and Windows XP (http://support.microsoft.com/kb/318378).


    Keep It Simple and Stupid.
    • Marked as answer by Chengyi Wu Thursday, July 30, 2009 7:33 AM
    Tuesday, July 28, 2009 1:30 AM
  • Why are people marking their own posts as the answer? Shouldn't that be the job of the person who started the thread?

    Shane.
    Windows Vista Home Premium SP2, Internet Explorer 8.0.6001.18783
    Friday, July 31, 2009 4:36 AM
  • This solution worked perfectly. Thanks Chengyi.

    Wednesday, June 30, 2010 6:23 PM
  • The real question is: why does it work on every other browser in the world except for IE, and only in IE you have to jump through hoops per site before it keeps any password?

    Just sharing some frustration :)

    The answer is security. IE doesn't want to transmit your password automatically to the server, unless you trust it. So it does save the password, it just doesn't want to transmit it in case the server was compromised.

    The question here is, why not just open the login window with the password auto-filled, and let me press "ok". I would be very happy with just that.

    If it doesn't work, why bother showing the checkbox ? Show it only if the site is in the trusted list and if automatic login was selected.

    (Oh, and KISS means keep it simple, stupid. no & there)


    Regards, Shai Petel.

    Tuesday, August 27, 2013 3:53 PM