none
Sharepoint Foundation 2010 Central Administration Error 503

    Question

  • Hi,

    for some of our customers we are evaluating following setup in our testlab:

    • Small Business Server 2008 as primary domain controller
    • Windows 2008 R2 Foundation Server with Sharepoint foundation 2010 with SQL 2008 SP1 Express Database and member Server in the domain

    The Sharepoint is installed as a farm, due to the technet description of installing with least privileges. So far so good, but the problem is, that after installing and running the first configuration wizard, we can't enter the Central Administration, there is an 503 error, an the Application Pool in IIS stops. In the logs there we have the following error:

    Application pool SharePoint Central Administration v4 has been disabled. Windows Process Activation Service (WAS) encountered a failure when it started a worker process to serve the application pool.

    As already searched, this is often related to changed passwords. But the account, used, here is 100% correct, and has a valid password, that has not been changed. And the Sharepoint and Server installations are fresh installs.

    If I let the Sharepoint Services run as NetworkService, everything works fine on that machine, but we can't use Emailactivation on folders.

    So has anyone a straight forward idea, what else can be wrong?

    Thanks for your help

    Best regards
    Bernhard

     

     

    Monday, June 07, 2010 6:53 AM

Answers

  • I think, I got one step ahead.

    After some search to the topic of the application pool I found following suggestions:

    • aspnet_regiis -ga domain\username      for reregistering the user and setting the correct permissions
    • and too I found out, that in the domain, there is an IIS_WPG group (although on the local machine there is no corresponding group, but in the domain, because here in the lab it is an old migrated 2003 sbs domain) - and I manually added the farm account to the IIS_WPG group.

    And now, I can start the central administration without an error.

    Now I can start and see, if all functions are working properly.

    Cheers 

    • Marked as answer by AH-Solutions Thursday, June 10, 2010 6:35 AM
    Wednesday, June 09, 2010 2:31 PM

All replies

  • Hi Bernhard,

    I've just responded to your query on my blog which i will replicate here.  Out of curiosity, when you ran the SharePoint Configuration wizard, which account were you logged in as?

    Have you tried the suggestion from the following blog?

    http://blog.henryong.com/2010/04/24/sharepoint-2010-troubleshooting-503-service-unavailable-app-pool-shutdown/

    Cheers


    Blog: http://sharepointgeorge.com Twitter: http://twitter.com/georgekhalil
    Monday, June 07, 2010 8:56 PM
  • Hi George,

     

    I ran the Configuration Wizard as the sp_Admin account, which has on that server local administrator rights.

    I also have already found before the suggestions postet above, but it unfortunatly it changed nothing. Is it corret, that the application pool runs under sp_farm account? Has the farm account to get some special priviledges? Or should everything been set by the wizard correctly?

    As I have already seen this in the past sometimes with the earlier releases corresponding to the Small Business Server can it be an localization error? That some special user groups have the wrong name etc? (as ist was in german the problem first with the wsus on sbs).

    Cheers

    Tuesday, June 08, 2010 10:04 AM
  • Hi Bernhard,

    The sp_farm account should have been specified as the "database access account" during the configuration wizard which will in turn run as the application pool identity for the SharePoint Central Administration Web Site.  The wizard should handle all of the configuration for you.

    I have not setup SharePoint on SBS so cannot really confirm whether there are any known issues.

    Cheers


    Blog: http://sharepointgeorge.com Twitter: http://twitter.com/georgekhalil
    Tuesday, June 08, 2010 12:13 PM
  • Hi George,

    It is not setup directly on the SBS, the SBS acts in the domain as the primary domain controller. The Sharepoint itself is installed on a Windows 2008 R2 Foundation Server, which is a member server in the domain.

    Yes, sp_farm was specified as the "database access account" during the configuration, and it has all the correct rights in the database.

    Any further ideas what I can test?

     

    Cheers

     

     

    Tuesday, June 08, 2010 1:48 PM
  • If you see your AppPool in IIS, it's stopped ? Are your service account enabled or with a valid password?
    Romeo Pruno | Microsoft MVP SharePoint Server | http://www.nonaka.eu/feed
    Tuesday, June 08, 2010 7:08 PM
  • Yes, in the app pool it is stopped. I can start it, but as soon as central administration is tried to open, it ends itself with the WAS error message in the log, and in the app pool it is stopped again.

    And yes ,the service account is enabled and has a valid password. IIS has been restartet several times too.

    Tuesday, June 08, 2010 8:41 PM
  • Only one more question: other webapps that run with different services account works fine?
    Romeo Pruno | Microsoft MVP SharePoint Server | http://www.nonaka.eu/feed
    Wednesday, June 09, 2010 6:49 AM
  • There are no other webapps running on that server other than the sharepoint serivces.

    After your question I created a new webite, directly pointing to wwwroot. That site runs as long as the pool identity is ApplicationPoolIdentity. If I change the identity to let's say, sp_farm as above, I get an 503 error as soon as I try to open a specific web site.

    I looked up, if the account is in the local IIS_IUSRS group, and it is.

    So, what else user rights or local policy settings does the pool account need, to run properly for, lets say, the default web site?

     

    Wednesday, June 09, 2010 11:09 AM
  • I think, I got one step ahead.

    After some search to the topic of the application pool I found following suggestions:

    • aspnet_regiis -ga domain\username      for reregistering the user and setting the correct permissions
    • and too I found out, that in the domain, there is an IIS_WPG group (although on the local machine there is no corresponding group, but in the domain, because here in the lab it is an old migrated 2003 sbs domain) - and I manually added the farm account to the IIS_WPG group.

    And now, I can start the central administration without an error.

    Now I can start and see, if all functions are working properly.

    Cheers 

    • Marked as answer by AH-Solutions Thursday, June 10, 2010 6:35 AM
    Wednesday, June 09, 2010 2:31 PM
  • manually added the farm account to the IIS_WPG group solved my problem

    cheers :)

    • Proposed as answer by weiherd Thursday, August 02, 2012 2:27 AM
    Thursday, August 02, 2012 2:27 AM