none
How to prevent a property is searchable using FAST Search

    Question

  • I need to prevent users to search on some properties, for example "Arquivo". Below the settings for this property:

    PS C:\FASTSearch\bin> Get-FASTSearchMetadataCrawledProperty Arquivo
    
    CategoryName       : JDBC
    IsMappedToContents : True
    IsNameEnum         : False
    IsMultiValued      : False
    Name               : arquivo
    Propset            : 4cc9f20a-c782-4c48-8961-c5356f8dff89
    VariantType        : 31
    PS C:\FASTSearch\bin> Get-FASTSearchMetadataManagedProperty pArquivo
    
    Name                   : pArquivo
    Description            :
    Type                   : Text
    Queryable              : False
    StemmingEnabled        : True
    RefinementEnabled      : False
    MergeCrawledProperties : False
    SubstringEnabled       : False
    DeleteDisallowed       : False
    MappingDisallowed      : False
    MaxIndexSize           : 1024
    MaxResultSize          : 64
    DecimalPlaces          : 3
    SortableType           : SortableDisabled
    SummaryType            : Static

    This property is not part of FullTextIndex. 

    PS C:\FASTSearch\bin> Get-FASTSearchMetadataFullTextIndexMapping

    ImportanceLevel: : 7 ManagedProperty: : Title FullTextIndex: : content ImportanceLevel: : 1 ManagedProperty: : body FullTextIndex: : content ImportanceLevel: : 3 ManagedProperty: : description FullTextIndex: : content ImportanceLevel: : 8 ManagedProperty: : anchortext FullTextIndex: : content ImportanceLevel: : 8 ManagedProperty: : assocqueries FullTextIndex: : content ImportanceLevel: : 5 ManagedProperty: : Keywords FullTextIndex: : content ImportanceLevel: : 4 ManagedProperty: : urlkeywords FullTextIndex: : content ImportanceLevel: : 2 ManagedProperty: : Author FullTextIndex: : content ImportanceLevel: : 2 ManagedProperty: : CreatedBy FullTextIndex: : content ImportanceLevel: : 2 ManagedProperty: : ModifiedBy FullTextIndex: : content ImportanceLevel: : 5 ManagedProperty: : DocKeywords FullTextIndex: : content ImportanceLevel: : 7 ManagedProperty: : DocSubject FullTextIndex: : content ImportanceLevel: : 1 ManagedProperty: : crawledpropertiescontent FullTextIndex: : content ImportanceLevel: : 2 ManagedProperty: : MetadataAuthor FullTextIndex: : content ImportanceLevel: : 2 ManagedProperty: : WorkEmail FullTextIndex: : content ImportanceLevel: : 1 ManagedProperty: : bitext1 FullTextIndex: : content ImportanceLevel: : 2 ManagedProperty: : bitext2 FullTextIndex: : content ImportanceLevel: : 3 ManagedProperty: : bitext3 FullTextIndex: : content ImportanceLevel: : 4 ManagedProperty: : bitext4 FullTextIndex: : content ImportanceLevel: : 5 ManagedProperty: : bitext5 FullTextIndex: : content ImportanceLevel: : 6 ManagedProperty: : bitext6 FullTextIndex: : content ImportanceLevel: : 7 ManagedProperty: : bitext7 FullTextIndex: : content ImportanceLevel: : 1 ManagedProperty: : bipivottable FullTextIndex: : content ImportanceLevel: : 1 ManagedProperty: : bitable FullTextIndex: : content ImportanceLevel: : 1 ManagedProperty: : bichart FullTextIndex: : content ImportanceLevel: : 1 ManagedProperty: : biother FullTextIndex: : content ImportanceLevel: : 1 ManagedProperty: : bigauge FullTextIndex: : content ImportanceLevel: : 3 ManagedProperty: : pNome FullTextIndex: : content ImportanceLevel: : 1 ManagedProperty: : pNomePrograma FullTextIndex: : content ImportanceLevel: : 2 ManagedProperty: : pTaxonomia FullTextIndex: : content

    I already re-feed content and I keep getting to do research for this property.

    I forgot something ?

    Wednesday, April 04, 2012 6:17 PM

Answers

  • Hello,

    To exclude a property from being searchable, you may try:

    Go to Shared Services Administration: SharedServices1 > Search Settings > Metadata property mappings. then you will find the property in Managed Properties View  list.
    Then, delete the property.

    Best Regards,

    Sally Tang

    • Marked as answer by Marcelo de Sa Monday, April 09, 2012 8:06 PM
    Friday, April 06, 2012 6:18 AM
  • Hello,

    To exclude a property from being searchable, you may try:

    Go to Shared Services Administration: SharedServices1 > Search Settings > Metadata property mappings. then you will find the property in Managed Properties View  list.
    Then, delete the property.

    Best Regards,

    Sally Tang

    I can´t find "Shared Services Administration" option, but using the same idea I use Crawled Properties - JDBC page and unchecked "<label for="ctl00_PlaceHolderMain_ifsMappings_ctl00_chkIncludeMappings">Include values for this property in the search index</label>" option. It worked.

    There is a way to do this using power Shell ?

    Thanks

    • Marked as answer by Marcelo de Sa Monday, April 09, 2012 8:07 PM
    Monday, April 09, 2012 8:06 PM

All replies

  • Hello,

    To exclude a property from being searchable, you may try:

    Go to Shared Services Administration: SharedServices1 > Search Settings > Metadata property mappings. then you will find the property in Managed Properties View  list.
    Then, delete the property.

    Best Regards,

    Sally Tang

    • Marked as answer by Marcelo de Sa Monday, April 09, 2012 8:06 PM
    Friday, April 06, 2012 6:18 AM
  • Hello,

    To exclude a property from being searchable, you may try:

    Go to Shared Services Administration: SharedServices1 > Search Settings > Metadata property mappings. then you will find the property in Managed Properties View  list.
    Then, delete the property.

    Best Regards,

    Sally Tang

    I can´t find "Shared Services Administration" option, but using the same idea I use Crawled Properties - JDBC page and unchecked "<label for="ctl00_PlaceHolderMain_ifsMappings_ctl00_chkIncludeMappings">Include values for this property in the search index</label>" option. It worked.

    There is a way to do this using power Shell ?

    Thanks

    • Marked as answer by Marcelo de Sa Monday, April 09, 2012 8:07 PM
    Monday, April 09, 2012 8:06 PM
  • Hi,

    Look at this article:

    http://technet.microsoft.com/en-us/library/ff191232.aspx

    Set-FASTSearchMetadataManagedProperty -Name "<ManagedPropertyName>" -Queryable <QueryableFlag>

    <QueryableFlag> is a Boolean indicating whether the managed property should be queryable or not. Set to $true if the managed property should be queryable, if not set to $false.

    Best Regards,

    Sally Tang

    Tuesday, April 10, 2012 2:49 AM
  • Hi,

    Look at this article:

    http://technet.microsoft.com/en-us/library/ff191232.aspx

    Set-FASTSearchMetadataManagedProperty -Name "<ManagedPropertyName>" -Queryable <QueryableFlag>

    <QueryableFlag> is a Boolean indicating whether the managed property should be queryable or not. Set to $true if the managed property should be queryable, if not set to $false.

    Best Regards,

    Sally Tang

    In my first post I put the result of "Get-FASTSearchMetadataManagedProperty pArquivo" command. The result already shows Queryable = false before I use your solution to avoid this property to be searchable. Or using the administration something else is done or there is a bug using powershell command to create a managed property.

    Thanks for your help.

    Tuesday, April 10, 2012 3:14 PM