none
The SharePoint 2010 Timer service terminated unexpectedly

    Question

  • Hi all,

    Here is my senario: SharePoint 2010 foundation+SQL2012 SQL ( for reporting+content db) are installed on one VM box.

    SharePoint 2010 foundation server shows the following error: ( almost every 2 min )

    • The SharePoint 2010 Timer service terminated unexpectedly. It has done this 696 time(s). The following corrective action will be taken in 30000 milliseconds: Restart the service.  (Event ID: 7031, Source: Service Control Manager)

      The SharePoint 2010 Timer service terminated with service-specific error %%-2147467259. (Event ID:7024, Source: Service Control Manager)

      Application log:

      Login failed for user 'NT AUTHORITY\SYSTEM'. Reason: Failed to open the explicitly specified database 'model'. [CLIENT: xxx.xxx.xxx.xxx]

      Login failed for user 'NT AUTHORITY\SYSTEM'. Reason: Failed to open the explicitly specified database 'ReportingService'. [CLIENT: xxx.xxx.xxx.xx]

      Login failed for ............

      It failed login with all database.

      Does it mean I need to Clear the SharePoint Configuration Cache?  Please help and advice.

      Thanks


    rw


    • Edited by rosew Monday, October 28, 2013 5:52 PM
    Monday, October 28, 2013 5:50 PM

All replies

  • Hi, what level of access does NT AUTHORITY\SYSTEM have within SQL (e.g. is it a sysadmin, securityadmin, etc.)?

    Generally, you don't want to be leveraging SYSTEM for any configurable services as if there is a vulnerability in those services that allows a remote user to function as the account, that gives complete control to that remote user.


    Trevor Seward, MCC

    Follow or contact me at...
      

    This post is my own opinion and does not necessarily reflect the opinion or view of Microsoft, its employees, or other MVPs.

    Monday, October 28, 2013 6:15 PM
    Moderator
  • Hi,

    The SharePoint 2010 farm service account:

    DB creator

    Public

    SecurityAdmin

    Sysadmin

    I have no any clue what caused Timer job start and stop every 2 min. Please advice.

    Thanks


    rw

    Monday, October 28, 2013 6:24 PM
  • Can you check the ULS log to see if it is executing a job right before it fails?  Do you have any custom solutions that leverage the timer service (custom timer job or health analyzer rule, for example)?

    Trevor Seward, MCC

    Follow or contact me at...
      

    This post is my own opinion and does not necessarily reflect the opinion or view of Microsoft, its employees, or other MVPs.

    Monday, October 28, 2013 6:28 PM
    Moderator
  • is this account 'NT AUTHORITY\SYSTEM' is your farm admin?

    also check this one for event id 7024/7031

    http://www.information-worker.nl/2011/08/31/timer-service-terminated-unexpectedly-error-7031-7024/


    Thanks -WS SharePoint administrator, MCITP(SharePoint 2010, 2013) Blog: http://wscheema.com/blog *Please remember to mark your question as answered & Vote helpful,if this solves/helps your problem.*

    Monday, October 28, 2013 6:34 PM
  • Hi,

    Thank you so much for your quick feedback, yes, there was an upgrade running on Sept 16 When I checked the log, also , I found the cache file, which was stuck at same time. That is why I thought it could be cache issue. Any input?

    Thanks


    rw

    Monday, October 28, 2013 6:57 PM
  • If the Account (NT AUTHORITY\SYSTEM) has full access to the Databases then restart the SQL Server Service and check.

    Also make sure Timer Job Service configured with proper managed account. 

    If it's not helpful, then register new Managed Account and add the same in SQL Server with full access to all required databases. Then configure the Timer Job Service to execute with that managed account.


    Regards,
    Venkatesh R
    /* My Code Runs in Visual Studio 2010 */
    http://geekswithblogs.net/venkatx5/
    MCTS : SharePoint 2010, Application Development | MCPD : SharePoint 2010 Developer

    Monday, October 28, 2013 9:12 PM
  • Hi all,

    Thanks all input, but I tried to clean up configuration cache tonight, it does not work. Still get same error. Here it the logs:

    10/29/2013 22:06:57.76  w3wp.exe (0x0C98)                        0x07D8 SharePoint Foundation          General                        72nz Medium   Videntityinfo::isFreshToken reported failure. 53c8402a-6a18-42eb-a563-854edceca6da
    10/29/2013 22:06:58.00  w3wp.exe (0x0C98)                        0x07D8 SharePoint Foundation          General                        6y1a Medium   Creating reg key "SOFTWARE\Microsoft\Shared Tools\Web Server Extensions\All Ports" 53c8402a-6a18-42eb-a563-854edceca6da
    10/29/2013 22:06:58.09  w3wp.exe (0x0C98)                        0x07D8 SharePoint Foundation          Monitoring                     b4ly High     Leaving Monitored Scope (GetFileAndMetaInfo). Execution Time=1403.98542272831 53c8402a-6a18-42eb-a563-854edceca6da
    10/29/2013 22:06:58.09  w3wp.exe (0x0C98)                        0x07D8 SharePoint Foundation          Monitoring                     b4ly High     Leaving Monitored Scope (GetWebPartPageContent). Execution Time=1405.04868635539 53c8402a-6a18-42eb-a563-854edceca6da
    10/29/2013 22:06:59.31  w3wp.exe (0x0C98)                        0x07D8 SharePoint Foundation          Web Parts                      emt7 High     Error: Failure in loading assembly: Microsoft.SharePoint.Portal, Version=12.0.0.0, Culture=neutral, PublicKeyToken=71e9bce111e9429c 53c8402a-6a18-42eb-a563-854edceca6da
    10/29/2013 22:06:59.31  w3wp.exe (0x0C98)                        0x07D8 SharePoint Foundation          Web Parts                      emt7 High     Error: Failure in loading assembly: Microsoft.Office.Server.Search, Version=12.0.0.0, Culture=neutral, PublicKeyToken=71e9bce111e9429c 53c8402a-6a18-42eb-a563-854edceca6da
    10/29/2013 22:06:59.31  w3wp.exe (0x0C98)                        0x07D8 SharePoint Foundation          Web Parts                      emt7 High     Error: Failure in loading assembly: Microsoft.SharePoint.Portal, Version=12.0.0.0, Culture=neutral, PublicKeyToken=71e9bce111e9429c 53c8402a-6a18-42eb-a563-854edceca6da
    10/29/2013 22:06:59.31  w3wp.exe (0x0C98)                        0x07D8 SharePoint Foundation          Web Parts                      emt7 High     Error: Failure in loading assembly: Microsoft.SharePoint.Portal, Version=12.0.0.0, Culture=neutral, PublicKeyToken=71e9bce111e9429c 53c8402a-6a18-42eb-a563-854edceca6da
    10/29/2013 22:06:59.31  w3wp.exe (0x0C98)                        0x07D8 SharePoint Foundation          Web Parts                      emt7 High     Error: Failure in loading assembly: Microsoft.SharePoint.Portal, Version=12.0.0.0, Culture=neutral, PublicKeyToken=71e9bce111e9429c 53c8402a-6a18-42eb-a563-854edceca6da
    10/29/2013 22:06:59.31  w3wp.exe (0x0C98)                        0x07D8 SharePoint Foundation          Web Parts                      emt7 High     Error: Failure in loading assembly: Microsoft.SharePoint.Portal, Version=12.0.0.0, Culture=neutral, PublicKeyToken=71e9bce111e9429c 53c8402a-6a18-42eb-a563-854edceca6da
    10/29/2013 22:06:59.31  w3wp.exe (0x0C98)                        0x07D8 SharePoint Foundation          Web Parts                      emt7 High     Error: Failure in loading assembly: Microsoft.SharePoint.Portal, Version=12.0.0.0, Culture=neutral, PublicKeyToken=71e9bce111e9429c 53c8402a-6a18-42eb-a563-854edceca6da
    10/29/2013 22:06:59.31  w3wp.exe (0x0C98)                        0x07D8 SharePoint Foundation          Web Parts                      emt7 High     Error: Failure in loading assembly: Microsoft.Office.Server.Search, Version=12.0.0.0, Culture=neutral, PublicKeyToken=71e9bce111e9429c 53c8402a-6a18-42eb-a563-854edceca6da
    10/29/2013 22:07:00.68  w3wp.exe (0x0C98)                        0x07D8 SharePoint Foundation          Web Parts                  

    I checked my farm account in the database. it has all required permission. Please advice and help.

    Thanks


    rw

    Wednesday, October 30, 2013 2:59 AM
  • Version 12 is Office 2007.  Are you sure you don't have a timer job or some other process referencing SharePoint 2007 binaries?

    Trevor Seward, MCC

    Follow or contact me at...
      

    This post is my own opinion and does not necessarily reflect the opinion or view of Microsoft, its employees, or other MVPs.

    Wednesday, October 30, 2013 3:09 AM
    Moderator
  • this error is refereeing the 2007 version, Its bit confusing.

    Do you have any 2007 solution in your farm? https://spfnr.codeplex.com/discussions/218655

    also see this blog and may fix your issue.

    http://share-point.blogspot.com/2011/03/sp2010-sharepoint-timer-service-crashes.html


    Thanks -WS SharePoint administrator, MCITP(SharePoint 2010, 2013) Blog: http://wscheema.com/blog *Please remember to mark your question as answered & Vote helpful,if this solves/helps your problem.*

    Wednesday, October 30, 2013 4:02 AM
  • Hi all,

    Sorry, my sharepoint verion is foundation 2010.  Also, I got the following error after I did cleaning cache:

    SPTimerStore.InitializeTimer: SPConfigurationDatabase.RefreshCache returned SPConstants.InvalidRowVersion

    The timer service could not initialize its configuration, please check the configuration database.

    Please help.

    Thanks lot


    rw


    • Edited by rosew Wednesday, October 30, 2013 11:52 AM
    Wednesday, October 30, 2013 10:58 AM
  • did you try this one, its talking about the config thinghttp://share-point.blogspot.com/2011/03/sp2010-sharepoint-timer-service-crashes.html


    Thanks -WS SharePoint administrator, MCITP(SharePoint 2010, 2013) Blog: http://wscheema.com/blog *Please remember to mark your question as answered & Vote helpful,if this solves/helps your problem.*

    Wednesday, October 30, 2013 1:01 PM
  • Hi Hemendra,

    Sorry delay repond, it is not suitable my case. The issue is still there. And advice?

    Thanks

    Rose


    rw

    Monday, November 11, 2013 3:42 PM
  • what error you are seeing in the event log?

    also need a deeep dive and check the fusion log.

    http://soerennielsen.wordpress.com/2009/01/14/fixing-the-timer-service-when-everything-breaks-down/


    Please remember to mark your question as answered &Vote helpful,if this solves/helps your problem. ****************************************************************************************** Thanks -WS MCITP(SharePoint 2010, 2013) Blog: http://wscheema.com/blog


    Monday, November 11, 2013 4:32 PM