none
SharePoint OpenDocuments Class Add-on IE9

    Question

  • Over the weekend I was troubleshooting a users computer that is having a problem opening Microsoft Office documents in SharePoint. I noticed that the SharePoint add ons for IE9 were not present on the domain accounts. For instance the domain admin account. But when I logged in as local administrator you could see those add-ons present and when I would access the SharePoint site everything worked fine. Has anyone had this issue before and can you please help me?

    Thank you,

    Ryan

    Monday, November 11, 2013 3:05 PM

All replies

  • Hi,

    According to your post, my understanding is that SharePoint OpenDocuments Class Add-on for IE9 were not present on the domain accounts.

    I try to reproduce the issue, however the sharepoint add-ons worked well in my environment. No matter I log in as the domain accounts  or log in as the local administrator, I can see those add-ons present and when I access the SharePoint site everything work fine.

    You need to enable it in Internet Explorer when you log in as the domain accounts  with the following steps:

    1. Click Tools
    2. Go to Manage Add-ons
    3. In the Show box, click All add-ons
    4. In the Name column, click SharePoint OpenDocumentsClass, click Enable.

    But if the SharePoint OpenDocuments Class isn’t listed in the collection of add-ons on your machine, you can try to fix it with the following steps. Cause it’s possible that the add-on does exist somewhere but that it wasn’t updated when recent Office upgrades were installed on your computer.

    1. From the Start menu, click Control Panel, and then click Programs.
    2. On the Control Panel Programs page, click Programs and Features.
    3. Scroll down the list of installed programs, select Microsoft Office, and then click Change.
    4. In the Change dialog, click Repair and then click Continue.

    Little interaction is required from you until the repair operation is complete. At that time, you might need to reboot your computer so the changes can take effect.

    When your computer finishes rebooting, go back into Internet Explorer and repeat the procedure for enabling the add-on.

    More information:

    SharePoint 2007 or 2010: Office Documents open ReadOnly from SharePoint site: http://support.microsoft.com/kb/2018958

    Best Regards,

    Linda Li


    Linda Li
    TechNet Community Support




    Tuesday, November 12, 2013 3:28 AM
    Moderator
  • Lindali,

    I tried this over the weekend and attempted again and still not luck. The add-on is not appearing in IE on the domain account. 

    Thanks,

    Ryan

    Tuesday, November 12, 2013 2:06 PM