none
Content Organizer - Drop Off Library - everything Unique Permissions?

    Question

  • I am uploading files to the drop-off library using both a bulk upload program I have created myself, as well as manually through the user interface.   In both cases, when I upload the document to the "End destination library" but don't specify the metadata it needs, it correctly moves the document to the Drop Off library.

    However it always sets unique permissions to those files?  How do I change this?   Or how do I add to the list of people it assigns to by default.  Rule Managers?  Right now I'm getting an error adding rule managers so can't test that...

    Thank you in advance.
    Susan H

    Tuesday, June 07, 2011 4:59 PM

Answers

  • OK Just so everyone knows who may search on this - I called in a Microsoft Support ticket on this.  After 2 days on and off of research, the end result is:  This is not a bug, this is expected behavior.  Yes, the documents that don't match any rules DO get unique permissions.  Only the user that uploads it and the System Administrator can get at the documents.

    I also found another thread via the same: http://social.msdn.microsoft.com/Forums/en/sharepoint2010general/thread/fd83b41c-6918-4729-96b4-99f8067256b2

    Right now Microsoft is researching to see if we can change who gets set as the default permissions, but we don't think so.  I'll update this thread if we have any further information.

    Reason:  This document is considered a "Draft" document and should not be accessable by anyone except those with full permissions.  In my experience, this has to be not only full owners, but actually Site Collection Administrators (I will check that again).


    UPDATE:  OK it turns out that if you ADD RULE MANAGERS in Site Actions --> Site Settings --> Content Organizer Settings, then _after that_ when anyone uploads a document that doesn't meet the rules, the document still does get Unique permissions, but those users you've added as Rule Managers will be added to the list of permissions for that document.

    Note: In our testing, in order to be added to the Rule Managers without the thing throwing a Nasty Error, you had to add the user _individually_ to the site, giving them direct "Full Control" permissions.  It appeared from our testing that just because a user was a Site Collection Admin, even though they should have full rights, we still needed to add them directly to the site in order to get them in as a Rule Manager.

    • Marked as answer by Seven M Thursday, June 16, 2011 7:31 AM
    • Edited by Susanh Friday, June 17, 2011 7:06 PM More Information to Answer
    Wednesday, June 15, 2011 1:11 AM

All replies

  • Hi,

    By default, all the new items will inhret permissions from parent.

    So, please check if you have any custom features to change the permissions for the new items.

    http://technet.microsoft.com/en-us/library/cc262778.aspx#section3

    Regards,

    Seven

    Thursday, June 09, 2011 8:56 AM
  • Thank you for the reply.  My program that I'm using to upload the documents don't touch permissions, but maybe it's the way I'm doing it....  I will research further.  What is strange though is even when I upload through the browser, it auto-breaks interitance.  I have only one custom feature is installed, and that is an Email event handler.

    Anyway thanks for the link.  If/when I figure it out, I will post here for others to search on.

    Friday, June 10, 2011 8:27 PM
  • OK Just so everyone knows who may search on this - I called in a Microsoft Support ticket on this.  After 2 days on and off of research, the end result is:  This is not a bug, this is expected behavior.  Yes, the documents that don't match any rules DO get unique permissions.  Only the user that uploads it and the System Administrator can get at the documents.

    I also found another thread via the same: http://social.msdn.microsoft.com/Forums/en/sharepoint2010general/thread/fd83b41c-6918-4729-96b4-99f8067256b2

    Right now Microsoft is researching to see if we can change who gets set as the default permissions, but we don't think so.  I'll update this thread if we have any further information.

    Reason:  This document is considered a "Draft" document and should not be accessable by anyone except those with full permissions.  In my experience, this has to be not only full owners, but actually Site Collection Administrators (I will check that again).


    UPDATE:  OK it turns out that if you ADD RULE MANAGERS in Site Actions --> Site Settings --> Content Organizer Settings, then _after that_ when anyone uploads a document that doesn't meet the rules, the document still does get Unique permissions, but those users you've added as Rule Managers will be added to the list of permissions for that document.

    Note: In our testing, in order to be added to the Rule Managers without the thing throwing a Nasty Error, you had to add the user _individually_ to the site, giving them direct "Full Control" permissions.  It appeared from our testing that just because a user was a Site Collection Admin, even though they should have full rights, we still needed to add them directly to the site in order to get them in as a Rule Manager.

    • Marked as answer by Seven M Thursday, June 16, 2011 7:31 AM
    • Edited by Susanh Friday, June 17, 2011 7:06 PM More Information to Answer
    Wednesday, June 15, 2011 1:11 AM