none
Server farm products missing locally - add server

    Question

  • Hi,

    i have 1 app server and 1 web server. now i am installing 2nd web server. setup run successfully on 2nd server. when i run configuration wizard got following screen :

    pls tell how do i fix and continue with psconfiguration wizard. thanks


    iffi

    Tuesday, April 10, 2012 4:47 AM

Answers

  • It definately seems as though you've added some "later" to the new server that wasn't in the original servers.  By doing so, you've now upgraded your database to a newer version of SharePoint than your original web and app servers are expecting.  You need to compare the patches and hotfixes between the old and new servers.

    Paul Turner http://redmanta.co.uk/blog Twitter: @RedMantaUK MCTS:WSS,MOSS,2010 MCITP:2010.
    Please remember to click "Mark As Answer" if a post solves your problem or "Vote As Helpful" if it was useful.

    • Marked as answer by Shimin Huang Friday, April 20, 2012 7:23 AM
    Tuesday, April 10, 2012 7:46 AM
  • Iffi,

    Are you getting "upgrade required" on your older web server and app server or the new web server? If it's the former then you may have upgraded your DB's by adding a later patch to your new web server and now need to run the config wizard on the other 2 servers.


    Paul Turner http://redmanta.co.uk/blog Twitter: @RedMantaUK MCTS:WSS,MOSS,2010 MCITP:2010.
    Please remember to click "Mark As Answer" if a post solves your problem or "Vote As Helpful" if it was useful.

    • Marked as answer by Shimin Huang Friday, April 20, 2012 7:23 AM
    Tuesday, April 10, 2012 7:30 AM
  • Iffi,

    A good place to start would be Control Panel, look at the currently installed programs and ensure "show updates" is enabled.  There are other methods available in this link. http://blogs.technet.com/b/patrick_heyde/archive/2010/08/30/sharepoint-2010-patching-upgrade-part-2-which-patch-level-build-level-is-installed-amp-what-s-their-history.aspx


    Paul Turner http://redmanta.co.uk/blog Twitter: @RedMantaUK MCTS:WSS,MOSS,2010 MCITP:2010.
    Please remember to click "Mark As Answer" if a post solves your problem or "Vote As Helpful" if it was useful.

    • Marked as answer by Shimin Huang Friday, April 20, 2012 7:23 AM
    Tuesday, April 10, 2012 7:52 AM
  • If it's a Windows patch it won't have an immeadiate effect on the issue you're trying to resolve but in the interest of making sure everything is the same you should try and get them to the same level.  Does nothing happen when you run the products and configuration wizard on each of the machines?

    Paul Turner http://redmanta.co.uk/blog Twitter: @RedMantaUK MCTS:WSS,MOSS,2010 MCITP:2010.
    Please remember to click "Mark As Answer" if a post solves your problem or "Vote As Helpful" if it was useful.

    • Marked as answer by Shimin Huang Friday, April 20, 2012 7:23 AM
    Tuesday, April 10, 2012 8:05 AM

All replies

  • Solution:

    How you install patches,hotfix,language packs etc.,in your first server like that you need installed the same component(hotfix,languagepacks etc) in the second server. and then run your configuration wizard.

    Regards

    Senthil

    Tuesday, April 10, 2012 4:56 AM
  • Hi,

    Firstly as the message says check for the following and make sure you have the exact versions of these installed on all servers.

    • Product SKU  (Server / Foundation)
    • Patch (Exact Version Number)
    • Language pack(s)

    Next, if the error persists, you can bypass the check through the following command. But do note that if there are inconsistencies and you bypass this check then you may face problems later during the operations of the farm. Ideal would be to try and install the patches seperately, make sure nothing is amiss and only as a last resort use the following configuration to complete the setup.

    psconfig -cmd installcheck -noinstallcheck


    -Sangeetha


    Tuesday, April 10, 2012 5:01 AM
  • Hi,

    i install all patached and installation and configuration wizard done. now i m getting "upgrade required" in status under servers in farm.

    i have already run configuration wizard.

    pls suggest what i have to do.

    thx.



    iffi

    Tuesday, April 10, 2012 7:12 AM
  • Iffi,

    Are you getting "upgrade required" on your older web server and app server or the new web server? If it's the former then you may have upgraded your DB's by adding a later patch to your new web server and now need to run the config wizard on the other 2 servers.


    Paul Turner http://redmanta.co.uk/blog Twitter: @RedMantaUK MCTS:WSS,MOSS,2010 MCITP:2010.
    Please remember to click "Mark As Answer" if a post solves your problem or "Vote As Helpful" if it was useful.

    • Marked as answer by Shimin Huang Friday, April 20, 2012 7:23 AM
    Tuesday, April 10, 2012 7:30 AM
  • Paul,

    I m getting "upgrade required" on older app server and new web server.

    i have install SP1 and june CU does need to run any specific command. Running configuration wizard not fix it.

    thx.


    iffi

    Tuesday, April 10, 2012 7:42 AM
  • It definately seems as though you've added some "later" to the new server that wasn't in the original servers.  By doing so, you've now upgraded your database to a newer version of SharePoint than your original web and app servers are expecting.  You need to compare the patches and hotfixes between the old and new servers.

    Paul Turner http://redmanta.co.uk/blog Twitter: @RedMantaUK MCTS:WSS,MOSS,2010 MCITP:2010.
    Please remember to click "Mark As Answer" if a post solves your problem or "Vote As Helpful" if it was useful.

    • Marked as answer by Shimin Huang Friday, April 20, 2012 7:23 AM
    Tuesday, April 10, 2012 7:46 AM
  • Hi,

    can u suggest me way to compare patch and hotfixes between old and new server.

    thx


    iffi

    Tuesday, April 10, 2012 7:48 AM
  • Iffi,

    A good place to start would be Control Panel, look at the currently installed programs and ensure "show updates" is enabled.  There are other methods available in this link. http://blogs.technet.com/b/patrick_heyde/archive/2010/08/30/sharepoint-2010-patching-upgrade-part-2-which-patch-level-build-level-is-installed-amp-what-s-their-history.aspx


    Paul Turner http://redmanta.co.uk/blog Twitter: @RedMantaUK MCTS:WSS,MOSS,2010 MCITP:2010.
    Please remember to click "Mark As Answer" if a post solves your problem or "Vote As Helpful" if it was useful.

    • Marked as answer by Shimin Huang Friday, April 20, 2012 7:23 AM
    Tuesday, April 10, 2012 7:52 AM
  • thanks.

    i m going through control panel to check patch status. initially i found sharepoint patches are same but one windows patch KB958488 is in old web server and not in new web server.

    should i install windows patch.

    also looking for article.  


    iffi

    Tuesday, April 10, 2012 8:00 AM
  • If it's a Windows patch it won't have an immeadiate effect on the issue you're trying to resolve but in the interest of making sure everything is the same you should try and get them to the same level.  Does nothing happen when you run the products and configuration wizard on each of the machines?

    Paul Turner http://redmanta.co.uk/blog Twitter: @RedMantaUK MCTS:WSS,MOSS,2010 MCITP:2010.
    Please remember to click "Mark As Answer" if a post solves your problem or "Vote As Helpful" if it was useful.

    • Marked as answer by Shimin Huang Friday, April 20, 2012 7:23 AM
    Tuesday, April 10, 2012 8:05 AM
  • Hi,

    one more patch has to install on new webserver that is TFS extension. let me install that and will update you.

    thx


    iffi

    Tuesday, April 10, 2012 9:11 AM