none
Custom Metadata as Search criteria

    Question

  • Hello,

    i created a custom Managed Userproperty (Hobby) and a managed Metadata Mapping within my Search Service Application.
    After that i performed a full crawl, but when i try to search for Hobbies, a get no results.
    When my Search criteria has to following Syntax it works: Hobby:"Fotography"

    Any ideas, why i don't get any results for my Search criteria without the Column-Prefix?

    Thank you.
    Markus

    Monday, February 27, 2012 4:21 PM

All replies

  • As you said Hobby is a Search Criteria, which means their is no content with tagged with "Hobby"

    However the content is tagged with "Hobby:something" that;s why you are not finding anything.

    I recommend creating a custom results page and personalizing the refinement panel to optimize search by Hobby. Don't forget you can pass search filters in the url using k= a= u= r= v= and i might be forgetting some.


    Benjamin Niaulin Blog: http://bniaulin.wordpress.com

    Monday, February 27, 2012 7:20 PM
  • Hi Benjamin,

    thanks for your Answer, but i don't understand, what you mean.
    When i search in People for "Fotography", i don't get any result, but when i search for Hobby:"Fotography", i get a list of results.

    When i have to customise my result page, for what is the Metadata Mapping in Central Administration?
    I thought the Metadate Mapping includes this custom Field "Hobby" to the Search and any Search query will now include my custom Field.

    Thanks.
    Markus 


    • Edited by Flaty Wednesday, February 29, 2012 10:23 AM
    Wednesday, February 29, 2012 10:20 AM